Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Need help with EIGRP unequal cost routing

Reply
Thread Tools

Need help with EIGRP unequal cost routing

 
 
srp336@getcoactive.com
Guest
Posts: n/a
 
      02-22-2006
I've got a situation where I have a connection to a remote office over
2 T1s. The router on this end is a 4700 and the remote side is using a
2621. About 10 channels of one of the T1s is being used for voice.
Currently, the configuration looks like:

interface Serial1
bandwidth 192
ip unnumbered Ethernet0

interface Serial2
bandwidth 112
ip unnumbered Ethernet0

ip route x.y.z.0 255.255.255.0 Serial1
ip route x.y.z.0 255.255.255.0 Serial2

I was hoping that the bandwidth statements would help the router
distribute the packets between the two links accordingly, but it looks
like I was mistaken.

I'm trying to look into EIGRP unequal cost routing to fix this
situation I've been reading about it, but I'm not sure how to apply it
to this situation. Could someone come up with a sample configuration?

My goal here is to get maximum usage out of the available bandwidth. If
you look at the stats on that router, the maximum traffic going through
to the other location is only a little less than a full T1's worth.

Thank you!

 
Reply With Quote
 
 
 
 
Roman Nakhmanson
Guest
Posts: n/a
 
      02-22-2006
Hi
please post
sh ip eigrp top x.y.z.0
sh ip route x.y.z.0

do you have "variance x" in your eigrp config?

Roman Nakhmanson

 
Reply With Quote
 
 
 
 
Merv
Guest
Posts: n/a
 
      02-22-2006

The EIGRP routing process variance command is the magic knob that you
are looking for along with the traffic-share command.


Figure out the EIGRP metric for each unequal cost route between the two
locations.
By default, EIGRP uses bandwidth and delay to compute routing metrics -
thus it is a composite metric.

configure the actually bandwidth available for data traffic on each
interface. This is important for a couple of reasons - one it is used
in the metric calculation and it is also the value that would be
retrieved by SNMP to do bandwidth utilization calculations.

If you want to prefer one path over another, you should always change
the interface delay value.

Increase the variance <value> until the desired result is accomplished
that is both paths being used

router eigrp
variance 1 ! use equal cost routes only (defualt behaviour)
traffic-share balanced
exit


router eigrp
variance 2 ! use all routes which fall within 2 x minimum path
metric
traffic-share balanced
exit

 
Reply With Quote
 
srp336@getcoactive.com
Guest
Posts: n/a
 
      02-22-2006
I'm sorry if I was being unclear. The config I gave in my original post
was what we are using now. We aren't yet using EIGRP, so I really can't
post anything about a config that doesn't exist yet. I think I have
some understanding of how the variance command works, but I still don't
know how to apply it to my situation. Is the config shown in Merv's
post all that I need on both sides? Does EIGRP find it's neighbors
automatically? Maybe it's simpler than I expected. I'm continuing to
read...

 
Reply With Quote
 
Merv
Guest
Posts: n/a
 
      02-22-2006
Ahhhhh you were try to load balance with static routes - that will
not work unless
they are equal-cost


Configuring EIGRP is quite straight-forwarded.

First to answer your question about neighbour - yes EIGRP send hellos
to its neighbour at a regular interval. Hellos serve a number of
purposes - one to make sure certain parameters are the same between
both EIGRP neighbour - otherwise an adjacency will not be formed. An
adjacency must be formed before routing info will be exchanged. The
hellos are also used to detect loss of an neighbour.

So what you

router eigrp <AS number>
! since most orgs do not have an AS number usually the number is set
to 1 or 100

! all interfaces with IP address that fall into this range will run
EIGRP

network 10.0.0.0 0.255.255.255 ! as many network statements as
required

passive-interface < interface> ! interfaces on which EIGRP is not to
be used

eigrp log-neighbor-changes
exit

There are other eigrp commands but you probably do not need to be
concerend with them on T1 circuits

 
Reply With Quote
 
srp336@getcoactive.com
Guest
Posts: n/a
 
      02-22-2006
Now things are beginning to make sense. A couple of questions:

- we actually have an AS number on our side, because we use BGP with
our upstream providers. The other side doesn't have one. But we can
just use any arbitrary number here, correct?
- including the statement 'variance 2' should cover our situation
correct? The lower bandwithd link is more than half of the higher one.
- hello packets get sent out every interface unless listed in a
passive-interface command, correct?
- I can get the EIGRP stanzas set up on both routers before taking out
the static routes, to minimize downtime, correct?

Thanks for all of your help... it's greatly appreciated!

--Steve

 
Reply With Quote
 
Merv
Guest
Posts: n/a
 
      02-22-2006

http://www.velocityreviews.com/forums/(E-Mail Removed) wrote:
> Now things are beginning to make sense. A couple of questions:
>
> - we actually have an AS number on our side, because we use BGP with
> our upstream providers. The other side doesn't have one. But we can
> just use any arbitrary number here, correct?


correct but both sides must match for EIGRP

> - including the statement 'variance 2' should cover our situation
> correct? The lower bandwithd link is more than half of the higher one.


correct

> - hello packets get sent out every interface unless listed in a
> passive-interface command, correct?


correct.

For example you would want to make the link to you ISP passive
and also do not sent CDP to you ISP

> I can get the EIGRP stanzas set up on both routers before taking out
> the static routes, to minimize downtime, correct?


correct

static have an admin distance of 1 so they win over any other type
other than connected

Just so you know you can also "float" statics so they are used unless a
dynamic route is announced with a lower admin distance

ip route x.x.x.x m.m.m.m nh.nh.nh.nh 200 ! admin distance of 200 -
this is a floating static route

On of the things to memorize or have handy is admin distance values
see
http://www.cisco.com/en/US/tech/tk36...80094823.shtml

for example EIGRP internal routes have an admin distance of 90

 
Reply With Quote
 
Charlie Root
Guest
Posts: n/a
 
      02-23-2006
<(E-Mail Removed)> wrote in message
news:(E-Mail Removed) oups.com...
> I've got a situation where I have a connection to a remote office over
> 2 T1s. The router on this end is a 4700 and the remote side is using a
> 2621. About 10 channels of one of the T1s is being used for voice.
> Currently, the configuration looks like:


There seems to be some conspiracy between people with 2T1 lines one of which
has 10 channels dedicated for voice - this is second case of this kind
within past two weeks

Look at this document
http://www.cisco.com/en/US/tech/tk36...8009437d.shtml

Kind regards,
iLya


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
route behavior in equal cost path EIGRP Y0giBear Cisco 2 02-18-2008 10:52 PM
Which command displays the EIGRP cost to a specific destination lrantisi@gmail.com Cisco 1 09-06-2006 09:56 PM
EIGRP, Want to prevent any EIGRP traffic to a interface BG Cisco 3 02-09-2006 08:05 PM
Does OSPF do unequal cost multipath routing? jimbo Cisco 1 04-01-2005 11:53 PM
Problem - OSPF Unequal Cost Load Balancing (Sort of) NNTP Reader Cisco 7 07-25-2003 12:52 AM



Advertisments