Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > HTML > Size of the table element does not satisfy the explicit settings.

Reply
Thread Tools

Size of the table element does not satisfy the explicit settings.

 
 
showandbeshown@gmail.com
Guest
Posts: n/a
 
      12-06-2007
Hi,

I define a table element (<td></td>) with the explicit values of the
height and width (20x20 px). Than I put an image in this element which
has the same size:
<td rowspan="1" colspan="1" style="width: 20px; height: 20px;">
<img src="img/l_t.php?int_col=e1e1e1" width="20" height="20" alt="" /
></td>


As a result I see that my table element (<td></td>) is not square (as
it is supposed to be). The hight is larger than width so that under
the square image I see some empty space. Why it is happening? Does
anybody have any idea?

The whole XHTML code you can find on:
http://www.showandbeshown.com/headtail.php

Pleas help me if you can!
 
Reply With Quote
 
 
 
 
Jonathan N. Little
Guest
Posts: n/a
 
      12-06-2007
http://www.velocityreviews.com/forums/(E-Mail Removed) wrote:
> Hi,
>
> I define a table element (<td></td>) with the explicit values of the
> height and width (20x20 px). Than I put an image in this element which
> has the same size:
> <td rowspan="1" colspan="1" style="width: 20px; height: 20px;">
> <img src="img/l_t.php?int_col=e1e1e1" width="20" height="20" alt="" /
>> </td>

>
> As a result I see that my table element (<td></td>) is not square (as
> it is supposed to be). The hight is larger than width so that under
> the square image I see some empty space. Why it is happening? Does
> anybody have any idea?
>
> The whole XHTML code you can find on:
> http://www.showandbeshown.com/headtail.php


Add

td img { display: block; }

to your stylesheet should fix your problem... images are inline by
default...


--
Take care,

Jonathan
-------------------
LITTLE WORKS STUDIO
http://www.LittleWorksStudio.com
 
Reply With Quote
 
 
 
 
showandbeshown@gmail.com
Guest
Posts: n/a
 
      12-06-2007
>
> Add
>
> td img { display: block; }
>
> to your stylesheet should fix your problem... images are inline by
> default...
>

Grate! It helps! Thanks a lot!
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ColGroup for a table element gets lost when the table element is made visible/invisible TS ASP .Net 5 08-16-2007 11:26 AM
Explicit instantiation of STL vector demands explicit instantiation of all the templates it using internally. krunalbauskar@gmail.com C++ 1 12-25-2006 03:51 PM
What's the difference betwwen explicit instantiaion and explicit specialization? Andy C++ 5 01-30-2005 11:46 PM
Is explicit template qualification required for explicit delete? J.T. Conklin C++ 1 08-11-2004 02:06 AM
Form validator problem. built in controls do not satisfy validation requirement. Girish ASP .Net Web Controls 0 01-22-2004 02:34 AM



Advertisments