Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > DSL Circuits

Reply
Thread Tools

DSL Circuits

 
 
Steve Ray
Guest
Posts: n/a
 
      11-06-2007
Guys

We have to set up a new DSL circuit for one of our customers. We've
deployed a C1800 onsite.

I'm having problems finding out how to set the interface up as well as
encapsulation needed

Does anyone have a worked exampled that they would be happy to share to help
me understand how I setup the ATM0 interface along with all other settings

Many thanks

 
Reply With Quote
 
 
 
 
Zub
Guest
Posts: n/a
 
      11-06-2007
On Nov 6, 9:10 am, "Steve Ray" <(E-Mail Removed)> wrote:
> Guys
>
> We have to set up a new DSL circuit for one of our customers. We've
> deployed a C1800 onsite.
>
> I'm having problems finding out how to set the interface up as well as
> encapsulation needed
>
> Does anyone have a worked exampled that they would be happy to share to help
> me understand how I setup the ATM0 interface along with all other settings
>
> Many thanks


Steve,

I've been sending out 800 routers for home usage in many different
countries and the first thing i'd recommend is to do a 'sh ip int br'
and see if the atm0 interface has come up up.

First if you could provide the type of DSL (ADSL/ADSL2/SDSL/etc) and
the vci/vpi id be more than happy to help with an example config

 
Reply With Quote
 
 
 
 
Steve Ray
Guest
Posts: n/a
 
      11-06-2007
Hi

I need to reply in chunks as I don't have the 1800 on site with me. its at a
remote site

I did notice the when I forced the ATM0 interface up from "Admin down" it
stayed as "Down/Down"

We are using ADSL2 (here in the UK)

VCI/VPI ID - No idea sorry

Steve


"Zub" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) oups.com...
> On Nov 6, 9:10 am, "Steve Ray" <(E-Mail Removed)> wrote:
>> Guys
>>
>> We have to set up a new DSL circuit for one of our customers. We've
>> deployed a C1800 onsite.
>>
>> I'm having problems finding out how to set the interface up as well as
>> encapsulation needed
>>
>> Does anyone have a worked exampled that they would be happy to share to
>> help
>> me understand how I setup the ATM0 interface along with all other
>> settings
>>
>> Many thanks

>
> Steve,
>
> I've been sending out 800 routers for home usage in many different
> countries and the first thing i'd recommend is to do a 'sh ip int br'
> and see if the atm0 interface has come up up.
>
> First if you could provide the type of DSL (ADSL/ADSL2/SDSL/etc) and
> the vci/vpi id be more than happy to help with an example config
>


 
Reply With Quote
 
Zub
Guest
Posts: n/a
 
      11-06-2007
On Nov 6, 2:00 pm, "Steve Ray" <(E-Mail Removed)> wrote:
> Hi
>
> I need to reply in chunks as I don't have the 1800 on site with me. its at a
> remote site
>
> I did notice the when I forced the ATM0 interface up from "Admin down" it
> stayed as "Down/Down"
>
> We are using ADSL2 (here in the UK)
>
> VCI/VPI ID - No idea sorry
>
> Steve
>
> "Zub" <(E-Mail Removed)> wrote in message
>
> news:(E-Mail Removed) oups.com...
>
> > On Nov 6, 9:10 am, "Steve Ray" <(E-Mail Removed)> wrote:
> >> Guys

>
> >> We have to set up a new DSL circuit for one of our customers. We've
> >> deployed a C1800 onsite.

>
> >> I'm having problems finding out how to set the interface up as well as
> >> encapsulation needed

>
> >> Does anyone have a worked exampled that they would be happy to share to
> >> help
> >> me understand how I setup the ATM0 interface along with all other
> >> settings

>
> >> Many thanks

>
> > Steve,

>
> > I've been sending out 800 routers for home usage in many different
> > countries and the first thing i'd recommend is to do a 'sh ip int br'
> > and see if the atm0 interface has come up up.

>
> > First if you could provide the type of DSL (ADSL/ADSL2/SDSL/etc) and
> > the vci/vpi id be more than happy to help with an example config


I would advise you have a look at
http://www.cisco.com/en/US/products/...80093e48.shtml

If the ATM0 interface isnt coming up we have a lower level problem. It
could be that the device you are using cannot work with ADSL2. FYI UK
is usually VPI=0 VCI=38.

 
Reply With Quote
 
Darren Green
Guest
Posts: n/a
 
      11-09-2007
On 6 Nov, 14:00, "Steve Ray" <(E-Mail Removed)> wrote:
> Hi
>
> I need to reply in chunks as I don't have the 1800 on site with me. its at a
> remote site
>
> I did notice the when I forced the ATM0 interface up from "Admin down" it
> stayed as "Down/Down"
>
> We are using ADSL2 (here in the UK)
>
> VCI/VPI ID - No idea sorry
>
> Steve
>
> "Zub" <(E-Mail Removed)> wrote in message
>
> news:(E-Mail Removed) oups.com...
>
>
>
> > On Nov 6, 9:10 am, "Steve Ray" <(E-Mail Removed)> wrote:
> >> Guys

>
> >> We have to set up a new DSL circuit for one of our customers. We've
> >> deployed a C1800 onsite.

>
> >> I'm having problems finding out how to set the interface up as well as
> >> encapsulation needed

>
> >> Does anyone have a worked exampled that they would be happy to share to
> >> help
> >> me understand how I setup the ATM0 interface along with all other
> >> settings

>
> >> Many thanks

>
> > Steve,

>
> > I've been sending out 800 routers for home usage in many different
> > countries and the first thing i'd recommend is to do a 'sh ip int br'
> > and see if the atm0 interface has come up up.

>
> > First if you could provide the type of DSL (ADSL/ADSL2/SDSL/etc) and
> > the vci/vpi id be more than happy to help with an example config- Hide quoted text -

>
> - Show quoted text -


Hi Steve,

Did you ge this sorted.

Sounds like a physical issue to me but having installed hundreds of
ASDL boxes in the UK I would:

Swap out the microfilter (you get the odd faulty one)

Change the ADSL RJ11 cable (as above)

Plug an analogue phone into the ADSL microfilter, do you have a
dialtone. NB This won't indicate that there is DSL on the line but I
have attended loads of installations where the PSTN line wasn't
working. This being the case you won't be going anywere until the
Telco sort the line error.

If you have a moduler 1800 with a WIC-1ADSL, what do the ports on the
WIC card say. If it is say a fixed 1801 you won't have a WIC-1ADSL
card

The PVC is 0/38 unless it's Kingston Comms.

Typical Config:

!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
interface Dialer0
ip address negotiated
encapsulation ppp
dialer pool 1
no cdp enable
ppp authentication chap callin
ppp chap hostname XYZ@Your-ISP
ppp chap password
!

Regards

Darren

 
Reply With Quote
 
Steve Ray
Guest
Posts: n/a
 
      11-13-2007
Hi

I'm hoping to get this sorted in the next few days. The ISP that put the
circuits in has not been overly helpful so I sent them a slightly disgrutled
email today. I have a sample config from Cisco but need the user ID's as
per the config below

I'll keep you updated. Thanks for the help

Steve

"Darren Green" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) oups.com...
> On 6 Nov, 14:00, "Steve Ray" <(E-Mail Removed)> wrote:
>> Hi
>>
>> I need to reply in chunks as I don't have the 1800 on site with me. its
>> at a
>> remote site
>>
>> I did notice the when I forced the ATM0 interface up from "Admin down" it
>> stayed as "Down/Down"
>>
>> We are using ADSL2 (here in the UK)
>>
>> VCI/VPI ID - No idea sorry
>>
>> Steve
>>
>> "Zub" <(E-Mail Removed)> wrote in message
>>
>> news:(E-Mail Removed) oups.com...
>>
>>
>>
>> > On Nov 6, 9:10 am, "Steve Ray" <(E-Mail Removed)> wrote:
>> >> Guys

>>
>> >> We have to set up a new DSL circuit for one of our customers. We've
>> >> deployed a C1800 onsite.

>>
>> >> I'm having problems finding out how to set the interface up as well as
>> >> encapsulation needed

>>
>> >> Does anyone have a worked exampled that they would be happy to share
>> >> to
>> >> help
>> >> me understand how I setup the ATM0 interface along with all other
>> >> settings

>>
>> >> Many thanks

>>
>> > Steve,

>>
>> > I've been sending out 800 routers for home usage in many different
>> > countries and the first thing i'd recommend is to do a 'sh ip int br'
>> > and see if the atm0 interface has come up up.

>>
>> > First if you could provide the type of DSL (ADSL/ADSL2/SDSL/etc) and
>> > the vci/vpi id be more than happy to help with an example config- Hide
>> > quoted text -

>>
>> - Show quoted text -

>
> Hi Steve,
>
> Did you ge this sorted.
>
> Sounds like a physical issue to me but having installed hundreds of
> ASDL boxes in the UK I would:
>
> Swap out the microfilter (you get the odd faulty one)
>
> Change the ADSL RJ11 cable (as above)
>
> Plug an analogue phone into the ADSL microfilter, do you have a
> dialtone. NB This won't indicate that there is DSL on the line but I
> have attended loads of installations where the PSTN line wasn't
> working. This being the case you won't be going anywere until the
> Telco sort the line error.
>
> If you have a moduler 1800 with a WIC-1ADSL, what do the ports on the
> WIC card say. If it is say a fixed 1801 you won't have a WIC-1ADSL
> card
>
> The PVC is 0/38 unless it's Kingston Comms.
>
> Typical Config:
>
> !
> interface ATM0
> no ip address
> no atm ilmi-keepalive
> dsl operating-mode auto
> pvc 0/38
> encapsulation aal5mux ppp dialer
> dialer pool-member 1
> !
> interface Dialer0
> ip address negotiated
> encapsulation ppp
> dialer pool 1
> no cdp enable
> ppp authentication chap callin
> ppp chap hostname XYZ@Your-ISP
> ppp chap password
> !
>
> Regards
>
> Darren
>


 
Reply With Quote
 
Steve Ray
Guest
Posts: n/a
 
      11-20-2007
Guys

I could really do with some help over this issue please. I'm obviously way
out of my depth and am totally unable to see what I'm doing wrong

I've pasted the config below

At the minute I cannot get the unit to connect to the ISP/internet

Any help would be seriously appreciated


--START OF CONFIG

hostname 1831_Customer
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip cef
!
interface FastEthernet0
no ip address
speed 100
full-duplex
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
!
interface FastEthernet1
description *** Connection into Internal LAN
!
interface ATM0
bandwidth inherit
no ip address
ip mtu 1500
ip nat outside
atm bandwidth dynamic
no atm ilmi-keepalive
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
pvc 8/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
!
interface Vlan1
description *** Internal LAN
ip address 10.10.10.5 255.255.255.0
ip nat inside
!
interface Vlan2
no ip address
!
interface Dialer0
ip address ISP-GRANTED-IP-ADDRESS 255.255.255.252
ip mtu 128
encapsulation ppp
dialer pool 1
dialer string 5551234567 class User@ISP
dialer-group 1
ppp authentication chap User@ISP
!
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route ISP-GRANTED-IP-ADDRESS 255.255.255.252 Dialer0
!
no ip http server
!
access-list 1 permit any
dialer-list 1 protocol ip permit
!
control-plane
!
end
--END OF CONFIG

Steve

"Steve Ray" <(E-Mail Removed)> wrote in message
news:fhcii3$piq$(E-Mail Removed)...
> Hi
>
> I'm hoping to get this sorted in the next few days. The ISP that put the
> circuits in has not been overly helpful so I sent them a slightly
> disgrutled email today. I have a sample config from Cisco but need the
> user ID's as per the config below
>
> I'll keep you updated. Thanks for the help
>
> Steve
>
> "Darren Green" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed) oups.com...
>> On 6 Nov, 14:00, "Steve Ray" <(E-Mail Removed)> wrote:
>>> Hi
>>>
>>> I need to reply in chunks as I don't have the 1800 on site with me. its
>>> at a
>>> remote site
>>>
>>> I did notice the when I forced the ATM0 interface up from "Admin down"
>>> it
>>> stayed as "Down/Down"
>>>
>>> We are using ADSL2 (here in the UK)
>>>
>>> VCI/VPI ID - No idea sorry
>>>
>>> Steve
>>>
>>> "Zub" <(E-Mail Removed)> wrote in message
>>>
>>> news:(E-Mail Removed) oups.com...
>>>
>>>
>>>
>>> > On Nov 6, 9:10 am, "Steve Ray" <(E-Mail Removed)> wrote:
>>> >> Guys
>>>
>>> >> We have to set up a new DSL circuit for one of our customers. We've
>>> >> deployed a C1800 onsite.
>>>
>>> >> I'm having problems finding out how to set the interface up as well
>>> >> as
>>> >> encapsulation needed
>>>
>>> >> Does anyone have a worked exampled that they would be happy to share
>>> >> to
>>> >> help
>>> >> me understand how I setup the ATM0 interface along with all other
>>> >> settings
>>>
>>> >> Many thanks
>>>
>>> > Steve,
>>>
>>> > I've been sending out 800 routers for home usage in many different
>>> > countries and the first thing i'd recommend is to do a 'sh ip int br'
>>> > and see if the atm0 interface has come up up.
>>>
>>> > First if you could provide the type of DSL (ADSL/ADSL2/SDSL/etc) and
>>> > the vci/vpi id be more than happy to help with an example config- Hide
>>> > quoted text -
>>>
>>> - Show quoted text -

>>
>> Hi Steve,
>>
>> Did you ge this sorted.
>>
>> Sounds like a physical issue to me but having installed hundreds of
>> ASDL boxes in the UK I would:
>>
>> Swap out the microfilter (you get the odd faulty one)
>>
>> Change the ADSL RJ11 cable (as above)
>>
>> Plug an analogue phone into the ADSL microfilter, do you have a
>> dialtone. NB This won't indicate that there is DSL on the line but I
>> have attended loads of installations where the PSTN line wasn't
>> working. This being the case you won't be going anywere until the
>> Telco sort the line error.
>>
>> If you have a moduler 1800 with a WIC-1ADSL, what do the ports on the
>> WIC card say. If it is say a fixed 1801 you won't have a WIC-1ADSL
>> card
>>
>> The PVC is 0/38 unless it's Kingston Comms.
>>
>> Typical Config:
>>
>> !
>> interface ATM0
>> no ip address
>> no atm ilmi-keepalive
>> dsl operating-mode auto
>> pvc 0/38
>> encapsulation aal5mux ppp dialer
>> dialer pool-member 1
>> !
>> interface Dialer0
>> ip address negotiated
>> encapsulation ppp
>> dialer pool 1
>> no cdp enable
>> ppp authentication chap callin
>> ppp chap hostname XYZ@Your-ISP
>> ppp chap password
>> !
>>
>> Regards
>>
>> Darren
>>

>


 
Reply With Quote
 
Merv
Guest
Posts: n/a
 
      11-20-2007

Do you have the DSL setup infomation that is normally provided by ISP
-
PVC, PPP authentication method, usernmae, password, etc, etc


You need to troubleshoot each of the layers used for the DSL
connection.

Layer 1 - DSL physical connectivity to the Digital Subscriber Line
Access Multiplexer (DSLAM) of your ISP

Layer 2 - ATM connectivity and Point-to-Point Protocol over ATM
(PPPoA)

Layer 3 - IP


The normal config for PPP CHAP is

int dialer 1
ppp chap hostname <username>
ppp chap password <password>



Post the output of the following commands:


sh version


! check the status of the DSL interface

sh int atm 0


! test if PVC 0/38 is the one in use by sending OAM echo packets to
the ISP's DSLAM

ping atm interface atm 0 0 38 seg-loopback


show atm int atm0


debug atm errors

debug atm events

debug ppp negotiation

debug ppp authentication



! unplug and replug cable to phone jack



! after testing is completed

undebug all



 
Reply With Quote
 
alexd
Guest
Posts: n/a
 
      11-22-2007
Steve Ray wrote:

> !
> interface ATM0
> bandwidth inherit
> no ip address
> ip mtu 1500
> ip nat outside
> atm bandwidth dynamic
> no atm ilmi-keepalive
> pvc 8/35
> encapsulation aal5mux ppp dialer
> dialer pool-member 1
> !
> pvc 8/38
> encapsulation aal5mux ppp dialer
> dialer pool-member 1
> !
> dsl operating-mode auto
> !


I would expect a 'no shutdown' somewhere in there. For example, the 'CD'
light won't start flashing on an 877 until you put 'no shutdown' on the ATM
interface. Look at the "Layer 1 Issues" section of this document:

http://www.cisco.com/warp/public/794...ts.shtml#task1

The other thing is, who is the ISP for the DSL circuit? Are they a BT
Wholesale reseller [the majority are]? If that is the case, then your pvc
statements are wrong.

--
<http://ale.cx/> (AIM:troffasky) ((E-Mail Removed))
10:10:07 up 10 days, 22:48, 2 users, load average: 0.10, 0.20, 0.23
50,000 watts of funking power

 
Reply With Quote
 
alexd
Guest
Posts: n/a
 
      11-22-2007
alexd wrote:

> The other thing is, who is the ISP for the DSL circuit? Are they a BT
> Wholesale reseller [the majority are]? If that is the case, then your pvc
> statements are wrong.


This is taken from a router connected to a Griffin/BT IPStream circuit:

!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no atm ilmi-keepalive
dsl operating-mode auto
!
! Note that for whatever reason ["you know nothing about Cisco"]
! 'show run' doesn't show a 'no shutdown' here, but without it
! it just won't work!
!
interface ATM0.1 point-to-point
no ip redirects
no ip unreachables
no ip proxy-arp
no snmp trap link-status
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!

interface Dialer0
description $FW_OUTSIDE$
ip address outside_IP 255.255.255.240
ip access-group 101 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip nbar protocol-discovery
ip flow ingress
ip flow egress
ip nat outside
ip inspect cdp-inspect out
ip ips sdm_ips_rule in
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname username@domain
ppp chap password 7 crypted_password
ppp pap sent-username username@domain password 7 crypted_password
crypto map SDM_CMAP_1
!

Good luck!

--
<http://ale.cx/> (AIM:troffasky) ((E-Mail Removed))
15:22:05 up 11 days, 4:00, 2 users, load average: 0.63, 0.56, 0.35
50,000 watts of funking power

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is D-Link DSL-604T same as D-Link DSL-604+ ? norm Wireless Networking 6 11-18-2005 10:25 AM
an Intel PRO/DSL 2100 or Intel PRO/DSL 2200 Modem roberthob Computer Support 0 09-25-2005 05:51 PM
Multiple ISP's and DSL Circuits Question Adam Cisco 2 06-09-2005 08:30 PM
Anyone good at debugging DSL problems? (DSL: Defect: LOS LOF LCDf: retraining) Richard Antony Burton Cisco 3 12-18-2003 04:30 PM
Re: Cisco836 and German Telekom DSL (T-DSL) Daniel Meyer Cisco 1 07-25-2003 04:01 PM



Advertisments