Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Second ISP

Reply
Thread Tools

Second ISP

 
 
Bob Simon
Guest
Posts: n/a
 
      10-31-2007
If I add a second Internet feed and can't run BGP, how do I tell my
network to send traffic out via the new router?
 
Reply With Quote
 
 
 
 
Trendkill
Guest
Posts: n/a
 
      10-31-2007
On Oct 31, 8:28 am, Bob Simon <(E-Mail Removed)> wrote:
> If I add a second Internet feed and can't run BGP, how do I tell my
> network to send traffic out via the new router?


BGP is just your EGP. All you need to do to make sure traffic goes
out both links is ensure that whatever routing protocol is running
between your network/core and the internet routers has equal costs or
a preferred metric for whatever internet pipe you wish to use. Also
make sure that the second ISP router does not have a better default
route out the other internet router, and is sending traffic out that
it receives from the core. All of this can be done with show ip route
0.0.0.0 commands.

Balancing internet traffic back in is a completely different story as
I'm sure you are aware......

 
Reply With Quote
 
 
 
 
bobneworleans@yahoo.com
Guest
Posts: n/a
 
      10-31-2007
On Oct 31, 8:17 am, Trendkill <(E-Mail Removed)> wrote:
> On Oct 31, 8:28 am, Bob Simon <(E-Mail Removed)> wrote:
>
> > If I add a second Internet feed and can't run BGP, how do I tell my
> > network to send traffic out via the new router?

>
> BGP is just your EGP. All you need to do to make sure traffic goes
> out both links is ensure that whatever routing protocol is running
> between your network/core and the internet routers has equal costs or
> a preferred metric for whatever internet pipe you wish to use. Also
> make sure that the second ISP router does not have a better default
> route out the other internet router, and is sending traffic out that
> it receives from the core. All of this can be done with show ip route
> 0.0.0.0 commands.
>
> Balancing internet traffic back in is a completely different story as
> I'm sure you are aware......


Currently, the network is simple and there is only one way out so we
are only using static routes. This is a school and Internet access
via the school board is intermittent. We simply want to get cable or
DSL for an alternate path out and back. Does this require a routing
protocol? If so, will RIP do?

 
Reply With Quote
 
Trendkill
Guest
Posts: n/a
 
      10-31-2007
On Oct 31, 10:38 am, "(E-Mail Removed)"
<(E-Mail Removed)> wrote:
> On Oct 31, 8:17 am, Trendkill <(E-Mail Removed)> wrote:
>
>
>
> > On Oct 31, 8:28 am, Bob Simon <(E-Mail Removed)> wrote:

>
> > > If I add a second Internet feed and can't run BGP, how do I tell my
> > > network to send traffic out via the new router?

>
> > BGP is just your EGP. All you need to do to make sure traffic goes
> > out both links is ensure that whatever routing protocol is running
> > between your network/core and the internet routers has equal costs or
> > a preferred metric for whatever internet pipe you wish to use. Also
> > make sure that the second ISP router does not have a better default
> > route out the other internet router, and is sending traffic out that
> > it receives from the core. All of this can be done with show ip route
> > 0.0.0.0 commands.

>
> > Balancing internet traffic back in is a completely different story as
> > I'm sure you are aware......

>
> Currently, the network is simple and there is only one way out so we
> are only using static routes. This is a school and Internet access
> via the school board is intermittent. We simply want to get cable or
> DSL for an alternate path out and back. Does this require a routing
> protocol? If so, will RIP do?


Static will load balance, but if one fails, you may be SOL. You could
do statics and point to the interface rather than the next hop (if its
point to point), but I would recommend a routing protocol. Rip should
do multi-path load balancing.

 
Reply With Quote
 
response3
Guest
Posts: n/a
 
      11-01-2007
On Oct 31, 8:41 am, Trendkill <(E-Mail Removed)> wrote:
> On Oct 31, 10:38 am, "(E-Mail Removed)"
>
>
>
> <(E-Mail Removed)> wrote:
> > On Oct 31, 8:17 am, Trendkill <(E-Mail Removed)> wrote:

>
> > > On Oct 31, 8:28 am, Bob Simon <(E-Mail Removed)> wrote:

>
> > > > If I add a second Internet feed and can't run BGP, how do I tell my
> > > > network to send traffic out via the new router?

>
> > > BGP is just your EGP. All you need to do to make sure traffic goes
> > > out both links is ensure that whatever routing protocol is running
> > > between your network/core and the internet routers has equal costs or
> > > a preferred metric for whatever internet pipe you wish to use. Also
> > > make sure that the second ISP router does not have a better default
> > > route out the other internet router, and is sending traffic out that
> > > it receives from the core. All of this can be done with show ip route
> > > 0.0.0.0 commands.

>
> > > Balancing internet traffic back in is a completely different story as
> > > I'm sure you are aware......

>
> > Currently, the network is simple and there is only one way out so we
> > are only using static routes. This is a school and Internet access
> > via the school board is intermittent. We simply want to get cable or
> > DSL for an alternate path out and back. Does this require a routing
> > protocol? If so, will RIP do?

>
> Static will load balance, but if one fails, you may be SOL. You could
> do statics and point to the interface rather than the next hop (if its
> point to point), but I would recommend a routing protocol. Rip should
> do multi-path load balancing.


Here's a way to do it based on protocol:


! First setup object tracking to ping your ISP's routers.

ip sla 1
icmp-echo <ISP1 next hop IP>
timeout 1000
frequency 5
ip sla schedule 1 life forever start-time now
ip sla 2
icmp-echo <ISP2 next hop IP>
timeout 1000
frequency 5
ip sla schedule 1 life forever start-time now

! Then define your default routes. We're going to use ISP 2 as the
preferred default route, since
! it has a lower metric. If the tracking object goes down, it will
failover to ISP2.

ip route 0.0.0.0 0.0.0.0 <ISP1 next hop IP> 20 track 1
ip route 0.0.0.0 0.0.0.0 <ISP2 next hop IP> track 2

! Now create the ACL that will match traffic you want to route
differently than your default route.

ip access-list extended PBR
permit tcp 10.233.165.0 0.0.0.255 any eq smtp
permit tcp 10.233.165.0 0.0.0.255 any eq www

! Setup the route map to match anything in the ACL to be routed out
ISP1. If the ISP1 upstream router is down, it will failover to ISP2
(our normal default route).

route-map RULES permit 10
description Tracking object routing - PBR ACL for bypass
match ip address PBR
set ip next-hop verify-availability <ISP1 next hop IP> 1 track 1

! Lastly, you need to setup NAT according to the ISP that you're
routing traffic to. Optional: Use a deny statement if you have lan to
lan vpn's.

ip access-list extended nat_rule
deny ip 10.233.160.0 0.0.31.255 10.233.148.0 0.0.0.255
permit ip 10.233.165.0 0.0.0.255 any

! Now create the route map to NAT according to which interface the
traffic is leaving.

route-map NAT_MAP_ISP2 permit 10
description To nat outbound traffic to ISP address block
match ip address nat_rule
match interface fa0/1
!
route-map NAT_MAP_ISP1 permit 10
description To nat outbound traffic to ISP address block
match ip address nat_rule
match interface fa0/2

! Dont' forget to put ip nat outside statements on each of your
Internet facing interfaces and ip nat inside on your LAN interface.

 
Reply With Quote
 
Merv
Guest
Posts: n/a
 
      11-01-2007

If you are using NAT, then take a look at Cisco doc "IOS NAT Load-
balancing for Two ISP Connections"

http://cco.cisco.com/en/US/tech/tk64...s_configuratio...



 
Reply With Quote
 
Merv
Guest
Posts: n/a
 
      11-01-2007
On Nov 1, 5:02 am, Merv <(E-Mail Removed)> wrote:
> If you are using NAT, then take a look at Cisco doc "IOS NAT Load-
> balancing for Two ISP Connections"




http://www.cisco.com/en/US/tech/tk64...808d2b72.shtml


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
strip all but second second line from bottom and then strip that!!!! yelipolok Perl Misc 4 01-27-2010 08:14 AM
How does typical ISP traffic shaping/bandwidth limiting work ? Do ISP's allow bursty traffic per second ? Skybuck Flying Cisco 0 01-19-2006 08:50 PM
Is it possible to open a file at a second ISP? Jerry Perl Misc 9 12-07-2005 05:20 PM
Network Diagnostics pings old ISP =?Utf-8?B?Q2hyaXN0aW5l?= Wireless Networking 0 02-14-2005 06:21 PM
network and ISP Thomas Wireless Networking 2 12-18-2004 10:11 AM



Advertisments