Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > VHDL > Testbench's configuration problem

Reply
Thread Tools

Testbench's configuration problem

 
 
Olaf
Guest
Posts: n/a
 
      09-25-2007
Hi,

for my self written uart (learning by doing I wrote a testbench and
want to use configurations for the test cases:

------>8--------------------------
package uart_tb_pkg is
type wire_t is (loopback, stuck_high, stuck_low, random);
end package;
------>8--------------------------
....
use work.uart_tb_pkg.all;

entity TB_uart is
generic (
WIRE_TYPE : wire_t := loopback);
end entity;
------>8--------------------------
architecture testbench of TB_uart is
....
end architecture;
------>8--------------------------
library ieee;
use work.uart_tb_pkg.all;

entity TB_uart_Wrapper is
end entity;

architecture structure of TB_uart_Wrapper is
begin
TB : entity work.TB_uart(testbench);
end architecture;
------>8--------------------------
configuration tb_uart_loopback_cfg of TB_uart_Wrapper is
for structure
for TB : work.TB_uart(testbench) -- L356
use entity work.TB_uart(testbench)
generic map (WIRE_TYPE => loopback);
end for;
end for;
end configuration;
------>8--------------------------

But I get the error:

Error: ../vhdl/TB_uart.vhd(356): (vcom-1141) Identifier "tb_uart" does
not identify a component declaration.

each time I use configurations I got into trouble

Is this way possible? How to get it working using vhdl93?

Thanks,
Olaf
 
Reply With Quote
 
 
 
 
Mike Treseler
Guest
Posts: n/a
 
      09-25-2007
Olaf wrote:

> But I get the error:
>
> Error: ../vhdl/TB_uart.vhd(356): (vcom-1141) Identifier "tb_uart" does
> not identify a component declaration.


A direct instance cannot be configured.

> each time I use configurations I got into trouble


They are fussy. That is one reason I prefer generic options
for a testbench.

-- Mike Treseler
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Caught Exception: System.Configuration.ConfigurationErrorsException: An error occurred loading a configuration file: Request for the permission of type 'System.Security.Permissions.FileIOPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicK Mike ASP .Net 5 08-15-2007 08:57 AM
Enterprise Library exception: The configuration section securityCryptographyConfiguration is not defined in the current configuration for the AppDomain. Jess Chadwick ASP .Net 1 09-21-2006 09:18 AM
Configuration reverted to previous configuration after power loss ward@sciinc.com Cisco 0 03-03-2006 04:14 PM
Microsoft Configuration Block and Enterprise library configuration tool Mark ASP .Net 0 02-15-2006 11:27 PM
PEAP Configuration Woes - PEAP configuration help jester Cisco 1 12-20-2005 02:04 PM



Advertisments