Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > I'm having trouble setting up a simple routing using Cisco 2610

Reply
Thread Tools

I'm having trouble setting up a simple routing using Cisco 2610

 
 
bk2007 bk2007 is offline
Junior Member
Join Date: Aug 2007
Posts: 5
 
      08-29-2007
I'm trying to configure a Cisco 2610 router with two ethernet interfaces as a gateway router. I can ping and traceroute to the Internet from my router's telnet but can not ping or traceroute to Internet from my LAN. Please help - I've spent the past two days on this and can not figure out what I'm doing wrong. Thanks.

Here is my Cisco configuration:

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname dolphin
!
enable secret 5
enable password
!
ip subnet-zero
ip name-server 4.2.2.1
!
!
!
interface Ethernet0/0
description to-WAN
ip address 198.78.141.1 255.255.255.252
no ip directed-broadcast
!
interface Ethernet1/0
description to-LAN
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
!
line con 0
password
login
transport preferred none
transport input none
line aux 0
password
login
modem InOut
transport preferred none
transport input all
stopbits 1
flowcontrol hardware
line vty 0 4
password
login
transport preferred none
!
no scheduler allocate
end
 

Last edited by bk2007; 08-29-2007 at 08:59 AM..
Reply With Quote
 
 
 
 
hinka hinka is offline
Junior Member
Join Date: Jul 2006
Posts: 26
 
      08-29-2007
you need to enable NAT on the router

router(config)#
!
! Goto your "outside" interface and tell it how to NAT
interface Ethernetl0/0
ip nat outside
exit
!
! Goto your "inside" interface and tell it how to NAT
interface Ethernet1/0
ip nat inside
exit
!
! Build an Access-List to tell the router what subnets to block.
access-list 101 permit ip any any
!
! Tell the router to use the new Access-List and to NAT using PAT
ip nat inside source list 101 interface ethernet0/0 overload
exit
copy running-config startup-config
 
Reply With Quote
 
 
 
 
bk2007 bk2007 is offline
Junior Member
Join Date: Aug 2007
Posts: 5
 
      08-29-2007
Thank you very much - the problem is solved.

I'm just wondering, in the past when I set up T1 connection and configured the Serial0/0 for outside connection; I never had to setup nat to get the static route working. I just used:

ip route 0.0.0.0 0.0.0.0 Serial0/0

and traffic flowed from Ethernet0/0 to Serial0/0 automatically without having to specify nat.

Is this because when you configure a Serial port for outside connection, the router would automatically uses nat?

Again - thank you for your help.
 
Reply With Quote
 
hinka hinka is offline
Junior Member
Join Date: Jul 2006
Posts: 26
 
      08-30-2007
192.168.1.0/24 are private ip which is not routable on the internet..you need public ip to reach the internet..thats why you need NAT
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot ROM chip required to upgrade both a Cisco 2610 and a Cisco 2620 router to support 32 megs+ flash and more than 64 megs RAM Mike Rahl Cisco 1 06-14-2007 05:33 PM
Need Help setting up T1 on CISCO 2610 bramsey3 General Computer Support 0 08-11-2006 11:29 AM
Having trouble with simple Java midlet jaheem.hippock@gmail.com Java 0 02-12-2005 02:22 PM
Having trouble with our routing on three subnets. Fred Cisco 0 11-04-2004 04:19 PM
connecting a Cisco 2610 to a Cisco PIX Firewall paul Cisco 1 11-10-2003 04:48 PM



Advertisments