Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Datagrid blank on postback.

Reply
Thread Tools

Datagrid blank on postback.

 
 
SatishPasala
Guest
Posts: n/a
 
      08-08-2007
Hi

I tried all the things I know am out of ideas now. Can you guys help
me out with this?

I have 4 grids on a page with I load on the Page_Load event. One of
the grids has paging. When I move to different page on one of the
grids, all the other Grids loose data on on postback.

I am binding all the grids on the Page_Load event of the page the
grids are in for each postback.

Does any one have any idea what I am missing?

satish

 
Reply With Quote
 
 
 
 
David Wier
Guest
Posts: n/a
 
      08-08-2007
Which version of DotNet are you using?
Are you using custom paging?
If so, they're not using the same event handlers, are they?

David Wier
http://aspnet101.com
http://iWritePro.com - One click PDF, convert .doc/.rtf/.txt to HTML with no
bloated markup



"SatishPasala" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) ups.com...
> Hi
>
> I tried all the things I know am out of ideas now. Can you guys help
> me out with this?
>
> I have 4 grids on a page with I load on the Page_Load event. One of
> the grids has paging. When I move to different page on one of the
> grids, all the other Grids loose data on on postback.
>
> I am binding all the grids on the Page_Load event of the page the
> grids are in for each postback.
>
> Does any one have any idea what I am missing?
>
> satish
>



 
Reply With Quote
 
 
 
 
SatishPasala
Guest
Posts: n/a
 
      08-08-2007
I am using .NET 1.1. I am not using custom paging. I debugged through
the code.

I see the dataview is assigned to the datasource of the DataGrid and
BindData() method being called.

I dont see the data in the grid except for the headers. I also
confirmend that there is data in the dataview that is being assigned.

I am not able to pin point where the error is.

The datagrid is in a user control. If it makes any difference.

satish


On Aug 8, 5:14 pm, "David Wier" <(E-Mail Removed)>
wrote:
> Which version of DotNet are you using?
> Are you using custom paging?
> If so, they're not using the same event handlers, are they?
>
> David Wierhttp://aspnet101.comhttp://iWritePro.com- One click PDF, convert .doc/.rtf/.txt to HTML with no
> bloated markup
>
> "SatishPasala" <(E-Mail Removed)> wrote in message
>
> news:(E-Mail Removed) ups.com...
>
> > Hi

>
> > I tried all the things I know am out of ideas now. Can you guys help
> > me out with this?

>
> > I have 4 grids on a page with I load on the Page_Load event. One of
> > the grids has paging. When I move to different page on one of the
> > grids, all the other Grids loose data on on postback.

>
> > I am binding all the grids on the Page_Load event of the page the
> > grids are in for each postback.

>
> > Does any one have any idea what I am missing?

>
> > satish



 
Reply With Quote
 
David Wier
Guest
Posts: n/a
 
      08-08-2007
Since you're saying the DataGrid is in a User control, you have 4 user
controls on the page, each of which has a DataGrid in it, right?

Do the datagrids share any information with one another (do any of them rely
on one or more of the others)?

David Wier
http://aspnet101.com
http://iWritePro.com - One click PDF, convert .doc/.rtf/.txt to HTML with no
bloated markup


"SatishPasala" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) oups.com...
>I am using .NET 1.1. I am not using custom paging. I debugged through
> the code.
>
> I see the dataview is assigned to the datasource of the DataGrid and
> BindData() method being called.
>
> I dont see the data in the grid except for the headers. I also
> confirmend that there is data in the dataview that is being assigned.
>
> I am not able to pin point where the error is.
>
> The datagrid is in a user control. If it makes any difference.
>
> satish
>
>
> On Aug 8, 5:14 pm, "David Wier" <(E-Mail Removed)>
> wrote:
>> Which version of DotNet are you using?
>> Are you using custom paging?
>> If so, they're not using the same event handlers, are they?
>>
>> David Wierhttp://aspnet101.comhttp://iWritePro.com- One click PDF,
>> convert .doc/.rtf/.txt to HTML with no
>> bloated markup
>>
>> "SatishPasala" <(E-Mail Removed)> wrote in message
>>
>> news:(E-Mail Removed) ups.com...
>>
>> > Hi

>>
>> > I tried all the things I know am out of ideas now. Can you guys help
>> > me out with this?

>>
>> > I have 4 grids on a page with I load on the Page_Load event. One of
>> > the grids has paging. When I move to different page on one of the
>> > grids, all the other Grids loose data on on postback.

>>
>> > I am binding all the grids on the Page_Load event of the page the
>> > grids are in for each postback.

>>
>> > Does any one have any idea what I am missing?

>>
>> > satish

>
>



 
Reply With Quote
 
SatishPasala
Guest
Posts: n/a
 
      08-08-2007
All of them have different information from different sources. They
are independent grids and do not share any information. I have paging
enabled in one grid. That particular grid works fine when I page to
different pages. For the first time !IsPostBack all the grids display
data properly. They only go blank when I click on a different page on
the datagrid.

Studio 2003 has a tendency to remove the event registrations in
InitializeComponent() method. I checked this method too to make sure
the event registrations are present.

satish

On Aug 8, 5:47 pm, "David Wier" <(E-Mail Removed)>
wrote:
> Since you're saying the DataGrid is in a User control, you have 4 user
> controls on the page, each of which has a DataGrid in it, right?
>
> Do the datagrids share any information with one another (do any of them rely
> on one or more of the others)?
>
> David Wierhttp://aspnet101.comhttp://iWritePro.com- One click PDF, convert .doc/.rtf/.txt to HTML with no
> bloated markup
>
> "SatishPasala" <(E-Mail Removed)> wrote in message
>
> news:(E-Mail Removed) oups.com...
>
> >I am using .NET 1.1. I am not using custom paging. I debugged through
> > the code.

>
> > I see the dataview is assigned to the datasource of the DataGrid and
> > BindData() method being called.

>
> > I dont see the data in the grid except for the headers. I also
> > confirmend that there is data in the dataview that is being assigned.

>
> > I am not able to pin point where the error is.

>
> > The datagrid is in a user control. If it makes any difference.

>
> > satish

>
> > On Aug 8, 5:14 pm, "David Wier" <(E-Mail Removed)>
> > wrote:
> >> Which version of DotNet are you using?
> >> Are you using custom paging?
> >> If so, they're not using the same event handlers, are they?

>
> >> David Wierhttp://aspnet101.comhttp://iWritePro.com-One click PDF,
> >> convert .doc/.rtf/.txt to HTML with no
> >> bloated markup

>
> >> "SatishPasala" <(E-Mail Removed)> wrote in message

>
> >>news:(E-Mail Removed) roups.com...

>
> >> > Hi

>
> >> > I tried all the things I know am out of ideas now. Can you guys help
> >> > me out with this?

>
> >> > I have 4 grids on a page with I load on the Page_Load event. One of
> >> > the grids has paging. When I move to different page on one of the
> >> > grids, all the other Grids loose data on on postback.

>
> >> > I am binding all the grids on the Page_Load event of the page the
> >> > grids are in for each postback.

>
> >> > Does any one have any idea what I am missing?

>
> >> > satish



 
Reply With Quote
 
tomisarobot@gmail.com
Guest
Posts: n/a
 
      08-08-2007
your paging logic might be repeated?

So if you go to page 2 on AAA.aspx, then go to BBB.aspx the grid looks
for page 2 but only has page 1. happens when you use common session
variables. Try using a ViewState variable instead.

Just a guess.

 
Reply With Quote
 
SatishPasala
Guest
Posts: n/a
 
      08-09-2007
All the girds are on one page. Paging is referenced to datagrid
paging. I am loosing data on the postback.

satish

On Aug 8, 6:58 pm, (E-Mail Removed) wrote:
> your paging logic might be repeated?
>
> So if you go to page 2 on AAA.aspx, then go to BBB.aspx the grid looks
> for page 2 but only has page 1. happens when you use common session
> variables. Try using a ViewState variable instead.
>
> Just a guess.



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
blank CD-R and blank DVD-R not recognized by Vista 64 Ultimate =?Utf-8?B?R3JlZyBLaXJrcGF0cmljaw==?= Windows 64bit 13 11-07-2007 12:23 PM
plzz help me to add How a Blank row in a datagrid without using da =?Utf-8?B?YWo=?= ASP .Net 0 11-02-2004 03:17 PM
Add a blank row to DataGrid tshad ASP .Net 4 10-20-2004 07:15 PM
DataGrid going blank on edit Chris Brandsma ASP .Net 1 01-30-2004 08:53 PM



Advertisments