Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > VHDL > array-cam-compile problem

Reply
Thread Tools

array-cam-compile problem

 
 
menmas menmas is offline
Junior Member
Join Date: Jul 2007
Posts: 2
 
      07-26-2007
Aloha!
Sorry for my english!

I want to create a cam memory in vhdl.
I found a code that might helps but i have problem to compile this code in modelsim.

The Error message is the following:
"Unknown identifier: ram_array"

Do i need in modelsim extra parameters (couse of array) to compile the code?

Also Ive never used arrays in vhdl and I dont know much about it.If anybody could guide my I would appreciate it.

Here is a part of that code that troubles me
architecture cam256_a of cam256 is
type ram_arry is array (0 to 255) of std_logic_vector(7 downto 0);
signal tag :ram_array;
signal data :ram_array;
signal count: integer range 0 to 255;
begin
.....
end mcam
 
Reply With Quote
 
 
 
 
menmas menmas is offline
Junior Member
Join Date: Jul 2007
Posts: 2
 
      07-27-2007
Hallo!
anybody here?
I need help!!
 
Reply With Quote
 
 
 
 
scottcarl scottcarl is offline
Member
Join Date: May 2007
Location: USA
Posts: 51
 
      07-27-2007
typo --> ram_array vs. ram_arry

Scott
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem problem problem :( Need Help Mike ASP General 2 05-11-2004 08:36 AM



Advertisments