Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > release mode Compile error BC2014

Reply
Thread Tools

release mode Compile error BC2014

 
 
news.microsoft.com
Guest
Posts: n/a
 
      07-13-2007
I have an asp.net 2.0 project that when I change the build configuration to
release I get the following error:

Command line error BC2014: the value 'None' is invalid for option
'debug'.

If I go into the projects Advanced Compile Options and change the Generate
Debug Info dropdown from None to PDB-Only the error goes away. Can anyone
explain why I have to do this and what can I do to get the one option to
work on a asp.net project? It is causing problems because the common
project is shared with a VB project that gets an error on release mode
compile if it is set to pdb-only.

Thanks for your help.


 
Reply With Quote
 
 
 
 
Juan T. Llibre
Guest
Posts: n/a
 
      07-13-2007
Just add this entry to the web.config file :


<compilation debug="true" />



Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"news.microsoft.com" <(E-Mail Removed)> wrote in message news:(E-Mail Removed)...
>I have an asp.net 2.0 project that when I change the build configuration to release I get the following error:
>
> Command line error BC2014: the value 'None' is invalid for option 'debug'.
>
> If I go into the projects Advanced Compile Options and change the Generate Debug Info dropdown from None to PDB-Only
> the error goes away. Can anyone explain why I have to do this and what can I do to get the one option to work on a
> asp.net project? It is causing problems because the common project is shared with a VB project that gets an error on
> release mode compile if it is set to pdb-only.
>
> Thanks for your help.
>



 
Reply With Quote
 
 
 
 
nahid
Guest
Posts: n/a
 
      07-13-2007
On Jul 14, 12:20 am, "Juan T. Llibre" <(E-Mail Removed)>
wrote:
> Just add this entry to the web.config file :
>
> <compilation debug="true" />
>
> Juan T. Llibre, asp.net MVP
> asp.net faq :http://asp.net.do/faq/
> foros de asp.net, en espaņol :http://asp.net.do/foros/
> ======================================
>
>
>
> "news.microsoft.com" <(E-Mail Removed)> wrote in messagenews:(E-Mail Removed).. .
> >I have an asp.net 2.0 project that when I change the build configuration to release I get the following error:

>
> > Command line error BC2014: the value 'None' is invalid for option 'debug'.

>
> > If I go into the projects Advanced Compile Options and change the Generate Debug Info dropdown from None to PDB-Only
> > the error goes away. Can anyone explain why I have to do this and what can I do to get the one option to work on a
> > asp.net project? It is causing problems because the common project is shared with a VB project that gets an error on
> > release mode compile if it is set to pdb-only.

>
> > Thanks for your help.- Hide quoted text -

>
> - Show quoted text -


hai,
he try build in release mode better set
<compilation debug="false" />

nahid
http://nahidulkibria.blogspot.com/
http://www.kaz.com.bd

 
Reply With Quote
 
Juan T. Llibre
Guest
Posts: n/a
 
      07-13-2007
re:
!> he try build in release mode better set
!> <compilation debug="false" />

No. He said that when :

!> I change the build configuration to release

....the error occurs, therefore setting it to debug="true" should fix it.

Your suggestion, debug="false", is the same as setting the application
to release mode, so he would likely continue to get the same error as
whenhe manually sets it to "release" mode.





Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"nahid" <(E-Mail Removed)> wrote in message news:(E-Mail Removed) oups.com...
On Jul 14, 12:20 am, "Juan T. Llibre" <(E-Mail Removed)>
wrote:
> Just add this entry to the web.config file :
>
> <compilation debug="true" />
>
> Juan T. Llibre, asp.net MVP
> asp.net faq :http://asp.net.do/faq/
> foros de asp.net, en espaņol :http://asp.net.do/foros/
> ======================================
>
>
>
> "news.microsoft.com" <(E-Mail Removed)> wrote in messagenews:(E-Mail Removed).. .
> >I have an asp.net 2.0 project that when I change the build configuration to release I get the following error:

>
> > Command line error BC2014: the value 'None' is invalid for option 'debug'.

>
> > If I go into the projects Advanced Compile Options and change the Generate Debug Info dropdown from None to PDB-Only
> > the error goes away. Can anyone explain why I have to do this and what can I do to get the one option to work on a
> > asp.net project? It is causing problems because the common project is shared with a VB project that gets an error
> > on
> > release mode compile if it is set to pdb-only.

>
> > Thanks for your help.- Hide quoted text -

>
> - Show quoted text -


hai,
he try build in release mode better set
<compilation debug="false" />

nahid
http://nahidulkibria.blogspot.com/
http://www.kaz.com.bd


 
Reply With Quote
 
nahid
Guest
Posts: n/a
 
      07-13-2007
On Jul 14, 12:53 am, "Juan T. Llibre" <(E-Mail Removed)>
wrote:
> re:
> !> he try build in release mode better set
> !> <compilation debug="false" />
>
> No. He said that when :
>
> !> I change the build configuration to release
>
> ...the error occurs, therefore setting it to debug="true" should fix it.
>
> Your suggestion, debug="false", is the same as setting the application
> to release mode, so he would likely continue to get the same error as
> whenhe manually sets it to "release" mode.
>
> Juan T. Llibre, asp.net MVP
> asp.net faq :http://asp.net.do/faq/
> foros de asp.net, en espaņol :http://asp.net.do/foros/
> ======================================"nahid" <(E-Mail Removed)> wrote in messagenews:(E-Mail Removed) ooglegroups.com...
>
> On Jul 14, 12:20 am, "Juan T. Llibre" <(E-Mail Removed)>
> wrote:
>
>
>
>
>
> > Just add this entry to the web.config file :

>
> > <compilation debug="true" />

>
> > Juan T. Llibre, asp.net MVP
> > asp.net faq :http://asp.net.do/faq/
> > foros de asp.net, en espaņol :http://asp.net.do/foros/
> > ======================================

>
> > "news.microsoft.com" <(E-Mail Removed)> wrote in messagenews:(E-Mail Removed).. .
> > >I have an asp.net 2.0 project that when I change the build configuration to release I get the following error:

>
> > > Command line error BC2014: the value 'None' is invalid for option 'debug'.

>
> > > If I go into the projects Advanced Compile Options and change the Generate Debug Info dropdown from None to PDB-Only
> > > the error goes away. Can anyone explain why I have to do this and what can I do to get the one option to work on a
> > > asp.net project? It is causing problems because the common project is shared with a VB project that gets an error
> > > on
> > > release mode compile if it is set to pdb-only.

>
> > > Thanks for your help.- Hide quoted text -

>
> > - Show quoted text -

>
> hai,
> he try build in release mode better set
> <compilation debug="false" />
>
> nahidhttp://nahidulkibria.blogspot.com/http://www.kaz.com.bd- Hide quoted text -
>
> - Show quoted text -


well so what is basically main problem, say i'm not prefer set
<compilation debug="true" /> because of loss some performance

nahid
http://nahidulkibria.blogspot.com/
http://www.kaz.com.bd

 
Reply With Quote
 
Juan T. Llibre
Guest
Posts: n/a
 
      07-13-2007
re:
!> well so what is basically main problem, say i'm not prefer set
!> <compilation debug="true" /> because of loss some performance

True enough, but to resolve the *current* problem ( that the app won't run ),
the solution is get get the app working *first* and then *later* we worry about performance.



Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"nahid" <(E-Mail Removed)> wrote in message news:(E-Mail Removed) oups.com...
On Jul 14, 12:53 am, "Juan T. Llibre" <(E-Mail Removed)>
wrote:
> re:
> !> he try build in release mode better set
> !> <compilation debug="false" />
>
> No. He said that when :
>
> !> I change the build configuration to release
>
> ...the error occurs, therefore setting it to debug="true" should fix it.
>
> Your suggestion, debug="false", is the same as setting the application
> to release mode, so he would likely continue to get the same error as
> whenhe manually sets it to "release" mode.
>
> Juan T. Llibre, asp.net MVP
> asp.net faq :http://asp.net.do/faq/
> foros de asp.net, en espaņol :http://asp.net.do/foros/
> ======================================"nahid" <(E-Mail Removed)> wrote in
> messagenews:(E-Mail Removed) ooglegroups.com...
>
> On Jul 14, 12:20 am, "Juan T. Llibre" <(E-Mail Removed)>
> wrote:
>
>
>
>
>
> > Just add this entry to the web.config file :

>
> > <compilation debug="true" />

>
> > Juan T. Llibre, asp.net MVP
> > asp.net faq :http://asp.net.do/faq/
> > foros de asp.net, en espaņol :http://asp.net.do/foros/
> > ======================================

>
> > "news.microsoft.com" <(E-Mail Removed)> wrote in messagenews:(E-Mail Removed).. .
> > >I have an asp.net 2.0 project that when I change the build configuration to release I get the following error:

>
> > > Command line error BC2014: the value 'None' is invalid for option 'debug'.

>
> > > If I go into the projects Advanced Compile Options and change the Generate Debug Info dropdown from None to
> > > PDB-Only
> > > the error goes away. Can anyone explain why I have to do this and what can I do to get the one option to work on
> > > a
> > > asp.net project? It is causing problems because the common project is shared with a VB project that gets an error
> > > on
> > > release mode compile if it is set to pdb-only.

>
> > > Thanks for your help.- Hide quoted text -

>
> > - Show quoted text -

>
> hai,
> he try build in release mode better set
> <compilation debug="false" />
>
> nahidhttp://nahidulkibria.blogspot.com/http://www.kaz.com.bd- Hide quoted text -
>
> - Show quoted text -


well so what is basically main problem, say i'm not prefer set
<compilation debug="true" /> because of loss some performance

nahid
http://nahidulkibria.blogspot.com/
http://www.kaz.com.bd


 
Reply With Quote
 
news.microsoft.com
Guest
Posts: n/a
 
      07-13-2007
I already have in my web config file <compilation defaultLanguage="vb"
debug="true"/>
and I am getting this message if the debug is set to true or false in the
web.config file.



"Juan T. Llibre" <(E-Mail Removed)> wrote in message
news:%(E-Mail Removed)...
> re:
> !> well so what is basically main problem, say i'm not prefer set
> !> <compilation debug="true" /> because of loss some performance
>
> True enough, but to resolve the *current* problem ( that the app won't
> run ),
> the solution is get get the app working *first* and then *later* we worry
> about performance.
>
>
>
> Juan T. Llibre, asp.net MVP
> asp.net faq : http://asp.net.do/faq/
> foros de asp.net, en espaņol : http://asp.net.do/foros/
> ======================================
> "nahid" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed) oups.com...
> On Jul 14, 12:53 am, "Juan T. Llibre" <(E-Mail Removed)>
> wrote:
>> re:
>> !> he try build in release mode better set
>> !> <compilation debug="false" />
>>
>> No. He said that when :
>>
>> !> I change the build configuration to release
>>
>> ...the error occurs, therefore setting it to debug="true" should fix it.
>>
>> Your suggestion, debug="false", is the same as setting the application
>> to release mode, so he would likely continue to get the same error as
>> whenhe manually sets it to "release" mode.
>>
>> Juan T. Llibre, asp.net MVP
>> asp.net faq :http://asp.net.do/faq/
>> foros de asp.net, en espaņol :http://asp.net.do/foros/
>> ======================================"nahid" <(E-Mail Removed)> wrote
>> in messagenews:(E-Mail Removed) ooglegroups.com...
>>
>> On Jul 14, 12:20 am, "Juan T. Llibre" <(E-Mail Removed)>
>> wrote:
>>
>>
>>
>>
>>
>> > Just add this entry to the web.config file :

>>
>> > <compilation debug="true" />

>>
>> > Juan T. Llibre, asp.net MVP
>> > asp.net faq :http://asp.net.do/faq/
>> > foros de asp.net, en espaņol :http://asp.net.do/foros/
>> > ======================================

>>
>> > "news.microsoft.com" <(E-Mail Removed)> wrote in
>> > messagenews:(E-Mail Removed).. .
>> > >I have an asp.net 2.0 project that when I change the build
>> > >configuration to release I get the following error:

>>
>> > > Command line error BC2014: the value 'None' is invalid for option
>> > > 'debug'.

>>
>> > > If I go into the projects Advanced Compile Options and change the
>> > > Generate Debug Info dropdown from None to PDB-Only
>> > > the error goes away. Can anyone explain why I have to do this and
>> > > what can I do to get the one option to work on a
>> > > asp.net project? It is causing problems because the common project
>> > > is shared with a VB project that gets an error
>> > > on
>> > > release mode compile if it is set to pdb-only.

>>
>> > > Thanks for your help.- Hide quoted text -

>>
>> > - Show quoted text -

>>
>> hai,
>> he try build in release mode better set
>> <compilation debug="false" />
>>
>> nahidhttp://nahidulkibria.blogspot.com/http://www.kaz.com.bd- Hide quoted
>> text -
>>
>> - Show quoted text -

>
> well so what is basically main problem, say i'm not prefer set
> <compilation debug="true" /> because of loss some performance
>
> nahid
> http://nahidulkibria.blogspot.com/
> http://www.kaz.com.bd
>
>



 
Reply With Quote
 
news.microsoft.com
Guest
Posts: n/a
 
      07-13-2007
I already have in my web config file <compilation defaultLanguage="vb"
debug="true"/>
and I am getting this message if the debug is set to true or false in the
web.config file if I am trying to compile in release mode with the Generate
Debug Info dropdown set to None. If I change the Generate Debug Info
dropdown set to PDB-Only or Full then the project compiles fine reguardless
of release or debug mode. I hope this clarifies the problem I am having.


"news.microsoft.com" <(E-Mail Removed)> wrote in message
news:OdSO1$(E-Mail Removed)...
>I already have in my web config file <compilation defaultLanguage="vb"
>debug="true"/>
> and I am getting this message if the debug is set to true or false in the
> web.config file.
>
>
>
> "Juan T. Llibre" <(E-Mail Removed)> wrote in message
> news:%(E-Mail Removed)...
>> re:
>> !> well so what is basically main problem, say i'm not prefer set
>> !> <compilation debug="true" /> because of loss some performance
>>
>> True enough, but to resolve the *current* problem ( that the app won't
>> run ),
>> the solution is get get the app working *first* and then *later* we worry
>> about performance.
>>
>>
>>
>> Juan T. Llibre, asp.net MVP
>> asp.net faq : http://asp.net.do/faq/
>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>> ======================================
>> "nahid" <(E-Mail Removed)> wrote in message
>> news:(E-Mail Removed) oups.com...
>> On Jul 14, 12:53 am, "Juan T. Llibre" <(E-Mail Removed)>
>> wrote:
>>> re:
>>> !> he try build in release mode better set
>>> !> <compilation debug="false" />
>>>
>>> No. He said that when :
>>>
>>> !> I change the build configuration to release
>>>
>>> ...the error occurs, therefore setting it to debug="true" should fix it.
>>>
>>> Your suggestion, debug="false", is the same as setting the application
>>> to release mode, so he would likely continue to get the same error as
>>> whenhe manually sets it to "release" mode.
>>>
>>> Juan T. Llibre, asp.net MVP
>>> asp.net faq :http://asp.net.do/faq/
>>> foros de asp.net, en espaņol :http://asp.net.do/foros/
>>> ======================================"nahid" <(E-Mail Removed)> wrote
>>> in messagenews:(E-Mail Removed) ooglegroups.com...
>>>
>>> On Jul 14, 12:20 am, "Juan T. Llibre" <(E-Mail Removed)>
>>> wrote:
>>>
>>>
>>>
>>>
>>>
>>> > Just add this entry to the web.config file :
>>>
>>> > <compilation debug="true" />
>>>
>>> > Juan T. Llibre, asp.net MVP
>>> > asp.net faq :http://asp.net.do/faq/
>>> > foros de asp.net, en espaņol :http://asp.net.do/foros/
>>> > ======================================
>>>
>>> > "news.microsoft.com" <(E-Mail Removed)> wrote in
>>> > messagenews:(E-Mail Removed).. .
>>> > >I have an asp.net 2.0 project that when I change the build
>>> > >configuration to release I get the following error:
>>>
>>> > > Command line error BC2014: the value 'None' is invalid for option
>>> > > 'debug'.
>>>
>>> > > If I go into the projects Advanced Compile Options and change the
>>> > > Generate Debug Info dropdown from None to PDB-Only
>>> > > the error goes away. Can anyone explain why I have to do this and
>>> > > what can I do to get the one option to work on a
>>> > > asp.net project? It is causing problems because the common project
>>> > > is shared with a VB project that gets an error
>>> > > on
>>> > > release mode compile if it is set to pdb-only.
>>>
>>> > > Thanks for your help.- Hide quoted text -
>>>
>>> > - Show quoted text -
>>>
>>> hai,
>>> he try build in release mode better set
>>> <compilation debug="false" />
>>>
>>> nahidhttp://nahidulkibria.blogspot.com/http://www.kaz.com.bd- Hide
>>> quoted text -
>>>
>>> - Show quoted text -

>>
>> well so what is basically main problem, say i'm not prefer set
>> <compilation debug="true" /> because of loss some performance
>>
>> nahid
>> http://nahidulkibria.blogspot.com/
>> http://www.kaz.com.bd
>>
>>

>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to compile and link application in Debug mode with library in Release mode sujeet C Programming 5 09-16-2007 05:23 PM
Compile time error BC2014: the value 'None' is invalid for option Steve Mauldin ASP .Net 0 07-31-2007 03:58 PM
cant compile on linux system.cant compile on cant compile onlinux system. Nagaraj C++ 1 03-01-2007 11:18 AM
Compile WS in release mode in VS 2005 SP ASP .Net Web Services 1 12-30-2005 03:04 AM
Debug mode dll's vs release mode dll's? Dave ASP .Net 0 02-20-2004 03:49 AM



Advertisments