Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Java > Problem invoking a Webservice with Eclipse!

Reply
Thread Tools

Problem invoking a Webservice with Eclipse!

 
 
pod69@gmx.net
Guest
Posts: n/a
 
      06-26-2007
Hello

I have a little problem with my Webservice and Eclipse!

If i invoke it with the console "java -classpath build/stubs/classes/
org/globus/examples/stubs/Service:$CLASSPATH
org.globus.examples.clients.Service.Client" it works fine and reports
no problems on the client and server side!

If I invoke it with eclipse i get the following errors:

AxisFault
faultCode: {http://schemas.xmlsoap.org/soap/
envelope/}Server.userException
faultSubcode:
faultString: org.globus.wsrf.security.SecurityException: [SEC]
Invocation subject not set
faultActor:
faultNode:
faultDetail:
{http://xml.apache.org/
axis/}stackTracerg.globus.wsrf.security.SecurityExcep tion: [SEC]
Invocation subject not set
at
org.globus.wsrf.impl.security.SecurityManagerImpl. getSubject(SecurityManagerImpl.java:
352)
at
org.globus.wsrf.impl.security.SecurityManagerImpl. setServiceOwnerFromContext(SecurityManagerImpl.jav a:
27
at
org.globus.wsrf.impl.security.SecurityManagerImpl. setServiceOwnerFromContext(SecurityManagerImpl.jav a:
261)
etc.........

and the server reports 2007-06-26 11:26:04,239 WARN
handlers.FaultHandler [ServiceThread-9,getFrom:114] The WS-Addressing
''To'' request header is missing

This happens only when I invoke it from Eclipse.

how can i solve that problem - so that i am able to invoke it with
eclipse?

thx

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SoapException when invoking a .NET webservice from java code. anil ASP .Net Web Services 0 06-02-2008 01:14 PM
Re: IllegalArgumentException when invoking axis2-webservice withclient Lew Java 1 02-17-2008 12:53 AM
IllegalArgumentException when invoking axis2-webservice with client MC Java 0 02-16-2008 06:42 PM
WebService Returns Black Page When Invoking David ASP .Net Web Services 2 07-27-2005 08:42 PM
Invoking WebMethods WebService Issue Arun Kumar ASP .Net Web Services 3 06-21-2004 05:09 PM



Advertisments