Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > application pool identity question

Reply
Thread Tools

application pool identity question

 
 
Tom
Guest
Posts: n/a
 
      05-29-2007
When I set my app pool Identity tab to a particular username and password,
I'm prompted for an username and password when I try to access the web site,
but when I have Identity set to 'predefined network service' I'm able to
access my web site without any issues.

I need to have my web sites run as a particular user so in my web.config
files I have:

<identity impersonate="true" userName="domain\testUser"
password="$password$"/>

is this the correct way to do this?



 
Reply With Quote
 
 
 
 
=?ISO-8859-1?Q?G=F6ran_Andersson?=
Guest
Posts: n/a
 
      05-29-2007
Tom wrote:
> When I set my app pool Identity tab to a particular username and password,
> I'm prompted for an username and password when I try to access the web site,
> but when I have Identity set to 'predefined network service' I'm able to
> access my web site without any issues.
>
> I need to have my web sites run as a particular user so in my web.config
> files I have:
>
> <identity impersonate="true" userName="domain\testUser"
> password="$password$"/>
>
> is this the correct way to do this?
>


In the properties for the web site, in the Directory Security tab, under
anonymous access, you specify what user account is used for anonymous
browsing.

--
Göran Andersson
_____
http://www.guffa.com
 
Reply With Quote
 
 
 
 
bruce barker
Guest
Posts: n/a
 
      05-29-2007
your application pool account needs access to the virtual directories
and the asp.net temp folders.

-- bruce (sqlwork.com)



Tom wrote:
> When I set my app pool Identity tab to a particular username and password,
> I'm prompted for an username and password when I try to access the web site,
> but when I have Identity set to 'predefined network service' I'm able to
> access my web site without any issues.
>
> I need to have my web sites run as a particular user so in my web.config
> files I have:
>
> <identity impersonate="true" userName="domain\testUser"
> password="$password$"/>
>
> is this the correct way to do this?
>
>
>

 
Reply With Quote
 
Mike
Guest
Posts: n/a
 
      05-30-2007
it does. The account being used has access to everything, we just changed
the password and now we're prompted everytime we try to access a web page.

"bruce barker" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> your application pool account needs access to the virtual directories and
> the asp.net temp folders.
>
> -- bruce (sqlwork.com)
>
>
>
> Tom wrote:
>> When I set my app pool Identity tab to a particular username and
>> password, I'm prompted for an username and password when I try to access
>> the web site, but when I have Identity set to 'predefined network
>> service' I'm able to access my web site without any issues.
>>
>> I need to have my web sites run as a particular user so in my web.config
>> files I have:
>>
>> <identity impersonate="true" userName="domain\testUser"
>> password="$password$"/>
>>
>> is this the correct way to do this?
>>
>>


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error Consuming Web Service from WIndows application when WebService is using Custom Service Account ( Create an Application Pool with a Custom Identity) DNB ASP .Net Security 1 01-22-2008 09:08 PM
Error Consuming Web Service from WIndows application when WebService is using Custom Service Account ( Create an Application Pool with a Custom Identity) DNB ASP .Net Web Services 1 01-20-2008 01:47 PM
identity impersonate=true masks the identity of the app pool for trusted sql connections Popezilla ASP .Net Security 2 03-18-2007 03:39 AM
ASP.NET 1.1 Application Pool Identity and user authentication problem with AD (Active Directory) pjdouillard@gmail.com ASP .Net 4 12-05-2005 04:08 PM
IIS6 Application Pool Identity 'invalid' Matt ASP .Net 1 10-15-2003 06:45 PM



Advertisments