Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > permission denied!

Reply
Thread Tools

permission denied!

 
 
wild_bunch
Guest
Posts: n/a
 
      05-17-2007

hi all

i am trying to use xmlHttp.open
while opening page A from a div in page B
i am using .net 2005 and my sites are on the different domains at
server
using the above function causes "permission denied" error
but when page A is on local host it works fine....
i call the function only with 3 parameters:
xmlHttp.open("GET", url ,true)
without username & password (i tried that too ofcourse)
can anyone tell me what's the problem?

thanx
wb



--
wild_bunch
------------------------------------------------------------------------
Posted via http://www.codecomments.com
------------------------------------------------------------------------

 
Reply With Quote
 
 
 
 
bruce barker
Guest
Posts: n/a
 
      05-17-2007
XmlHttpRequest can only open sites in the same domain as the source of
the calling page.

if you need to call another domain, you will need to put a proxy page on
the calling domain.

-- bruce (sqlwork.com)

wild_bunch wrote:
> hi all
>
> i am trying to use xmlHttp.open
> while opening page A from a div in page B
> i am using .net 2005 and my sites are on the different domains at
> server
> using the above function causes "permission denied" error
> but when page A is on local host it works fine....
> i call the function only with 3 parameters:
> xmlHttp.open("GET", url ,true)
> without username & password (i tried that too ofcourse)
> can anyone tell me what's the problem?
>
> thanx
> wb
>
>
>
> --
> wild_bunch
> ------------------------------------------------------------------------
> Posted via http://www.codecomments.com
> ------------------------------------------------------------------------
>

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fixed: The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID {555F3418-D99E-4E51-800A-6E89CFD8B1D7} to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19). Skybuck Flying Windows 64bit 1 06-29-2009 06:17 PM
Permission Settings problems. Kardon Coupé Wireless Networking 7 03-08-2005 02:54 AM
WINXP SP2 ICON WIRELESS PERMISSION =?Utf-8?B?SnVhbiBDYXJsb3MgTXXDsW96?= Wireless Networking 0 02-08-2005 10:13 AM
Getting "You might not have permission to use this network..." err =?Utf-8?B?U29tZSBHdXk=?= Wireless Networking 2 01-09-2005 08:32 AM
Error Message - No permission to use this network resource - =?Utf-8?B?UGV0ZXI=?= Wireless Networking 3 12-13-2004 04:37 PM



Advertisments