Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Cisco T1 Internet Config

Reply
Thread Tools

Cisco T1 Internet Config

 
 
Alan Siu
Guest
Posts: n/a
 
      05-02-2007
Hi,

I am pretty new to cisco router config, but I have looked at various router
configuration from our office existing router. I am just trying to
understand the config done by our previous employee in our remote office, so
please help me out. This is a T1 internet line by MCI and use unnumbered in
their serial interface, here is what I don't understand as most of the line
in our main office have ip on their serial interface.

The line under Serial0/0
encapsulation frame-relay IETF -- Do I need this line? This is not a frame
relay but an internet line only.

Also, the interface Serial0/0.1 part
interface Serial0/0.1 point-to-point -- Do I need this 4 lines at all?
bandwidth 1536
ip unnumbered FastEthernet0/0
frame-relay interface-dlci 500 IETF

I just need a bare minimum for internet access only, and here is the
complete config (removed lines with password and line)
Please help, thank you so much.

C2620-R2-R23#sh running-config
Building configuration...

Current configuration : 1528 bytes
!
! No configuration change since last restart
!
version 12.3
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname C2620-R2-R23
!
boot-start-marker
boot-end-marker
!
logging buffered 8196 debugging
!
memory-size iomem 15
clock timezone PST -8
clock summer-time PDT recurring
no aaa new-model
ip subnet-zero
ip cef
!
ip audit po max-events 100
!
interface FastEthernet0/0
description To Office Ethernet R23
ip address 11.111.111.111 255.255.255.240
duplex auto
speed auto
!
interface Serial0/0
bandwidth 1536
no ip address
encapsulation frame-relay IETF
no fair-queue
service-module t1 timeslots 1-24
frame-relay lmi-type ansi
!
interface Serial0/0.1 point-to-point
bandwidth 1536
ip unnumbered FastEthernet0/0
frame-relay interface-dlci 500 IETF
!
no ip http server
no ip http secure-server
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0.1
!
ntp clock-period 17180386
ntp server 207.46.130.100 prefer
!
end


--
Thanks,
Alan


 
Reply With Quote
 
 
 
 
Scooby
Guest
Posts: n/a
 
      05-02-2007
Alan,

That is pretty close to bare minimum there. First, don't confuse your layer
2 protocol with the services that are provided over the line. Meaning, just
because this is internet, doesn't mean that the connection is not frame
relay. If the line is functioning properly with this config, then it is
certainly frame relay. That's like saying you don't have DSL/Cable, you
have internet. Well, DSL/Cable just gets you to the service provider. In
this case, frame relay is just getting you to the service provider.

I personally would not have used a sub interface in this case as you only
have one pvc and frame relay would most likely have just auto discovered it
through lmi - no other config for this would have been needed. Except the
ip unnumbered command would have moved to the serial interface. But, it is
not a bad config as is.

So, if it ain't broke....

But, you may want to consider hardening this a little bit. Check out the
SDM utility - free download from Cisco. Great place to get started on this
stuff.

Jim



"Alan Siu" <(E-Mail Removed)> wrote in message
news:f1a57n$cl1$(E-Mail Removed)...
> Hi,
>
> I am pretty new to cisco router config, but I have looked at various
> router configuration from our office existing router. I am just trying to
> understand the config done by our previous employee in our remote office,
> so please help me out. This is a T1 internet line by MCI and use
> unnumbered in their serial interface, here is what I don't understand as
> most of the line in our main office have ip on their serial interface.
>
> The line under Serial0/0
> encapsulation frame-relay IETF -- Do I need this line? This is not a frame
> relay but an internet line only.
>
> Also, the interface Serial0/0.1 part
> interface Serial0/0.1 point-to-point -- Do I need this 4 lines at all?
> bandwidth 1536
> ip unnumbered FastEthernet0/0
> frame-relay interface-dlci 500 IETF
>
> I just need a bare minimum for internet access only, and here is the
> complete config (removed lines with password and line)
> Please help, thank you so much.
>
> C2620-R2-R23#sh running-config
> Building configuration...
>
> Current configuration : 1528 bytes
> !
> ! No configuration change since last restart
> !
> version 12.3
> service timestamps debug datetime localtime
> service timestamps log datetime localtime
> service password-encryption
> !
> hostname C2620-R2-R23
> !
> boot-start-marker
> boot-end-marker
> !
> logging buffered 8196 debugging
> !
> memory-size iomem 15
> clock timezone PST -8
> clock summer-time PDT recurring
> no aaa new-model
> ip subnet-zero
> ip cef
> !
> ip audit po max-events 100
> !
> interface FastEthernet0/0
> description To Office Ethernet R23
> ip address 11.111.111.111 255.255.255.240
> duplex auto
> speed auto
> !
> interface Serial0/0
> bandwidth 1536
> no ip address
> encapsulation frame-relay IETF
> no fair-queue
> service-module t1 timeslots 1-24
> frame-relay lmi-type ansi
> !
> interface Serial0/0.1 point-to-point
> bandwidth 1536
> ip unnumbered FastEthernet0/0
> frame-relay interface-dlci 500 IETF
> !
> no ip http server
> no ip http secure-server
> ip classless
> ip route 0.0.0.0 0.0.0.0 Serial0/0.1
> !
> ntp clock-period 17180386
> ntp server 207.46.130.100 prefer
> !
> end
>
>
> --
> Thanks,
> Alan
>



 
Reply With Quote
 
 
 
 
Doug McIntyre
Guest
Posts: n/a
 
      05-02-2007
"Alan Siu" <(E-Mail Removed)> writes:
>The line under Serial0/0
>encapsulation frame-relay IETF -- Do I need this line? This is not a frame
>relay but an internet line only.


MCI uses frame-relay layer-2 encapsulation for most of their delivery
for their own management policies. Doesn't mean its a frame-relay network.
You do need this line, as you have to match what MCI is doing. If MCI
requires frame-relay layer-2 encapsulation, you have to match what
they want.

>Also, the interface Serial0/0.1 part
>interface Serial0/0.1 point-to-point -- Do I need this 4 lines at all?
> bandwidth 1536
> ip unnumbered FastEthernet0/0
> frame-relay interface-dlci 500 IETF


Its best to put frame-relay entries in a sub-interface, and you do
need the DLCI definition in order to talk to MCI across the link.

Technically, you aren't doing anything that references the bandwidth
line, but why remove it? You may do something in the future that does.

You appear to be running unnumbered across the serial link, and thats
what 'ip unnumbered' does. You do need it, its required for your setup
again with MCI.

>I just need a bare minimum for internet access only, and here is the
>complete config (removed lines with password and line)


This config is pretty bare-bones basic. There isn't much you can
remove and still have it function to match what MCI is doing.

Why are you considering removing anything?

There isn't anything you could make "simpler" about this config.



 
Reply With Quote
 
Alan Siu
Guest
Posts: n/a
 
      05-02-2007
Yes correct, that's MCI line. Does it mean the config may vary between
different ISP? When I look at the config in the remote office compared to
the one I have in my local office, it just look a lot more complicated than
the config on my T1 router. Compared to the T1 I have with Verizon with an
IP in the serial interface, it looks a lot simpler.

interface Serial0

ip address 111.111.111.111 255.255.255.252

no ip redirects

no fair-queue

!

interface FastEthernet0

ip address 222.222.222.222 255.255.255.248

no ip redirects

speed auto

full-duplex

!

ip classless

ip route 0.0.0.0 0.0.0.0 121.121.121.121

no ip http server


Last question, does the config varies between 1700 or 2600 series router?
Why there is a sub-interface Serial 0/0 and 0/0.1 in 2600 series but in 1700
series, you only have interface Serial 0 or 1?

Thanks for all the people who answered.


--
Thanks,
Alan
"Doug McIntyre" <(E-Mail Removed)> wrote in message
news:4638b682$0$36710$(E-Mail Removed) anews.com...
> "Alan Siu" <(E-Mail Removed)> writes:
>>The line under Serial0/0
>>encapsulation frame-relay IETF -- Do I need this line? This is not a frame
>>relay but an internet line only.

>
> MCI uses frame-relay layer-2 encapsulation for most of their delivery
> for their own management policies. Doesn't mean its a frame-relay network.
> You do need this line, as you have to match what MCI is doing. If MCI
> requires frame-relay layer-2 encapsulation, you have to match what
> they want.
>
>>Also, the interface Serial0/0.1 part
>>interface Serial0/0.1 point-to-point -- Do I need this 4 lines at all?
>> bandwidth 1536
>> ip unnumbered FastEthernet0/0
>> frame-relay interface-dlci 500 IETF

>
> Its best to put frame-relay entries in a sub-interface, and you do
> need the DLCI definition in order to talk to MCI across the link.
>
> Technically, you aren't doing anything that references the bandwidth
> line, but why remove it? You may do something in the future that does.
>
> You appear to be running unnumbered across the serial link, and thats
> what 'ip unnumbered' does. You do need it, its required for your setup
> again with MCI.
>
>>I just need a bare minimum for internet access only, and here is the
>>complete config (removed lines with password and line)

>
> This config is pretty bare-bones basic. There isn't much you can
> remove and still have it function to match what MCI is doing.
>
> Why are you considering removing anything?
>
> There isn't anything you could make "simpler" about this config.
>
>
>



 
Reply With Quote
 
Martin Gallagher
Guest
Posts: n/a
 
      05-04-2007
On Wed, 02 May 2007 17:40:21 -0400, Alan Siu wrote:

> Yes correct, that's MCI line. Does it mean the config may vary between
> different ISP?


Yes.

> When I look at the config in the remote office compared to
> the one I have in my local office, it just look a lot more complicated than
> the config on my T1 router. Compared to the T1 I have with Verizon with an
> IP in the serial interface, it looks a lot simpler.
>
> interface Serial0
> ip address 111.111.111.111 255.255.255.252
> no ip redirects
> no fair-queue


Verizon are using HDLC encapsulation, which is the default on Cisco
routers, what you get if you don't do anything else, so it does look
simpler. I guess HDLC is also a simpler protocol then Frame Relay.

>
> Last question, does the config varies between 1700 or 2600 series router?


Yes and No, more no than yes. The same technology, a Frame Relay
interface for instance, is the same on both routers.

> Why there is a sub-interface Serial 0/0 and 0/0.1 in 2600 series but in
> 1700 series, you only have interface Serial 0 or 1?


Interface numbering differs across platforms, depending on the number
and type of available slots on the router. Subinterfaces are used with
frame-relay encapsulation but not with HDLC.

--
Rgds,
Martin
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dll config and web.config and Label Expressions (binding label text to dll config settings) CSharpner ASP .Net 0 04-09-2007 09:00 PM
Cisco Router Config with a T1 Internet line Alan Cisco 4 09-26-2006 10:29 PM
Cisco Newbie: Cisco 1721 - no internet - no idea why - Here´s the config. Christian Lungwitz Cisco 1 01-02-2005 02:03 AM
Q: Cisco Router config: Leasedline with internet-based ipsec tunnel as backup ? Martin Bilgrav Cisco 0 10-06-2004 07:42 PM
Re: CISCO 1003 UK internet config - Help! Daniel Cisco 0 12-07-2003 12:33 AM



Advertisments