Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > how to create an ASPNET.mdf file?

Reply
Thread Tools

how to create an ASPNET.mdf file?

 
 
Mich
Guest
Posts: n/a
 
      04-08-2007
Hi,

i'm building an web application for anonymous users. They can take a look in
the website, nothing more. In order to perform other actions, the anonymous
user must be logged. So i create an aspx page with the CreateUserWizard
control. The user can fill his username, password etc ....

My problem is: when an user fills everything and clicks on button "create an
account", nothing happens (no error, but no user account created).
I thought asp.net would create in App_Data an ASPNET.MDF file for storing
user and membership information and add automatically a new connection
string in web.config. But it doesn't happen.

I know i can go in design mode (n VWD) and click on "administer the site",
but all the users are anonymous, so i can't create user in advance.
Do i have to put some configuration code in web.config? Or something else?

Thanks for help
Mich


 
Reply With Quote
 
 
 
 
Juan T. Llibre
Guest
Posts: n/a
 
      04-08-2007
Run aspnet_regsql.exe from a command window in your .Net Framework 2.0 directory.




Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Mich" <(E-Mail Removed)> wrote in message news:Og6O%(E-Mail Removed)...
> Hi,
>
> i'm building an web application for anonymous users. They can take a look in the website, nothing
> more. In order to perform other actions, the anonymous user must be logged. So i create an aspx
> page with the CreateUserWizard control. The user can fill his username, password etc ....
>
> My problem is: when an user fills everything and clicks on button "create an account", nothing
> happens (no error, but no user account created).
> I thought asp.net would create in App_Data an ASPNET.MDF file for storing user and membership
> information and add automatically a new connection string in web.config. But it doesn't happen.
>
> I know i can go in design mode (n VWD) and click on "administer the site", but all the users are
> anonymous, so i can't create user in advance.
> Do i have to put some configuration code in web.config? Or something else?
>
> Thanks for help
> Mich
>



 
Reply With Quote
 
 
 
 
Mich
Guest
Posts: n/a
 
      04-08-2007
Hi Juan, thanks for replying..

I did this and an mdf file ASPNETDB.MDF was created in the sql server
directory.
So i copied both files (mdf and log) into APP_Data of my application.
I added a connection string in web.config like this:
<add name="aspnetdb" connectionString="Data
Source=.\SQLEXPRESS;AttachDbFilename=|DataDirector y|\ASPNETDB.MDF;Integrated
Security=True;User Instance=True" providerName="System.Data.SqlClient"/>

Now, when starting the aspx page containing the createuserwizard and filling
all texboxes, again, nothing happens (user is not created). If i try it
within VWDev., the user is then created.
What do i forget or do wrong?
Thanks



"Juan T. Llibre" <(E-Mail Removed)> schreef in bericht
news:(E-Mail Removed)...
> Run aspnet_regsql.exe from a command window in your .Net Framework 2.0
> directory.
>
>
>
>
> Juan T. Llibre, asp.net MVP
> asp.net faq : http://asp.net.do/faq/
> foros de asp.net, en espaņol : http://asp.net.do/foros/
> ===================================
> "Mich" <(E-Mail Removed)> wrote in message
> news:Og6O%(E-Mail Removed)...
>> Hi,
>>
>> i'm building an web application for anonymous users. They can take a look
>> in the website, nothing more. In order to perform other actions, the
>> anonymous user must be logged. So i create an aspx page with the
>> CreateUserWizard control. The user can fill his username, password etc
>> ....
>>
>> My problem is: when an user fills everything and clicks on button "create
>> an account", nothing happens (no error, but no user account created).
>> I thought asp.net would create in App_Data an ASPNET.MDF file for storing
>> user and membership information and add automatically a new connection
>> string in web.config. But it doesn't happen.
>>
>> I know i can go in design mode (n VWD) and click on "administer the
>> site", but all the users are anonymous, so i can't create user in
>> advance.
>> Do i have to put some configuration code in web.config? Or something
>> else?
>>
>> Thanks for help
>> Mich
>>

>
>



 
Reply With Quote
 
David
Guest
Posts: n/a
 
      04-09-2007
I notice you ahve integrated security rather than user names and passwords.
I may be wrong but I think integrated security will require the current user
to have permission in the database. When you are doing it through VWDev, you
are probably carrying your username through, but when doing it from ASP.NET,
you are using the ASP.NET user account, which may not have permission.

--
Best regards,
Dave Colliver.
http://www.AshfieldFOCUS.com
~~
http://www.FOCUSPortals.com - Local franchises available


"Mich" <(E-Mail Removed)> wrote in message
news:Ox%(E-Mail Removed)...
> Hi Juan, thanks for replying..
>
> I did this and an mdf file ASPNETDB.MDF was created in the sql server
> directory.
> So i copied both files (mdf and log) into APP_Data of my application.
> I added a connection string in web.config like this:
> <add name="aspnetdb" connectionString="Data
> Source=.\SQLEXPRESS;AttachDbFilename=|DataDirector y|\ASPNETDB.MDF;Integrated
> Security=True;User Instance=True" providerName="System.Data.SqlClient"/>
>
> Now, when starting the aspx page containing the createuserwizard and
> filling all texboxes, again, nothing happens (user is not created). If i
> try it within VWDev., the user is then created.
> What do i forget or do wrong?
> Thanks
>
>
>
> "Juan T. Llibre" <(E-Mail Removed)> schreef in bericht
> news:(E-Mail Removed)...
>> Run aspnet_regsql.exe from a command window in your .Net Framework 2.0
>> directory.
>>
>>
>>
>>
>> Juan T. Llibre, asp.net MVP
>> asp.net faq : http://asp.net.do/faq/
>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>> ===================================
>> "Mich" <(E-Mail Removed)> wrote in message
>> news:Og6O%(E-Mail Removed)...
>>> Hi,
>>>
>>> i'm building an web application for anonymous users. They can take a
>>> look in the website, nothing more. In order to perform other actions,
>>> the anonymous user must be logged. So i create an aspx page with the
>>> CreateUserWizard control. The user can fill his username, password etc
>>> ....
>>>
>>> My problem is: when an user fills everything and clicks on button
>>> "create an account", nothing happens (no error, but no user account
>>> created).
>>> I thought asp.net would create in App_Data an ASPNET.MDF file for
>>> storing user and membership information and add automatically a new
>>> connection string in web.config. But it doesn't happen.
>>>
>>> I know i can go in design mode (n VWD) and click on "administer the
>>> site", but all the users are anonymous, so i can't create user in
>>> advance.
>>> Do i have to put some configuration code in web.config? Or something
>>> else?
>>>
>>> Thanks for help
>>> Mich
>>>

>>
>>

>
>



 
Reply With Quote
 
Mich
Guest
Posts: n/a
 
      04-09-2007
Account ASPNET has R/W rights on the APP_Data dir.
And if it was not so, i would get an error, but here, no error, nothing
happens ...

"David" <(E-Mail Removed)> schreef in bericht
news:(E-Mail Removed)...
>I notice you ahve integrated security rather than user names and passwords.
>I may be wrong but I think integrated security will require the current
>user to have permission in the database. When you are doing it through
>VWDev, you are probably carrying your username through, but when doing it
>from ASP.NET, you are using the ASP.NET user account, which may not have
>permission.
>
> --
> Best regards,
> Dave Colliver.
> http://www.AshfieldFOCUS.com
> ~~
> http://www.FOCUSPortals.com - Local franchises available
>
>
> "Mich" <(E-Mail Removed)> wrote in message
> news:Ox%(E-Mail Removed)...
>> Hi Juan, thanks for replying..
>>
>> I did this and an mdf file ASPNETDB.MDF was created in the sql server
>> directory.
>> So i copied both files (mdf and log) into APP_Data of my application.
>> I added a connection string in web.config like this:
>> <add name="aspnetdb" connectionString="Data
>> Source=.\SQLEXPRESS;AttachDbFilename=|DataDirector y|\ASPNETDB.MDF;Integrated
>> Security=True;User Instance=True" providerName="System.Data.SqlClient"/>
>>
>> Now, when starting the aspx page containing the createuserwizard and
>> filling all texboxes, again, nothing happens (user is not created). If i
>> try it within VWDev., the user is then created.
>> What do i forget or do wrong?
>> Thanks
>>
>>
>>
>> "Juan T. Llibre" <(E-Mail Removed)> schreef in bericht
>> news:(E-Mail Removed)...
>>> Run aspnet_regsql.exe from a command window in your .Net Framework 2.0
>>> directory.
>>>
>>>
>>>
>>>
>>> Juan T. Llibre, asp.net MVP
>>> asp.net faq : http://asp.net.do/faq/
>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>> ===================================
>>> "Mich" <(E-Mail Removed)> wrote in message
>>> news:Og6O%(E-Mail Removed)...
>>>> Hi,
>>>>
>>>> i'm building an web application for anonymous users. They can take a
>>>> look in the website, nothing more. In order to perform other actions,
>>>> the anonymous user must be logged. So i create an aspx page with the
>>>> CreateUserWizard control. The user can fill his username, password etc
>>>> ....
>>>>
>>>> My problem is: when an user fills everything and clicks on button
>>>> "create an account", nothing happens (no error, but no user account
>>>> created).
>>>> I thought asp.net would create in App_Data an ASPNET.MDF file for
>>>> storing user and membership information and add automatically a new
>>>> connection string in web.config. But it doesn't happen.
>>>>
>>>> I know i can go in design mode (n VWD) and click on "administer the
>>>> site", but all the users are anonymous, so i can't create user in
>>>> advance.
>>>> Do i have to put some configuration code in web.config? Or something
>>>> else?
>>>>
>>>> Thanks for help
>>>> Mich
>>>>
>>>
>>>

>>
>>

>
>



 
Reply With Quote
 
David
Guest
Posts: n/a
 
      04-09-2007
but what about your database?

just having access to the directory does not give database permission.

Set up a user in your database. Give that user permission to see the table
you want to view. Put that users username/password into your connection
string.

--
Best regards,
Dave Colliver.
http://www.AshfieldFOCUS.com
~~
http://www.FOCUSPortals.com - Local franchises available


"Mich" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Account ASPNET has R/W rights on the APP_Data dir.
> And if it was not so, i would get an error, but here, no error, nothing
> happens ...
>
> "David" <(E-Mail Removed)> schreef in bericht
> news:(E-Mail Removed)...
>>I notice you ahve integrated security rather than user names and
>>passwords. I may be wrong but I think integrated security will require the
>>current user to have permission in the database. When you are doing it
>>through VWDev, you are probably carrying your username through, but when
>>doing it from ASP.NET, you are using the ASP.NET user account, which may
>>not have permission.
>>
>> --
>> Best regards,
>> Dave Colliver.
>> http://www.AshfieldFOCUS.com
>> ~~
>> http://www.FOCUSPortals.com - Local franchises available
>>
>>
>> "Mich" <(E-Mail Removed)> wrote in message
>> news:Ox%(E-Mail Removed)...
>>> Hi Juan, thanks for replying..
>>>
>>> I did this and an mdf file ASPNETDB.MDF was created in the sql server
>>> directory.
>>> So i copied both files (mdf and log) into APP_Data of my application.
>>> I added a connection string in web.config like this:
>>> <add name="aspnetdb" connectionString="Data
>>> Source=.\SQLEXPRESS;AttachDbFilename=|DataDirector y|\ASPNETDB.MDF;Integrated
>>> Security=True;User Instance=True" providerName="System.Data.SqlClient"/>
>>>
>>> Now, when starting the aspx page containing the createuserwizard and
>>> filling all texboxes, again, nothing happens (user is not created). If i
>>> try it within VWDev., the user is then created.
>>> What do i forget or do wrong?
>>> Thanks
>>>
>>>
>>>
>>> "Juan T. Llibre" <(E-Mail Removed)> schreef in bericht
>>> news:(E-Mail Removed)...
>>>> Run aspnet_regsql.exe from a command window in your .Net Framework 2.0
>>>> directory.
>>>>
>>>>
>>>>
>>>>
>>>> Juan T. Llibre, asp.net MVP
>>>> asp.net faq : http://asp.net.do/faq/
>>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>> ===================================
>>>> "Mich" <(E-Mail Removed)> wrote in message
>>>> news:Og6O%(E-Mail Removed)...
>>>>> Hi,
>>>>>
>>>>> i'm building an web application for anonymous users. They can take a
>>>>> look in the website, nothing more. In order to perform other actions,
>>>>> the anonymous user must be logged. So i create an aspx page with the
>>>>> CreateUserWizard control. The user can fill his username, password etc
>>>>> ....
>>>>>
>>>>> My problem is: when an user fills everything and clicks on button
>>>>> "create an account", nothing happens (no error, but no user account
>>>>> created).
>>>>> I thought asp.net would create in App_Data an ASPNET.MDF file for
>>>>> storing user and membership information and add automatically a new
>>>>> connection string in web.config. But it doesn't happen.
>>>>>
>>>>> I know i can go in design mode (n VWD) and click on "administer the
>>>>> site", but all the users are anonymous, so i can't create user in
>>>>> advance.
>>>>> Do i have to put some configuration code in web.config? Or something
>>>>> else?
>>>>>
>>>>> Thanks for help
>>>>> Mich
>>>>>
>>>>
>>>>
>>>
>>>

>>
>>

>
>



 
Reply With Quote
 
Mich
Guest
Posts: n/a
 
      04-09-2007
David, i did all those things but i found it:
the map security of the standard website in the IIS was set on Windows
Integrated Auth.
The map security of my website (one level lower in the IIS as all other
websites) is set on Anonymous.
This is the reason why login and createuserwizard doesn't work.
I changed the map security of the standard website into Anonymous and
everything works.
Amazing, no?
Do you have an explanation for that?


"David" <(E-Mail Removed)> schreef in bericht
news:e%(E-Mail Removed)...
> but what about your database?
>
> just having access to the directory does not give database permission.
>
> Set up a user in your database. Give that user permission to see the table
> you want to view. Put that users username/password into your connection
> string.
>
> --
> Best regards,
> Dave Colliver.
> http://www.AshfieldFOCUS.com
> ~~
> http://www.FOCUSPortals.com - Local franchises available
>
>
> "Mich" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
>> Account ASPNET has R/W rights on the APP_Data dir.
>> And if it was not so, i would get an error, but here, no error, nothing
>> happens ...
>>
>> "David" <(E-Mail Removed)> schreef in bericht
>> news:(E-Mail Removed)...
>>>I notice you ahve integrated security rather than user names and
>>>passwords. I may be wrong but I think integrated security will require
>>>the current user to have permission in the database. When you are doing
>>>it through VWDev, you are probably carrying your username through, but
>>>when doing it from ASP.NET, you are using the ASP.NET user account, which
>>>may not have permission.
>>>
>>> --
>>> Best regards,
>>> Dave Colliver.
>>> http://www.AshfieldFOCUS.com
>>> ~~
>>> http://www.FOCUSPortals.com - Local franchises available
>>>
>>>
>>> "Mich" <(E-Mail Removed)> wrote in message
>>> news:Ox%(E-Mail Removed)...
>>>> Hi Juan, thanks for replying..
>>>>
>>>> I did this and an mdf file ASPNETDB.MDF was created in the sql server
>>>> directory.
>>>> So i copied both files (mdf and log) into APP_Data of my application.
>>>> I added a connection string in web.config like this:
>>>> <add name="aspnetdb" connectionString="Data
>>>> Source=.\SQLEXPRESS;AttachDbFilename=|DataDirector y|\ASPNETDB.MDF;Integrated
>>>> Security=True;User Instance=True"
>>>> providerName="System.Data.SqlClient"/>
>>>>
>>>> Now, when starting the aspx page containing the createuserwizard and
>>>> filling all texboxes, again, nothing happens (user is not created). If
>>>> i try it within VWDev., the user is then created.
>>>> What do i forget or do wrong?
>>>> Thanks
>>>>
>>>>
>>>>
>>>> "Juan T. Llibre" <(E-Mail Removed)> schreef in bericht
>>>> news:(E-Mail Removed)...
>>>>> Run aspnet_regsql.exe from a command window in your .Net Framework 2.0
>>>>> directory.
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> Juan T. Llibre, asp.net MVP
>>>>> asp.net faq : http://asp.net.do/faq/
>>>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>> ===================================
>>>>> "Mich" <(E-Mail Removed)> wrote in message
>>>>> news:Og6O%(E-Mail Removed)...
>>>>>> Hi,
>>>>>>
>>>>>> i'm building an web application for anonymous users. They can take a
>>>>>> look in the website, nothing more. In order to perform other actions,
>>>>>> the anonymous user must be logged. So i create an aspx page with the
>>>>>> CreateUserWizard control. The user can fill his username, password
>>>>>> etc ....
>>>>>>
>>>>>> My problem is: when an user fills everything and clicks on button
>>>>>> "create an account", nothing happens (no error, but no user account
>>>>>> created).
>>>>>> I thought asp.net would create in App_Data an ASPNET.MDF file for
>>>>>> storing user and membership information and add automatically a new
>>>>>> connection string in web.config. But it doesn't happen.
>>>>>>
>>>>>> I know i can go in design mode (n VWD) and click on "administer the
>>>>>> site", but all the users are anonymous, so i can't create user in
>>>>>> advance.
>>>>>> Do i have to put some configuration code in web.config? Or something
>>>>>> else?
>>>>>>
>>>>>> Thanks for help
>>>>>> Mich
>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>

>>
>>

>
>



 
Reply With Quote
 
Tony Girgenti
Guest
Posts: n/a
 
      04-09-2007
Hello Mich.

I'm trying to follow along in this thread beacuse i think i'm having the
same problem.

Can you explain where you went to change your "map security"?

Is it in the IIS Administration?

Any help would be gratefully appreciated.

Thanks,
Tony

"Mich" <(E-Mail Removed)> wrote in message
news:eZES%(E-Mail Removed)...
> David, i did all those things but i found it:
> the map security of the standard website in the IIS was set on Windows
> Integrated Auth.
> The map security of my website (one level lower in the IIS as all other
> websites) is set on Anonymous.
> This is the reason why login and createuserwizard doesn't work.
> I changed the map security of the standard website into Anonymous and
> everything works.
> Amazing, no?
> Do you have an explanation for that?
>
>
> "David" <(E-Mail Removed)> schreef in bericht
> news:e%(E-Mail Removed)...
>> but what about your database?
>>
>> just having access to the directory does not give database permission.
>>
>> Set up a user in your database. Give that user permission to see the
>> table you want to view. Put that users username/password into your
>> connection string.
>>
>> --
>> Best regards,
>> Dave Colliver.
>> http://www.AshfieldFOCUS.com
>> ~~
>> http://www.FOCUSPortals.com - Local franchises available
>>
>>
>> "Mich" <(E-Mail Removed)> wrote in message
>> news:(E-Mail Removed)...
>>> Account ASPNET has R/W rights on the APP_Data dir.
>>> And if it was not so, i would get an error, but here, no error, nothing
>>> happens ...
>>>
>>> "David" <(E-Mail Removed)> schreef in bericht
>>> news:(E-Mail Removed)...
>>>>I notice you ahve integrated security rather than user names and
>>>>passwords. I may be wrong but I think integrated security will require
>>>>the current user to have permission in the database. When you are doing
>>>>it through VWDev, you are probably carrying your username through, but
>>>>when doing it from ASP.NET, you are using the ASP.NET user account,
>>>>which may not have permission.
>>>>
>>>> --
>>>> Best regards,
>>>> Dave Colliver.
>>>> http://www.AshfieldFOCUS.com
>>>> ~~
>>>> http://www.FOCUSPortals.com - Local franchises available
>>>>
>>>>
>>>> "Mich" <(E-Mail Removed)> wrote in message
>>>> news:Ox%(E-Mail Removed)...
>>>>> Hi Juan, thanks for replying..
>>>>>
>>>>> I did this and an mdf file ASPNETDB.MDF was created in the sql server
>>>>> directory.
>>>>> So i copied both files (mdf and log) into APP_Data of my application.
>>>>> I added a connection string in web.config like this:
>>>>> <add name="aspnetdb" connectionString="Data
>>>>> Source=.\SQLEXPRESS;AttachDbFilename=|DataDirector y|\ASPNETDB.MDF;Integrated
>>>>> Security=True;User Instance=True"
>>>>> providerName="System.Data.SqlClient"/>
>>>>>
>>>>> Now, when starting the aspx page containing the createuserwizard and
>>>>> filling all texboxes, again, nothing happens (user is not created). If
>>>>> i try it within VWDev., the user is then created.
>>>>> What do i forget or do wrong?
>>>>> Thanks
>>>>>
>>>>>
>>>>>
>>>>> "Juan T. Llibre" <(E-Mail Removed)> schreef in bericht
>>>>> news:(E-Mail Removed)...
>>>>>> Run aspnet_regsql.exe from a command window in your .Net Framework
>>>>>> 2.0 directory.
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> Juan T. Llibre, asp.net MVP
>>>>>> asp.net faq : http://asp.net.do/faq/
>>>>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>>> ===================================
>>>>>> "Mich" <(E-Mail Removed)> wrote in message
>>>>>> news:Og6O%(E-Mail Removed)...
>>>>>>> Hi,
>>>>>>>
>>>>>>> i'm building an web application for anonymous users. They can take a
>>>>>>> look in the website, nothing more. In order to perform other
>>>>>>> actions, the anonymous user must be logged. So i create an aspx page
>>>>>>> with the CreateUserWizard control. The user can fill his username,
>>>>>>> password etc ....
>>>>>>>
>>>>>>> My problem is: when an user fills everything and clicks on button
>>>>>>> "create an account", nothing happens (no error, but no user account
>>>>>>> created).
>>>>>>> I thought asp.net would create in App_Data an ASPNET.MDF file for
>>>>>>> storing user and membership information and add automatically a new
>>>>>>> connection string in web.config. But it doesn't happen.
>>>>>>>
>>>>>>> I know i can go in design mode (n VWD) and click on "administer the
>>>>>>> site", but all the users are anonymous, so i can't create user in
>>>>>>> advance.
>>>>>>> Do i have to put some configuration code in web.config? Or something
>>>>>>> else?
>>>>>>>
>>>>>>> Thanks for help
>>>>>>> Mich
>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>

>>
>>

>
>



 
Reply With Quote
 
Juan T. Llibre
Guest
Posts: n/a
 
      04-09-2007
re:
> Can you explain where you went to change your "map security"?


He meant "the mapped security".

Use the IIS Manager for that.
Right-click and select "Properties"; then select the "Directory Security" tab.




Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Tony Girgenti" <tony(nospam)@lakesideos.com> wrote in message
news:(E-Mail Removed)...
> Hello Mich.
>
> I'm trying to follow along in this thread beacuse i think i'm having the same problem.
>
> Can you explain where you went to change your "map security"?
>
> Is it in the IIS Administration?
>
> Any help would be gratefully appreciated.
>
> Thanks,
> Tony
>
> "Mich" <(E-Mail Removed)> wrote in message news:eZES%(E-Mail Removed)...
>> David, i did all those things but i found it:
>> the map security of the standard website in the IIS was set on Windows Integrated Auth.
>> The map security of my website (one level lower in the IIS as all other websites) is set on
>> Anonymous.
>> This is the reason why login and createuserwizard doesn't work.
>> I changed the map security of the standard website into Anonymous and everything works.
>> Amazing, no?
>> Do you have an explanation for that?
>>
>>
>> "David" <(E-Mail Removed)> schreef in bericht
>> news:e%(E-Mail Removed)...
>>> but what about your database?
>>>
>>> just having access to the directory does not give database permission.
>>>
>>> Set up a user in your database. Give that user permission to see the table you want to view. Put
>>> that users username/password into your connection string.
>>>
>>> --
>>> Best regards,
>>> Dave Colliver.
>>> http://www.AshfieldFOCUS.com
>>> ~~
>>> http://www.FOCUSPortals.com - Local franchises available
>>>
>>>
>>> "Mich" <(E-Mail Removed)> wrote in message news:(E-Mail Removed)...
>>>> Account ASPNET has R/W rights on the APP_Data dir.
>>>> And if it was not so, i would get an error, but here, no error, nothing happens ...
>>>>
>>>> "David" <(E-Mail Removed)> schreef in bericht
>>>> news:(E-Mail Removed)...
>>>>>I notice you ahve integrated security rather than user names and passwords. I may be wrong but
>>>>>I think integrated security will require the current user to have permission in the database.
>>>>>When you are doing it through VWDev, you are probably carrying your username through, but when
>>>>>doing it from ASP.NET, you are using the ASP.NET user account, which may not have permission.
>>>>>
>>>>> --
>>>>> Best regards,
>>>>> Dave Colliver.
>>>>> http://www.AshfieldFOCUS.com
>>>>> ~~
>>>>> http://www.FOCUSPortals.com - Local franchises available
>>>>>
>>>>>
>>>>> "Mich" <(E-Mail Removed)> wrote in message news:Ox%(E-Mail Removed)...
>>>>>> Hi Juan, thanks for replying..
>>>>>>
>>>>>> I did this and an mdf file ASPNETDB.MDF was created in the sql server directory.
>>>>>> So i copied both files (mdf and log) into APP_Data of my application.
>>>>>> I added a connection string in web.config like this:
>>>>>> <add name="aspnetdb" connectionString="Data
>>>>>> Source=.\SQLEXPRESS;AttachDbFilename=|DataDirector y|\ASPNETDB.MDF;Integrated
>>>>>> Security=True;User Instance=True" providerName="System.Data.SqlClient"/>
>>>>>>
>>>>>> Now, when starting the aspx page containing the createuserwizard and filling all texboxes,
>>>>>> again, nothing happens (user is not created). If i try it within VWDev., the user is then
>>>>>> created.
>>>>>> What do i forget or do wrong?
>>>>>> Thanks
>>>>>>
>>>>>>
>>>>>>
>>>>>> "Juan T. Llibre" <(E-Mail Removed)> schreef in bericht
>>>>>> news:(E-Mail Removed)...
>>>>>>> Run aspnet_regsql.exe from a command window in your .Net Framework 2.0 directory.
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> Juan T. Llibre, asp.net MVP
>>>>>>> asp.net faq : http://asp.net.do/faq/
>>>>>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>>>> ===================================
>>>>>>> "Mich" <(E-Mail Removed)> wrote in message news:Og6O%(E-Mail Removed)...
>>>>>>>> Hi,
>>>>>>>>
>>>>>>>> i'm building an web application for anonymous users. They can take a look in the website,
>>>>>>>> nothing more. In order to perform other actions, the anonymous user must be logged. So i
>>>>>>>> create an aspx page with the CreateUserWizard control. The user can fill his username,
>>>>>>>> password etc ....
>>>>>>>>
>>>>>>>> My problem is: when an user fills everything and clicks on button "create an account",
>>>>>>>> nothing happens (no error, but no user account created).
>>>>>>>> I thought asp.net would create in App_Data an ASPNET.MDF file for storing user and
>>>>>>>> membership information and add automatically a new connection string in web.config. But it
>>>>>>>> doesn't happen.
>>>>>>>>
>>>>>>>> I know i can go in design mode (n VWD) and click on "administer the site", but all the
>>>>>>>> users are anonymous, so i can't create user in advance.
>>>>>>>> Do i have to put some configuration code in web.config? Or something else?
>>>>>>>>
>>>>>>>> Thanks for help
>>>>>>>> Mich
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>

>>
>>

>
>



 
Reply With Quote
 
Mich
Guest
Posts: n/a
 
      04-09-2007
Yes.

Rightclick on Standard website (maybe diffferent in windows 2003, i use xp
prof.), then take properties and then Map security. There you can choose
anonymous or win. int. auth.

"Tony Girgenti" <tony(nospam)@lakesideos.com> schreef in bericht
news:(E-Mail Removed)...
> Hello Mich.
>
> I'm trying to follow along in this thread beacuse i think i'm having the
> same problem.
>
> Can you explain where you went to change your "map security"?
>
> Is it in the IIS Administration?
>
> Any help would be gratefully appreciated.
>
> Thanks,
> Tony
>
> "Mich" <(E-Mail Removed)> wrote in message
> news:eZES%(E-Mail Removed)...
>> David, i did all those things but i found it:
>> the map security of the standard website in the IIS was set on Windows
>> Integrated Auth.
>> The map security of my website (one level lower in the IIS as all other
>> websites) is set on Anonymous.
>> This is the reason why login and createuserwizard doesn't work.
>> I changed the map security of the standard website into Anonymous and
>> everything works.
>> Amazing, no?
>> Do you have an explanation for that?
>>
>>
>> "David" <(E-Mail Removed)> schreef in bericht
>> news:e%(E-Mail Removed)...
>>> but what about your database?
>>>
>>> just having access to the directory does not give database permission.
>>>
>>> Set up a user in your database. Give that user permission to see the
>>> table you want to view. Put that users username/password into your
>>> connection string.
>>>
>>> --
>>> Best regards,
>>> Dave Colliver.
>>> http://www.AshfieldFOCUS.com
>>> ~~
>>> http://www.FOCUSPortals.com - Local franchises available
>>>
>>>
>>> "Mich" <(E-Mail Removed)> wrote in message
>>> news:(E-Mail Removed)...
>>>> Account ASPNET has R/W rights on the APP_Data dir.
>>>> And if it was not so, i would get an error, but here, no error, nothing
>>>> happens ...
>>>>
>>>> "David" <(E-Mail Removed)> schreef in
>>>> bericht news:(E-Mail Removed)...
>>>>>I notice you ahve integrated security rather than user names and
>>>>>passwords. I may be wrong but I think integrated security will require
>>>>>the current user to have permission in the database. When you are doing
>>>>>it through VWDev, you are probably carrying your username through, but
>>>>>when doing it from ASP.NET, you are using the ASP.NET user account,
>>>>>which may not have permission.
>>>>>
>>>>> --
>>>>> Best regards,
>>>>> Dave Colliver.
>>>>> http://www.AshfieldFOCUS.com
>>>>> ~~
>>>>> http://www.FOCUSPortals.com - Local franchises available
>>>>>
>>>>>
>>>>> "Mich" <(E-Mail Removed)> wrote in message
>>>>> news:Ox%(E-Mail Removed)...
>>>>>> Hi Juan, thanks for replying..
>>>>>>
>>>>>> I did this and an mdf file ASPNETDB.MDF was created in the sql server
>>>>>> directory.
>>>>>> So i copied both files (mdf and log) into APP_Data of my application.
>>>>>> I added a connection string in web.config like this:
>>>>>> <add name="aspnetdb" connectionString="Data
>>>>>> Source=.\SQLEXPRESS;AttachDbFilename=|DataDirector y|\ASPNETDB.MDF;Integrated
>>>>>> Security=True;User Instance=True"
>>>>>> providerName="System.Data.SqlClient"/>
>>>>>>
>>>>>> Now, when starting the aspx page containing the createuserwizard and
>>>>>> filling all texboxes, again, nothing happens (user is not created).
>>>>>> If i try it within VWDev., the user is then created.
>>>>>> What do i forget or do wrong?
>>>>>> Thanks
>>>>>>
>>>>>>
>>>>>>
>>>>>> "Juan T. Llibre" <(E-Mail Removed)> schreef in bericht
>>>>>> news:(E-Mail Removed)...
>>>>>>> Run aspnet_regsql.exe from a command window in your .Net Framework
>>>>>>> 2.0 directory.
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> Juan T. Llibre, asp.net MVP
>>>>>>> asp.net faq : http://asp.net.do/faq/
>>>>>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>>>> ===================================
>>>>>>> "Mich" <(E-Mail Removed)> wrote in message
>>>>>>> news:Og6O%(E-Mail Removed)...
>>>>>>>> Hi,
>>>>>>>>
>>>>>>>> i'm building an web application for anonymous users. They can take
>>>>>>>> a look in the website, nothing more. In order to perform other
>>>>>>>> actions, the anonymous user must be logged. So i create an aspx
>>>>>>>> page with the CreateUserWizard control. The user can fill his
>>>>>>>> username, password etc ....
>>>>>>>>
>>>>>>>> My problem is: when an user fills everything and clicks on button
>>>>>>>> "create an account", nothing happens (no error, but no user account
>>>>>>>> created).
>>>>>>>> I thought asp.net would create in App_Data an ASPNET.MDF file for
>>>>>>>> storing user and membership information and add automatically a new
>>>>>>>> connection string in web.config. But it doesn't happen.
>>>>>>>>
>>>>>>>> I know i can go in design mode (n VWD) and click on "administer the
>>>>>>>> site", but all the users are anonymous, so i can't create user in
>>>>>>>> advance.
>>>>>>>> Do i have to put some configuration code in web.config? Or
>>>>>>>> something else?
>>>>>>>>
>>>>>>>> Thanks for help
>>>>>>>> Mich
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>

>>
>>

>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Re: How include a large array? Edward A. Falk C Programming 1 04-04-2013 08:07 PM
Create Api to create document and add,edit,delete text and t Krithika San Ruby 3 11-14-2009 09:29 PM
How can i create new users without utilizing the create user wizar prady ASP .Net 2 12-29-2007 10:46 PM
Can I create a Create .NET 1.1 project in VS2005? JB ASP .Net 1 12-14-2007 10:53 AM
How to create python script which can create csv we file with relationship Sonu Python 1 08-03-2007 01:08 PM



Advertisments