Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > BGP multihoming single site, two isp

Reply
Thread Tools

BGP multihoming single site, two isp

 
 
jan.rockstedt@gmail.com
Guest
Posts: n/a
 
      04-04-2007
Hi all,

We are soon starting up bgp and multihoming.
Two ISPs and we have one site.
We have already PI number and ASN assign to us.
A Cisco 3825 with 3 ethernet interface with IOS advanced feature pack
is order.
No full routing table.

Any sugestion for a config?

Regards Jan Rockstedt

 
Reply With Quote
 
 
 
 
Lars L. Christensen
Guest
Posts: n/a
 
      04-04-2007
"(E-Mail Removed)" <(E-Mail Removed)> wrote in
news:(E-Mail Removed) oups.com:

> Hi all,
>
> We are soon starting up bgp and multihoming.
> Two ISPs and we have one site.
> We have already PI number and ASN assign to us.
> A Cisco 3825 with 3 ethernet interface with IOS advanced feature pack
> is order.
> No full routing table.
>
> Any sugestion for a config?
>
> Regards Jan Rockstedt
>
>


Hi Jan

You could do it two ways:

1. Use one ISP as primary and one as secondary
2. Use both ISPs and recieve default routes from both ISP along with
their "own" IPs

For both ISPs you setup standard BGP settings as described in the
documentation from Cisco (take a look at CCO and do a search on BGP).

With option 1 you tag the inbound routes from both ISPs, setting the
local-preference for 200 on the primary routes and leave the secondary
ISP with default local-preference (that'll be 100). When you advertise
your own routes, do a prepend to the routes you advertise to the
secondary ISP.


With option 2 you simply accept any routes advertised by the ISP and
advertise your own routes with default settings.


If you need further information / help, please respond to this group.

Cheers,
Lars Christensen
 
Reply With Quote
 
 
 
 
Bod43@hotmail.co.uk
Guest
Posts: n/a
 
      04-04-2007
On 4 Apr, 18:52, "Lars L. Christensen" <(E-Mail Removed)>
wrote:
> "(E-Mail Removed)" <(E-Mail Removed)> wrote innews:(E-Mail Removed) groups.com:
>
> > Hi all,

>
> > We are soon starting up bgp and multihoming.
> > Two ISPs and we have one site.
> > We have already PI number and ASN assign to us.
> > A Cisco 3825 with 3 ethernet interface with IOS advanced feature pack
> > is order.
> > No full routing table.

>
> > Any sugestion for a config?

>
> > Regards Jan Rockstedt

>
> Hi Jan
>
> You could do it two ways:
>
> 1. Use one ISP as primary and one as secondary
> 2. Use both ISPs and recieve default routes from both ISP along with
> their "own" IPs
>
> For both ISPs you setup standard BGP settings as described in the
> documentation from Cisco (take a look at CCO and do a search on BGP).
>
> With option 1 you tag the inbound routes from both ISPs, setting the
> local-preference for 200 on the primary routes and leave the secondary
> ISP with default local-preference (that'll be 100). When you advertise
> your own routes, do a prepend to the routes you advertise to the
> secondary ISP.
>
> With option 2 you simply accept any routes advertised by the ISP and
> advertise your own routes with default settings.
>
> If you need further information / help, please respond to this group.


Thanks, that is interesting to me too.

Is it possible to find out how many AS numbers to
"prepend" to effectively guarantee that one path
will become primary for all ISPs?

I have made a stab at 4 relating to 2 connections within a single
city.
How many would be needed to guarantee this globally?

Is there a limit to the number of ASs in a path and
if so what is a reasonable number to limit our prepends
to?

Thanks.


 
Reply With Quote
 
jan.rockstedt@gmail.com
Guest
Posts: n/a
 
      04-05-2007
On 4 Apr, 19:52, "Lars L. Christensen" <(E-Mail Removed)>
wrote:
> "(E-Mail Removed)" <(E-Mail Removed)> wrote innews:(E-Mail Removed) groups.com:
>
> > Hi all,

>
> > We are soon starting up bgp and multihoming.
> > Two ISPs and we have one site.
> > We have already PI number and ASN assign to us.
> > A Cisco 3825 with 3 ethernet interface with IOS advanced feature pack
> > is order.
> > No full routing table.

>
> > Any sugestion for a config?

>
> > Regards Jan Rockstedt

>
> Hi Jan
>
> You could do it two ways:
>
> 1. Use one ISP as primary and one as secondary
> 2. Use both ISPs and recieve default routes from both ISP along with
> their "own" IPs
>
> For both ISPs you setup standard BGP settings as described in the
> documentation from Cisco (take a look at CCO and do a search on BGP).
>
> With option 1 you tag the inbound routes from both ISPs, setting the
> local-preference for 200 on the primary routes and leave the secondary
> ISP with default local-preference (that'll be 100). When you advertise
> your own routes, do a prepend to the routes you advertise to the
> secondary ISP.
>
> With option 2 you simply accept any routes advertised by the ISP and
> advertise your own routes with default settings.
>
> If you need further information / help, please respond to this group.
>
> Cheers,
> Lars Christensen


Hi Lars,

Thanks for your respond.

I have found so many doc on the google.
Many are old quit .....

Our primary isp are the link 50 Mbit and our second isp we have a 10
Mbit.
So two default routes, one with static 0.0.0.0/0.0.0.0 with default
100 to the 50 Mbit and one with 0.0.0.0/0.0.0.0 with 200 to the 10
Mbit
Redistribute static to bgp?

router bgp our-ASN
network 1.0.0.0
network 2.0.0.0

neighbor 10.10.10.10 remote-as ISP1-ASN
neighbor 10.10.10.10 route-map localonly out
neighbor 20.20.20.20 remote-as IPS2-ASN
neighbor 20.20.20.20 route-map localonly out

//Jan

 
Reply With Quote
 
Vincent C Jones
Guest
Posts: n/a
 
      04-10-2007
http://www.velocityreviews.com/forums/(E-Mail Removed) wrote:

> On 4 Apr, 19:52, "Lars L. Christensen" <(E-Mail Removed)>
> wrote:
>> "(E-Mail Removed)" <(E-Mail Removed)> wrote
>> innews:(E-Mail Removed) groups.com:
>>
>> > Hi all,

>>
>> > We are soon starting up bgp and multihoming.
>> > Two ISPs and we have one site.
>> > We have already PI number and ASN assign to us.
>> > A Cisco 3825 with 3 ethernet interface with IOS advanced feature pack
>> > is order.
>> > No full routing table.

>>
>> > Any sugestion for a config?

>>
>> > Regards Jan Rockstedt

>>
>> Hi Jan
>>
>> You could do it two ways:
>>
>> 1. Use one ISP as primary and one as secondary
>> 2. Use both ISPs and recieve default routes from both ISP along with
>> their "own" IPs
>>
>> For both ISPs you setup standard BGP settings as described in the
>> documentation from Cisco (take a look at CCO and do a search on BGP).
>>
>> With option 1 you tag the inbound routes from both ISPs, setting the
>> local-preference for 200 on the primary routes and leave the secondary
>> ISP with default local-preference (that'll be 100). When you advertise
>> your own routes, do a prepend to the routes you advertise to the
>> secondary ISP.
>>
>> With option 2 you simply accept any routes advertised by the ISP and
>> advertise your own routes with default settings.
>>
>> If you need further information / help, please respond to this group.
>>
>> Cheers,
>> Lars Christensen

>
> Hi Lars,
>
> Thanks for your respond.
>
> I have found so many doc on the google.
> Many are old quit .....
>
> Our primary isp are the link 50 Mbit and our second isp we have a 10
> Mbit.
> So two default routes, one with static 0.0.0.0/0.0.0.0 with default
> 100 to the 50 Mbit and one with 0.0.0.0/0.0.0.0 with 200 to the 10
> Mbit
> Redistribute static to bgp?
>
> router bgp our-ASN
> network 1.0.0.0
> network 2.0.0.0
>
> neighbor 10.10.10.10 remote-as ISP1-ASN
> neighbor 10.10.10.10 route-map localonly out
> neighbor 20.20.20.20 remote-as IPS2-ASN
> neighbor 20.20.20.20 route-map localonly out
>
> //Jan


A few comments...

Don't worry about the age of the docs on the web! Not much has changed with
BGP since version 4 was released last century. If you can track down a copy
of my book, read the chapter on connecting to an ISP, it still applies.

As for your proposal, I do not recommend it if your goal is to minimize
potential for black holes. Rather than using static default routes, have
your ISPs advertise a default route to you (that way, you only get a
default route if your link to the ISP is up). There are even better ways to
protect against problems in your ISP or upstream, but they take more
effort, as does setting up reasonable load balancing.

Good luck and have fun!
--
Vincent C Jones, Consultant Expert advice and a helping hand
Networking Unlimited, Inc. for those who want to manage and
Tenafly, NJ Phone: 201 568-7810 control their networking destiny
http://www.networkingunlimited.com
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
To BGP or not to BGP (multihoming with ISPs over uneven links speed)?!? papi Cisco 4 09-08-2009 02:45 AM
Multihoming with two ISP's Sinan Cisco 0 10-11-2007 08:22 PM
Multihoming without BGP using 2 ISP connections with PAT pmachete@gmail.com Cisco 5 06-16-2006 10:22 PM
BGP multihoming with uneven links - sample config and Qs papi Cisco 2 04-05-2005 02:34 PM
Multihoming question / BGP (default route) Christian Lox Cisco 4 07-04-2004 06:35 PM



Advertisments