Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > UK VOIP > Anyone successfully passing caller ID info thru voip.co.uk

Reply
Thread Tools

Anyone successfully passing caller ID info thru voip.co.uk

 
 
Matt
Guest
Posts: n/a
 
      03-31-2007
On Mar 31, 2:47 pm, Jono <(E-Mail Removed)> wrote:
> on 31/03/2007, Matt supposed :
>
> > It lets me verify my other numbers, but not the 08704 number. Very
> > strange...

>
> > Now getting Trixbox to use that details seems to be another challenge!

>
> > Do you set the outgoing id in the extension or the trunk? Or both?
> > Which format are you using? 00441827, 441827 or 01827?

>
> Here's my voipcheap.com trunk. As you can see that the CLID is set in
> my trunk, not in the extensions.
>
> PEER Details:
> allow=ulaw&alaw
> authuser=username
> disallow=all
> dtmfmode=rfc2833
> fromdomain=voipcheap.com
> fromuser=00448700xxxxxx
> host=sip.voipcheap.com
> insecure=very
> nat=yes
> qualify=yes
> secret=password
> type=friend
> username=username


Cheers Jono,

Will try those settings later.

Ta!

Matt

 
Reply With Quote
 
 
 
 
Philippe Deleye
Guest
Posts: n/a
 
      03-31-2007

"Jono" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed). ..
> I will try my German number in a bit, however, even though I have set
> everything up as 004401 or 0044870 (for the UK ones), the number that
> is presented is not in the format 00441, nor +441 but 01. Therefore, I
> suspect that the German one would be correct for dialling a German
> number......


Yes, of course the CLI is presented as 01. This is because your provider in
the UK (e.g. BT) is correcting the 00441 into 01.
If you use a german number for outgong CLI, the number will be presented as
0049xxx except in Germany, where it will be presented as 0xxx



 
Reply With Quote
 
 
 
 
Matt
Guest
Posts: n/a
 
      03-31-2007
On Mar 31, 4:08 pm, "Matt" <(E-Mail Removed)> wrote:
> On Mar 31, 2:47 pm, Jono <(E-Mail Removed)> wrote:
>
>
>
>
>
> > on 31/03/2007, Matt supposed :

>
> > > It lets me verify my other numbers, but not the 08704 number. Very
> > > strange...

>
> > > Now getting Trixbox to use that details seems to be another challenge!

>
> > > Do you set the outgoing id in the extension or the trunk? Or both?
> > > Which format are you using? 00441827, 441827 or 01827?

>
> > Here's my voipcheap.com trunk. As you can see that the CLID is set in
> > my trunk, not in the extensions.

>
> > PEER Details:
> > allow=ulaw&alaw
> > authuser=username
> > disallow=all
> > dtmfmode=rfc2833
> > fromdomain=voipcheap.com
> > fromuser=00448700xxxxxx
> > host=sip.voipcheap.com
> > insecure=very
> > nat=yes
> > qualify=yes
> > secret=password
> > type=friend
> > username=username

>
> Cheers Jono,
>
> Will try those settings later.
>
> Ta!
>
> Matt- Hide quoted text -
>
> - Show quoted text -


That sorted it.

Just need to find a way of setting the clid on an extension be
extension basis....

Cheers Jono!

 
Reply With Quote
 
Jono
Guest
Posts: n/a
 
      03-31-2007
Philippe Deleye wrote :
> "Jono" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed). ..
>> I will try my German number in a bit, however, even though I have set
>> everything up as 004401 or 0044870 (for the UK ones), the number that
>> is presented is not in the format 00441, nor +441 but 01. Therefore, I
>> suspect that the German one would be correct for dialling a German
>> number......

>
> Yes, of course the CLI is presented as 01. This is because your provider in
> the UK (e.g. BT) is correcting the 00441 into 01.
> If you use a german number for outgong CLI, the number will be presented as
> 0049xxx except in Germany, where it will be presented as 0xxx


I am gonna have to try it now...


 
Reply With Quote
 
Jono
Guest
Posts: n/a
 
      03-31-2007
Philippe Deleye expressed precisely :
> "Jono" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed). ..
>> I will try my German number in a bit, however, even though I have set
>> everything up as 004401 or 0044870 (for the UK ones), the number that
>> is presented is not in the format 00441, nor +441 but 01. Therefore, I
>> suspect that the German one would be correct for dialling a German
>> number......

>
> Yes, of course the CLI is presented as 01. This is because your provider in
> the UK (e.g. BT) is correcting the 00441 into 01.
> If you use a german number for outgong CLI, the number will be presented as
> 0049xxx except in Germany, where it will be presented as 0xxx


Not sure I've seen you get anything wrong yet & it hasn't happened this
time either.


 
Reply With Quote
 
Mike Sun
Guest
Posts: n/a
 
      03-31-2007
"Philippe Deleye" <(E-Mail Removed)> wrote in message
news:460e45f2$0$13864$(E-Mail Removed)...
> A few more tips to get this correctly done:
> * register your landlines as descrobed above, but make sure you use the
> format 0044 xxxx, not in the format +44 xxx
> The latter will work for verification, but not for CLI..
> * set your SIP device or IP phone to use your phone number, and also use
> the
> same format (0044 xxxx) here.
> If you have dones this correctly, it will work perfectly, even for non-UK
> numbers.


Hey - that is a fantastically helpful tip which I confirm works well with
my ATA (Gate 102) and voipcheap.com - many thanks - Cheers from Mike


 
Reply With Quote
 
Philippe Deleye
Guest
Posts: n/a
 
      03-31-2007

"Jono" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed). ..
> Not sure I've seen you get anything wrong yet & it hasn't happened this
> time either.
>

Is this a compliment ?? Thanks a lot
Happy to know that I could help
I must admit that my english is not that good (I'm flemish speaking belgian)
but I guess I could make myself understanable ...
I'm also following german voip groups, hence I'm just transmitting
(translating) thungs I learned over there

rgds
Philippe


 
Reply With Quote
 
Jono
Guest
Posts: n/a
 
      03-31-2007
on 31/03/2007, Philippe Deleye supposed :
> "Jono" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed). ..
>> Not sure I've seen you get anything wrong yet & it hasn't happened this
>> time either.
>>

> Is this a compliment ?? Thanks a lot
> Happy to know that I could help
> I must admit that my english is not that good (I'm flemish speaking belgian)
> but I guess I could make myself understanable ...
> I'm also following german voip groups, hence I'm just transmitting
> (translating) thungs I learned over there
>
> rgds
> Philippe


Obviously rushing when typing the above..?

For a moment, I wondered what a Flemish was that spoke Belgian .
English - what an odd language.

It was most definitely a compliment, yes.

Thanks for your input & make sure you come back here!


 
Reply With Quote
 
Matt
Guest
Posts: n/a
 
      04-05-2007
On Mar 31, 7:41 pm, "Matt" <(E-Mail Removed)> wrote:
> On Mar 31, 4:08 pm, "Matt" <(E-Mail Removed)> wrote:
>
>
>
> > On Mar 31, 2:47 pm, Jono <(E-Mail Removed)> wrote:

>
> > > on 31/03/2007, Matt supposed :

>
> > > > It lets me verify my other numbers, but not the 08704 number. Very
> > > > strange...

>
> > > > Now getting Trixbox to use that details seems to be another challenge!

>
> > > > Do you set the outgoing id in the extension or the trunk? Or both?
> > > > Which format are you using? 00441827, 441827 or 01827?

>
> > > Here's my voipcheap.com trunk. As you can see that the CLID is set in
> > > my trunk, not in the extensions.

>
> > > PEER Details:
> > > allow=ulaw&alaw
> > > authuser=username
> > > disallow=all
> > > dtmfmode=rfc2833
> > > fromdomain=voipcheap.com
> > > fromuser=00448700xxxxxx
> > > host=sip.voipcheap.com
> > > insecure=very
> > > nat=yes
> > > qualify=yes
> > > secret=password
> > > type=friend
> > > username=username

>
> > Cheers Jono,

>
> > Will try those settings later.

>
> > Ta!

>
> > Matt- Hide quoted text -

>
> > - Show quoted text -

>
> That sorted it.
>
> Just need to find a way of setting the clid on an extension be
> extension basis....
>
> Cheers Jono!


In answer to my own question....

If you remove the fromuser definition in the trunk, and set the CLID
in the extension, is all seems to work and pass out the extenstion
CLID!

Hope this helps someone else.

Thanks

Matthew

 
Reply With Quote
 
Jono
Guest
Posts: n/a
 
      04-05-2007
Matt was thinking very hard :

>
> In answer to my own question....
>
> If you remove the fromuser definition in the trunk, and set the CLID
> in the extension, is all seems to work and pass out the extenstion
> CLID!
>
> Hope this helps someone else.
>
> Thanks
>
> Matthew


Interesting.

Pity only 5 numbers can be added.....


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Order notes starting at C thru B rather than A thru G Max Williams Ruby 3 01-06-2009 11:37 AM
RDP thru Cisco VPN client and thru 501 Failure curttampa@gmail.com Cisco 21 08-26-2008 03:11 PM
Can't access Web Service thru DLL (but can thru Windows App) THTB ASP .Net Web Services 0 05-17-2007 06:43 PM
VS2005 "Add Web Reference" "Unable to connect to the remote server", then successfully displays the service info. Add reference button is disabled. Connecting to WS outside of VS is fast. BobC ASP .Net Web Services 1 01-25-2007 02:27 PM
Can't get function caller if the caller is from a function within a popup window Mark Javascript 2 04-03-2004 07:57 AM



Advertisments