Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > HTML > IE 6 'display:block' problem

Reply
Thread Tools

IE 6 'display:block' problem

 
 
prash.marne@gmail.com
Guest
Posts: n/a
 
      03-28-2007
hello,
i am creating a simple image map & my HTML code is ..

<html>
<head>
<style type="text/css">
#main-box a.us {
position: relative;
top: -248px;
left: 130px;
background-color: none;
display: block;
width: 93px;
height: 17px;
}
</style>
</head>
<body>
<div id="main-box" style="border: 1px solid #000000">
<div class="map">
<img src="./map.gif" type="image/gif" usemap="#map1"
alt="map">
<a href="#" class="us"><img src="./united-states.gif" ></
a>
<map name="map1">
<area alt="" shape="poly"
coords="83,119,124,123,196,131" href="#">
</map>
</div>
</div>
</body>
</html>

it's working fine for all he browser ecxept IE 6
On IE 6 it takes some additional space at the bottom of the map image
I tried placing text insted of image for <a> it works fine
also if i remove display:block it works fine , but can't remove it ...
(on IE 7 also it works fine)

Is it IE 6 problem...? i am going wrong somwhere...??
or is there any substitute for 'display:block' ...??
plz help.......

Thanks ,
Prashant.

 
Reply With Quote
 
 
 
 
Jim Moe
Guest
Posts: n/a
 
      03-28-2007
http://www.velocityreviews.com/forums/(E-Mail Removed) wrote:
> hello,
> i am creating a simple image map & my HTML code is ..
>

Post an URL to a test case.
>
> it's working fine for all he browser ecxept IE 6
> On IE 6 it takes some additional space at the bottom of the map image
>

If the posted code is your complete page, you are missing a DTD
(doctype), and a <title>. HTML Strict is appropriate. Otherwise browsers
switch a Quirks mode where all sorts of unusual behavior happens.

--
jmm (hyphen) list (at) sohnen-moe (dot) com
(Remove .AXSPAMGN for email)
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem problem problem :( Need Help Mike ASP General 2 05-11-2004 08:36 AM



Advertisments