Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Unable to get VoIP QoS working on PIX

Reply
Thread Tools

Unable to get VoIP QoS working on PIX

 
 
mhoppes@gmail.com
Guest
Posts: n/a
 
      03-27-2007
I am attempting to get VoIP QoS running on a Cisco PIX. It's not
working.

Running 7.0(1) It is a PIX-515

Config:
interface Ethernet0
nameif outside
security-level 0
ip address xxx.xxx.xxx.98 255.255.255.224
!

access-list 109 extended permit udp any any eq 4569

class-map VOIP
match access-list 109
(also tried) match port udp eq 4569
!
policy-map VOIP
class VOIP
priority
!
service-policy VOIP interface outside

Any ideas as to why this is not working?
access-list 109; 1 elements
access-list 109 line 1 extended permit udp any any eq 4569 (hitcnt=0)

 
Reply With Quote
 
 
 
 
headsetadapter.com
Guest
Posts: n/a
 
      03-28-2007
Why are you trying to match the only one UDP Port (4569)? UDP Port 4569 is
used by IAX2 protocol between two Asterisk boxes, and usually it does not
require QoS. However you need QoS for RTP traffic, which uses dynamic UDP
ports in the range >15000 (in case you use a standard Asterisk
configuration), and ports above 16356 in case of Cisco IP Phones. So, it
would be better if you either specify other access-list, or use another
parameter for selecting traffic (for example, use DSCP value). Here is a
Cisco example, how to configure QoS over VPN on PIX 7.x code:

http://www.cisco.com/en/US/products/...8080dfa7.shtml

Mike
CCNP, CCDP, CCSP, Cisco Voice, MCSE W2K, MCSE+I, Security+, Sun SCSA,
Checkpoint CCSA, etc.
CCIE R&S (in progress), CCIE Voice (in progress)
------
Headset Adapters for Cisco IP Phones
www.ciscoheadsetadapter.com
www.headsetadapter.com


<(E-Mail Removed)> wrote in message
news:(E-Mail Removed) ups.com...
>I am attempting to get VoIP QoS running on a Cisco PIX. It's not
> working.
>
> Running 7.0(1) It is a PIX-515
>
> Config:
> interface Ethernet0
> nameif outside
> security-level 0
> ip address xxx.xxx.xxx.98 255.255.255.224
> !
>
> access-list 109 extended permit udp any any eq 4569
>
> class-map VOIP
> match access-list 109
> (also tried) match port udp eq 4569
> !
> policy-map VOIP
> class VOIP
> priority
> !
> service-policy VOIP interface outside
>
> Any ideas as to why this is not working?
> access-list 109; 1 elements
> access-list 109 line 1 extended permit udp any any eq 4569 (hitcnt=0)
>



 
Reply With Quote
 
 
 
 
mhoppes@gmail.com
Guest
Posts: n/a
 
      03-28-2007
You are correct, it is IAX. The reason we are trying to QoS the IAX2
traffic is because there is a single T1 line. Often the T1 will
become saturated. When this happens, VoIP call quality (over IAX)
breaks up. We are trying to assure that the VoIP calls have priority
over data traffic.

Do you have a better solution.

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
QOS for VOIP using 768k of FR / Auto QOS Andrew Albert Cisco 7 02-09-2005 07:42 PM



Advertisments