Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Windows 64bit > COM component not working

Reply
Thread Tools

COM component not working

 
 
Freddy Chavez
Guest
Posts: n/a
 
      05-07-2006
Hi guys. I have a COM component developed in VB6 which works fine on
Win2000.
It's nothing unusual: a DLL file, a COM package and an application
instancing that component.

Now I'm trying to make it work on Win2003 R2 64-bit but it's not working.
Whenever I try to instance the object it says:

Error No: 424
Origen: Microsoft VBScript runtime error
Descripción: Object required

I tried everything con the "Componente Services":
- unselect "enforce access checks..."
- activate the component with an administrator user
- make the user as a member of "distributed com users" local group

I don't know if it's a problem related to Win2003 R2 or related to 64-bit.
Any help would be appreciated. Thanks a lot!!!.

Regards,
Freddy Chavez.


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Remoting Component --> Com+ Component: Karuppasamy ASP .Net 0 01-15-2004 10:21 AM
com+ component and Component Service Karuppasamy ASP .Net 1 01-14-2004 11:30 PM
com+ component and Component Service Karuppasamy ASP .Net 0 01-13-2004 06:09 PM
using client-side component keeps calling component's init Jim Hammond ASP .Net 1 11-12-2003 08:13 PM
Re: Calling a .NET component from a COM component remotely Soni ASP .Net 0 07-25-2003 04:33 AM



Advertisments