Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Windows 64bit > Dual boot can't load x64 w/o CD in boot drive.

Reply
Thread Tools

Dual boot can't load x64 w/o CD in boot drive.

 
 
Jud Hendrix
Guest
Posts: n/a
 
      05-23-2005
On Thu, 19 May 2005 15:34:02 -0700, Lanurd
<(E-Mail Removed)> wrote:

>Wow, fixed this issue on my PC by setting the BIOS to boot from the Win XP
>Pro 32bit drive rather than the 64bit drive. Seems Windows installed a dual
>boot .ini file on the 32bit drive and nothing on the 64bit drive. I can
>select either at bootup and both work now with no CD mounted.


Well, I had the same problem. Installed 64 on another partition, and
everything worked fine. Then decided in an idle moment to do a clean
install of 32, and then the system didn't want to boot into 64 with
same error as the OP. I ended up by copying the "ntldr" file from 64
to the 32 C-drive (overwriting the one on there, which was a different
one), and now the system boots in 64 again as well

jud

 
Reply With Quote
 
 
 
 
=?Utf-8?B?RGVidWdnZXI=?=
Guest
Posts: n/a
 
      05-29-2005
There is a small bug when you install dual boot in Windows. For some reason,
Windows tries to put the system folder in BOOT.INI file in a different place
when you do dual boot.

Look for the file BOOT.INI in the system root:

[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windo ws XP Professional x64
Edition" /noexecute=optin /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINXP="Windows XP Professional"
/noexecute=optin /fastdetect

You need to redirect the Windows folder or partition to the correct place
editing this file. Note that exists partition(1)\WINDOWS and \WINXP but the
WINXP one is in another drive.


"Jud Hendrix" wrote:

> On Thu, 19 May 2005 15:34:02 -0700, Lanurd
> <(E-Mail Removed)> wrote:
>
> >Wow, fixed this issue on my PC by setting the BIOS to boot from the Win XP
> >Pro 32bit drive rather than the 64bit drive. Seems Windows installed a dual
> >boot .ini file on the 32bit drive and nothing on the 64bit drive. I can
> >select either at bootup and both work now with no CD mounted.

>
> Well, I had the same problem. Installed 64 on another partition, and
> everything worked fine. Then decided in an idle moment to do a clean
> install of 32, and then the system didn't want to boot into 64 with
> same error as the OP. I ended up by copying the "ntldr" file from 64
> to the 32 C-drive (overwriting the one on there, which was a different
> one), and now the system boots in 64 again as well
>
> jud
>
>

 
Reply With Quote
 
 
 
 
=?Utf-8?B?amFja2Zyb3N0?=
Guest
Posts: n/a
 
      05-29-2005
Have similar situation here in that I install XP 64 and it installs and runs
great until I install XP Pro , bingo, the XP pro 32 boots but XP64 does not.
If I reinstall XP 64 It boots perfect, but, XP32 no longer is listed as
part of the dual boot. I have Nvidia Nforce 3. I sure will be glad when this
is solved.


Richard

"Debugger" wrote:

> There is a small bug when you install dual boot in Windows. For some reason,
> Windows tries to put the system folder in BOOT.INI file in a different place
> when you do dual boot.
>
> Look for the file BOOT.INI in the system root:
>
> [operating systems]
> multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windo ws XP Professional x64
> Edition" /noexecute=optin /fastdetect
> multi(0)disk(0)rdisk(0)partition(1)\WINXP="Windows XP Professional"
> /noexecute=optin /fastdetect
>
> You need to redirect the Windows folder or partition to the correct place
> editing this file. Note that exists partition(1)\WINDOWS and \WINXP but the
> WINXP one is in another drive.
>
>
> "Jud Hendrix" wrote:
>
> > On Thu, 19 May 2005 15:34:02 -0700, Lanurd
> > <(E-Mail Removed)> wrote:
> >
> > >Wow, fixed this issue on my PC by setting the BIOS to boot from the Win XP
> > >Pro 32bit drive rather than the 64bit drive. Seems Windows installed a dual
> > >boot .ini file on the 32bit drive and nothing on the 64bit drive. I can
> > >select either at bootup and both work now with no CD mounted.

> >
> > Well, I had the same problem. Installed 64 on another partition, and
> > everything worked fine. Then decided in an idle moment to do a clean
> > install of 32, and then the system didn't want to boot into 64 with
> > same error as the OP. I ended up by copying the "ntldr" file from 64
> > to the 32 C-drive (overwriting the one on there, which was a different
> > one), and now the system boots in 64 again as well
> >
> > jud
> >
> >

 
Reply With Quote
 
Jud Hendrix
Guest
Posts: n/a
 
      05-29-2005
On Sun, 29 May 2005 16:27:01 -0700, jackfrost
<(E-Mail Removed)> wrote:

>Have similar situation here in that I install XP 64 and it installs and runs
>great until I install XP Pro , bingo, the XP pro 32 boots but XP64 does not.
>If I reinstall XP 64 It boots perfect, but, XP32 no longer is listed as
>part of the dual boot. I have Nvidia Nforce 3. I sure will be glad when this
>is solved.


Make sure your "boot.ini" and "ntldr" (the 64-bit version, which you
find on the x64-CD in the "I386"-directory) are in your 32-bit
root-partition. Check if your boot.ini is set-up correct (do a "map
arc" from the recovery console, and compare this one with your
"boot.ini").

jud

 
Reply With Quote
 
=?Utf-8?B?amFja2Zyb3N0?=
Guest
Posts: n/a
 
      05-30-2005
Success at last! Decided to Install XP 64 I last time. Change Partitions
and installed. Bingo! So far so goodit is running great. It may be a fluke,
but it worked for me.

"Jud Hendrix" wrote:

> On Sun, 29 May 2005 16:27:01 -0700, jackfrost
> <(E-Mail Removed)> wrote:
>
> >Have similar situation here in that I install XP 64 and it installs and runs
> >great until I install XP Pro , bingo, the XP pro 32 boots but XP64 does not.
> >If I reinstall XP 64 It boots perfect, but, XP32 no longer is listed as
> >part of the dual boot. I have Nvidia Nforce 3. I sure will be glad when this
> >is solved.

>
> Make sure your "boot.ini" and "ntldr" (the 64-bit version, which you
> find on the x64-CD in the "I386"-directory) are in your 32-bit
> root-partition. Check if your boot.ini is set-up correct (do a "map
> arc" from the recovery console, and compare this one with your
> "boot.ini").
>
> jud
>
>

 
Reply With Quote
 
=?Utf-8?B?TW9iaXVz?=
Guest
Posts: n/a
 
      06-02-2005
I had the exact same problem as you did with an x64 migration. The problem
lies in the fack that the bootloader from your previous windows install is
still there secretly. After I formatted all my raid and spare drives it
removed all of that. So that the new 64 bit version never needed the cd to
load up anymore.

Hope that solves your problem.
Mobius
system:
3.5GHz AMD 64
1gig of OCZ dual channel ram
2 western digital raptor 10,000 rpm drives on raid 2
1 western digital 20gig drive
msi k8n neo 2 platinum
msi 128 Geforce FX 9800xt
sound blaster audigy 2
koolance case full tower

"jackfrost" wrote:

> Success at last! Decided to Install XP 64 I last time. Change Partitions
> and installed. Bingo! So far so goodit is running great. It may be a fluke,
> but it worked for me.
>
> "Jud Hendrix" wrote:
>
> > On Sun, 29 May 2005 16:27:01 -0700, jackfrost
> > <(E-Mail Removed)> wrote:
> >
> > >Have similar situation here in that I install XP 64 and it installs and runs
> > >great until I install XP Pro , bingo, the XP pro 32 boots but XP64 does not.
> > >If I reinstall XP 64 It boots perfect, but, XP32 no longer is listed as
> > >part of the dual boot. I have Nvidia Nforce 3. I sure will be glad when this
> > >is solved.

> >
> > Make sure your "boot.ini" and "ntldr" (the 64-bit version, which you
> > find on the x64-CD in the "I386"-directory) are in your 32-bit
> > root-partition. Check if your boot.ini is set-up correct (do a "map
> > arc" from the recovery console, and compare this one with your
> > "boot.ini").
> >
> > jud
> >
> >

 
Reply With Quote
 
Aldo Bleeker
Guest
Posts: n/a
 
      06-05-2005
If you install XP x32 AFTER x64, x32 will overwrite the boot files
Ntdetect.com, and Ntldr (no extension). This will allow x32 to boot, but
x64 won't, as it needs the newer x64 versions. This is because the x32
version naturally isn't upwards compatible, while the x64 one is
downwards compatible. In other words, the x64 files will boot both x32,
and x64, while the x32 files will only boot x32, and will give this very
error message when trying to boot x64.

This one has bitten me a number of times, even though I know about this
issue. The solution is simple, you don't even have to install anything,
just take Ntdetect.com, and Ntldr from the x64 CD, and copy them to the
boot disk, overwriting the older x32 versions. Recheck Boot.ini (it
doesn't hurt to that at this time), reboot, and you'll be able to boot
both x32, and x64!

BTW, reinstalling x64 will work as well, because it will install the new
boot files as well, but it's a bit of overkill for this particular problem.

In general, to boot alle OS'es, you always need to install the newest
boot files, as they're downwards compatible, but not upwards compatible.

Aldo Bleeker

aimbie wrote:
> I have loaded x64 in a dual boot with WinXp 32 bit. The 32 bit version works
> fine, but I can't boot into the x64 version without setting bios to boot
> from the CD first and have the x64 install CD in the drive. If I don't have
> the CD in or set the computer to boot from hard drive or removeable drive I
> get the following message:
>
> "Windows could not start because the following file is missing or corrupt:
> <Windows root>\System32\ntoskrnl.exe. Please re-install a copy of the above
> file."
>
> My system specs:
>
> CoolerMaster CM Stacker
> Thermaltake Purepower 680W
> ASUS A8N-SLI Deluxe (Rev. 1.2) Bios 1007
> AMD 64 FX53 - ADAFX53DEP5AS
> Thermaltake Venus 12
> Corsair TWINX 1024 - 3200XL PRO
> 2 x eVga 6800 Ultra PCIe
> Audigy 2
> Nvidia SATA Drives:
> WD 74GB Raptor - WinXP SP2 - nForce 6.53 - video 73.00
> WD 74GB Raptor - WinXP x64 - nForce 6.56 - video 76.71
> Maxtor Diamond 10 250GB
> 2 X 80GB Seagate SATA drives-RAID 1 - Silicon Image
> Pioneer DVD-RW DVR-108
> Plextor DVDR PX-716A
> Mitsumi floppy drive
> Samsung 213T
>
> Any Ideas what could be causing this, it is annoying to have to keep the CD
> in the drive.
>
>

 
Reply With Quote
 
R. C. White
Guest
Posts: n/a
 
      07-15-2005
BINGO!!

Aldo is right!

The Golden Rule in dual-booting is: Always install the newest Windows LAST.

It's not necessary to install the oldest first, as sometimes stated, but it
is essential that the latest install is of the latest version. Otherwise,
you must - as Aldo said - repair the installation by updating the startup
files NTLDR and NTDETECT.COM.

Every NT-based Windows since NT4 (which is where I got on board) has used
the same 3 filenames to start the computer and load whichever version(s) of
Windows is installed on the computer. But even though the filenames are the
same, the file contents are different! For example, my latest NTLDR for
WinXP x86 was 233,632 bytes, dated 3/31/03; for WinXP x64, NTLDR is 295,536
bytes, dated 3/25/05. For NTDETECT.COM, the file sizes were 47,580 and
47,772.

When Win2K's NTLDR was written, WinXP did not exist so, naturally, that
version of NTLDR has no instructions for loading WinXP. Likewise, the older
WinXP Pro version of NTLDR has no idea how to load the x64 version. But the
latest version of NTLDR knows about all the prior versions.

Whenever we boot from the CD-ROM and install WinXP, Setup writes NTLDR,
etc., to the first Active partition on the first HD (as HDs are enumerated
at that time) - typically C: - no matter where we tell it to install the
rest of WinXP. If the usual first HD is unplugged (or disabled or otherwise
changed the boot sequence in the BIOS) before booting from the CD-ROM, then
NTLDR, etc., cannot be written to the disabled HD. They will be written to
whichever was the first Active (bootable) partition on the first HD active
at the time of booting from the CD. When the original HD (with the x86
NTLDR) was reenabled and the computer rebooted, it would still have had the
old NTLDR (and perhaps the old Boot.ini). As Aldo said, it would not have
known anything about x64, so it could not show it on the menu. Even if the
active copy of Boot.ini had been used, the x86 version of NTDETECT.COM would
not have known how to load x64. But when booting from the CD, the x64
version of those files would have been loaded and would have known how to
handle it.

Always install the newest Windows last - or repair the startup files later.

RC
--
R. C. White, CPA
San Marcos, TX
http://www.velocityreviews.com/forums/(E-Mail Removed)
Microsoft Windows MVP

"Aldo Bleeker" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> If you install XP x32 AFTER x64, x32 will overwrite the boot files
> Ntdetect.com, and Ntldr (no extension). This will allow x32 to boot, but
> x64 won't, as it needs the newer x64 versions. This is because the x32
> version naturally isn't upwards compatible, while the x64 one is downwards
> compatible. In other words, the x64 files will boot both x32, and x64,
> while the x32 files will only boot x32, and will give this very error
> message when trying to boot x64.
>
> This one has bitten me a number of times, even though I know about this
> issue. The solution is simple, you don't even have to install anything,
> just take Ntdetect.com, and Ntldr from the x64 CD, and copy them to the
> boot disk, overwriting the older x32 versions. Recheck Boot.ini (it
> doesn't hurt to that at this time), reboot, and you'll be able to boot
> both x32, and x64!
>
> BTW, reinstalling x64 will work as well, because it will install the new
> boot files as well, but it's a bit of overkill for this particular
> problem.
>
> In general, to boot alle OS'es, you always need to install the newest boot
> files, as they're downwards compatible, but not upwards compatible.
>
> Aldo Bleeker
>
> aimbie wrote:
>> I have loaded x64 in a dual boot with WinXp 32 bit. The 32 bit version
>> works fine, but I can't boot into the x64 version without setting bios to
>> boot from the CD first and have the x64 install CD in the drive. If I
>> don't have the CD in or set the computer to boot from hard drive or
>> removeable drive I get the following message:
>>
>> "Windows could not start because the following file is missing or
>> corrupt: <Windows root>\System32\ntoskrnl.exe. Please re-install a copy
>> of the above file."
>>
>> My system specs:
>>
>> CoolerMaster CM Stacker
>> Thermaltake Purepower 680W
>> ASUS A8N-SLI Deluxe (Rev. 1.2) Bios 1007
>> AMD 64 FX53 - ADAFX53DEP5AS
>> Thermaltake Venus 12
>> Corsair TWINX 1024 - 3200XL PRO
>> 2 x eVga 6800 Ultra PCIe
>> Audigy 2
>> Nvidia SATA Drives:
>> WD 74GB Raptor - WinXP SP2 - nForce 6.53 - video 73.00
>> WD 74GB Raptor - WinXP x64 - nForce 6.56 - video 76.71
>> Maxtor Diamond 10 250GB
>> 2 X 80GB Seagate SATA drives-RAID 1 - Silicon Image
>> Pioneer DVD-RW DVR-108
>> Plextor DVDR PX-716A
>> Mitsumi floppy drive
>> Samsung 213T
>>
>> Any Ideas what could be causing this, it is annoying to have to keep the
>> CD in the drive.




 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
to dual boot or not to dual boot Hugh Sutherland Computer Support 5 01-21-2010 09:37 PM
dual boot or not to dual boot Hugh Sutherland Computer Support 1 01-20-2010 10:10 PM
Dual Boot/Dual HDD Me@WMe@w.Kitty.kitty.kitty Computer Support 4 12-11-2007 06:49 PM
64-bit dual core: vista business x64 or XP Pro x64? Jon Windows 64bit 1 05-29-2007 06:53 PM
NetGear SPH200D dual Dual-mode, Cordless Phone vs Dualphone 3088 dual mode cordless phone Paul NZ Computing 0 05-08-2007 09:06 AM



Advertisments