Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Firefox > Weird error messages with shell integration in Windows XP

Reply
Thread Tools

Weird error messages with shell integration in Windows XP

 
 
Zaghadka
Guest
Posts: n/a
 
      03-24-2007
This one cropped up just the other day. Every time I launch a .URL file
(Internet Shortcut) from the Windows shell, and the Firefox browser is not
already open, I get an error message:

"Windows cannot find '[full url here]'. Make sure you typed the name correctly,
and then try again. To search for a file, click the Start button, and then
click Search." [Dialogue button: OK]

(whatever url, e.g. http://www.yahoo.com, appears as the [full url here])

The same happens when I type a web address into the "Run..." dialogue. It does
not happen when I double-click a URL from within Agent, however.

Nevermind that it actually works, and the web page is opened in Firefox, but if
the browser is not already open to begin with, Windows generates this clearly
bogus error message on my machine.

Of course, entering "Set Program Access and Defaults" and chosing "IE" as my
default browser clears the problem up right away. Except that it launches IE,
of course.

Changing it back wasn't easy either, because Firefox also no longer shows up in
the "Choose a Default Web Browser" section of the "Set Defaults" applet. I'm
not sure it ever did, but that may be the source of the problem. Several
reinstalls of Firefox did not fix this problem.

I'm using version 2.0.0.3, and a revert to 2.0.0.2 also didn't fix the problem,
so this is apparently Microsoft's problem, as it just stopped working
yesterday. I am using the latest version of IE 6, instead of IE 7, BTW. Windows
XP SP2.

I've tried reassociating "URL" files to "open" with "path:\firefox.exe %L," and
going directly to regedit and changing the .URL association entry from
"InternetShortcut" to "FirefoxURL" and get the exact same problem. Error
message, but the URL otherwise opens fine.

Is this happening on anyone else's machine? It is completely annoying, and
given MS's track record, I doubt it is any "bug" on the part of the Mozilla
team, but rather a direct attempt by Microsoft to make using the Firefox
browser annoying. They are asserting their "ownership" of *my* desktop, in
other words. I am not pleased.

I can find nothing on Bugzilla, nor do I fully understand how to report a bug
to Bugzilla. There should be a simple way to anonymously post a bug to a
moderator, but it doesn't seem to exist.

Thanks for your time.

--
Zag


"The Ends Justify The Means" ~Niccolo Machiavelli, c. 1550

"The Means Justify The Means" ~George W. Bush, c. 2000
 
Reply With Quote
 
 
 
 
Peter.Potamus.the.Purple.Hippo@gmail.com
Guest
Posts: n/a
 
      03-24-2007
On Mar 23, 10:13 pm, Zaghadka <(E-Mail Removed)> wrote:
> This one cropped up just the other day. Every time I launch a .URL file
> (Internet Shortcut) from the Windows shell, and the Firefox browser is not
> already open, I get an error message:
>
> "Windows cannot find '[full url here]'. Make sure you typed the name correctly,
> and then try again. To search for a file, click the Start button, and then
> click Search." [Dialogue button: OK]
>
> (whatever url, e.g.http://www.yahoo.com, appears as the [full url here])
>
> The same happens when I type a web address into the "Run..." dialogue. It does
> not happen when I double-click a URL from within Agent, however.
>
> Nevermind that it actually works, and the web page is opened in Firefox, but if
> the browser is not already open to begin with, Windows generates this clearly
> bogus error message on my machine.
>
> Of course, entering "Set Program Access and Defaults" and chosing "IE" as my
> default browser clears the problem up right away. Except that it launches IE,
> of course.
>
> Changing it back wasn't easy either, because Firefox also no longer shows up in
> the "Choose a Default Web Browser" section of the "Set Defaults" applet. I'm
> not sure it ever did, but that may be the source of the problem. Several
> reinstalls of Firefox did not fix this problem.
>


stop uninstalling and reinstalling. Thats not the problem. All your
settings, prefs, bookmarks, etc, are stored in an area called the FF
profile. The profile is located separate from the program. When you
uninstall, all you're doing is removing the program. The profile is
not touched. This is where your problem is.

To set FF as the default, look under Tools, Options, General and it
should be right in the middle

> I'm using version 2.0.0.3, and a revert to 2.0.0.2 also didn't fix the problem,
> so this is apparently Microsoft's problem, as it just stopped working
> yesterday. I am using the latest version of IE 6, instead of IE 7, BTW. Windows
> XP SP2.
>
> I've tried reassociating "URL" files to "open" with "path:\firefox.exe %L," and


that should be %1 [one], and it should be in quotation marks, and you
need to put the full path in. It should be something like this:

"C:\Program Files\mozilla.org\SeaMonkey\seamonkey.exe" -url "%1"



 
Reply With Quote
 
 
 
 
Zaghadka
Guest
Posts: n/a
 
      03-25-2007
On 23 Mar 2007 22:40:43 -0700, in alt.fan.mozilla,
http://www.velocityreviews.com/forums/(E-Mail Removed) wrote:

>On Mar 23, 10:13 pm, Zaghadka <(E-Mail Removed)> wrote:
>> This one cropped up just the other day. Every time I launch a .URL file
>> (Internet Shortcut) from the Windows shell, and the Firefox browser is not
>> already open, I get an error message:
>>
>> "Windows cannot find '[full url here]'. Make sure you typed the name correctly,
>> and then try again. To search for a file, click the Start button, and then
>> click Search." [Dialogue button: OK]
>>
>> (whatever url, e.g.http://www.yahoo.com, appears as the [full url here])
>>
>> The same happens when I type a web address into the "Run..." dialogue. It does
>> not happen when I double-click a URL from within Agent, however.
>>
>> Nevermind that it actually works, and the web page is opened in Firefox, but if
>> the browser is not already open to begin with, Windows generates this clearly
>> bogus error message on my machine.
>>
>> Of course, entering "Set Program Access and Defaults" and chosing "IE" as my
>> default browser clears the problem up right away. Except that it launches IE,
>> of course.
>>
>> Changing it back wasn't easy either, because Firefox also no longer shows up in
>> the "Choose a Default Web Browser" section of the "Set Defaults" applet. I'm
>> not sure it ever did, but that may be the source of the problem. Several
>> reinstalls of Firefox did not fix this problem.
>>

>
>stop uninstalling and reinstalling. Thats not the problem. All your
>settings, prefs, bookmarks, etc, are stored in an area called the FF
>profile. The profile is located separate from the program.


Right, on my system the profile is located in "%USERPROFILE%\Application
Data\Mozilla\Firefox."

> When you
>uninstall, all you're doing is removing the program. The profile is
>not touched. This is where your problem is.
>

No. The problem appears to be with shell integration. As I mentioned, Firefox
launches just fine, the URL opens just fine, but if I don't already have the
browser open, then I get an error message for no apparent reason.

It's nothing more than an annoyance at this point.

>To set FF as the default, look under Tools, Options, General and it
>should be right in the middle
>

It is the default. I've even tried changing key .URL==InternetShortcut to
"FirefoxURL" and I get the same problem. I thought doing an end run around
shdocvw.dll would do the trick, but it doesn't.

However, Firefox no longer shows up in my "Set Program Access and Defaults"
applet. Do you know if that is normal?

>> I'm using version 2.0.0.3, and a revert to 2.0.0.2 also didn't fix the problem,
>> so this is apparently Microsoft's problem, as it just stopped working
>> yesterday. I am using the latest version of IE 6, instead of IE 7, BTW. Windows
>> XP SP2.
>>
>> I've tried reassociating "URL" files to "open" with "path:\firefox.exe %L," and

>
>that should be %1 [one], and it should be in quotation marks, and you
>need to put the full path in. It should be something like this:
>

%L (file link) and %1 (first batch argument) are actually the same thing in
this case. The default "InternetShortcut" command is:

rundll32.exe shdocvw.dll,OpenURL %l (That's a lower case "L", not 1)

They both work, but they both produce this annoying error message. I'll try
blowing away my FF profile directory next, but I get the feeling something odd
is happening on my machine. Don't know what I did, but it doesn't sound like
this is a common problem. ;^)

Thanks for your help.

--
Zag


"The Ends Justify The Means" ~Niccolo Machiavelli, c. 1550

"The Means Justify The Means" ~George W. Bush, c. 2000
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Re: How to pass shell variable to shell script from python Christian Heimes Python 0 02-27-2008 10:53 AM
Weird error messages with XP when launching URL files -- Success! Zaghadka Firefox 0 03-27-2007 01:44 AM
weird error messages on application exit =?iso-8859-1?B?aWFuYXLp?= Python 2 07-05-2006 04:24 AM
WinRAR 3.40 shell integration Thomas G. Madsen Windows 64bit 31 06-09-2005 03:01 PM
can I run unix shell command in the ModelSim shell? clinton__bill@hotmail.com VHDL 2 02-18-2005 10:04 PM



Advertisments