Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > QOS on 837 for SIP

Reply
Thread Tools

QOS on 837 for SIP

 
 
Brad
Guest
Posts: n/a
 
      03-23-2007
Hi everyone,

I have been trying to get some sort of usefull QOS working on my 837
router, so that VoIP traffic is not affected by other traffic on the
link. I am connected to a 512/128 ADSL connection.

I have been following the guide at
http://www.cisco.com/en/US/products/...html#wp1097357


This is what I have so far in my config...

!
class-map match-all voice
match ip precedence 5
!
!
policy-map LLQ
class voice
priority 64
class class-default
fair-queue
policy-map shape
class class-default
shape average 2250000
service-policy LLQ
!
interface Ethernet0
ip address 192.168.2.5 255.255.255.0
ip nat inside
ip virtual-reassembly
hold-queue 100 out
!
interface Ethernet2
no ip address
shutdown
hold-queue 100 out
!
interface ATM0
mtu 300
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
interface Dialer1
bandwidth 128
ip address negotiated
ip access-group 101 in
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp chap refuse
ppp pap sent-username XXX
ppp multilink
ppp multilink interleave
ppp multilink fragment-delay 10
!



I can apply the policy map LLQ to the dialer interface, and see that 'sh
policy-map int d1', shows that it is picking up the voice traffic
correctly, but the voice quality is terrible if anything else is using
the link at the same time.

The reference page says that 'shape average 128000' should be applied
under 'policy-map shape'. It lets me enter it without an error, but it
doesn't appear there in a 'sh run'

I can apply 'service-policy output shape' to the dialer interface,
without an error, but it also won't show up in a 'sh run'

Can anyone see what I am doing wrong?



 
Reply With Quote
 
 
 
 
Martin Bilgrav
Guest
Posts: n/a
 
      03-25-2007
Hi,

From what I understand, the Qos you are tying to do in not support in
virtuel interfaces:
read the note in the URL you are ref. to: CBTS is supported on the Ethernet
1 interface.

Also normally you would specify strict priority as LLQ, but this could
varify from IOS image.

Also read the part about the tx transmit ring in the ATM (same URL)
HTH
Martin

"Brad" <(E-Mail Removed)> wrote in message
news:46036984$(E-Mail Removed)...
> Hi everyone,
>
> I have been trying to get some sort of usefull QOS working on my 837
> router, so that VoIP traffic is not affected by other traffic on the link.
> I am connected to a 512/128 ADSL connection.
>
> I have been following the guide at
> http://www.cisco.com/en/US/products/...html#wp1097357
>
>
> This is what I have so far in my config...
>
> !
> class-map match-all voice
> match ip precedence 5
> !
> !
> policy-map LLQ
> class voice
> priority 64
> class class-default
> fair-queue
> policy-map shape
> class class-default
> shape average 2250000
> service-policy LLQ
> !
> interface Ethernet0
> ip address 192.168.2.5 255.255.255.0
> ip nat inside
> ip virtual-reassembly
> hold-queue 100 out
> !
> interface Ethernet2
> no ip address
> shutdown
> hold-queue 100 out
> !
> interface ATM0
> mtu 300
> no ip address
> no atm ilmi-keepalive
> dsl operating-mode auto
> pvc 8/35
> encapsulation aal5mux ppp dialer
> dialer pool-member 1
> !
> interface Dialer1
> bandwidth 128
> ip address negotiated
> ip access-group 101 in
> ip nat outside
> ip virtual-reassembly
> encapsulation ppp
> dialer pool 1
> dialer-group 1
> ppp authentication pap callin
> ppp chap refuse
> ppp pap sent-username XXX
> ppp multilink
> ppp multilink interleave
> ppp multilink fragment-delay 10
> !
>
>
>
> I can apply the policy map LLQ to the dialer interface, and see that 'sh
> policy-map int d1', shows that it is picking up the voice traffic
> correctly, but the voice quality is terrible if anything else is using the
> link at the same time.
>
> The reference page says that 'shape average 128000' should be applied
> under 'policy-map shape'. It lets me enter it without an error, but it
> doesn't appear there in a 'sh run'
>
> I can apply 'service-policy output shape' to the dialer interface, without
> an error, but it also won't show up in a 'sh run'
>
> Can anyone see what I am doing wrong?
>
>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VPN between Cisco 837 and cisco 837 with IP static and ip dinamic lyvicro@hotmail.com Cisco 4 12-15-2005 09:10 PM
QoS over 837. AM Cisco 0 12-06-2004 02:03 PM
Working: 837 Wake On Lan over internet using NAT (837) Richard Antony Burton Cisco 0 01-05-2004 10:08 AM
Cisco 837 to Cisco 837 VPN, ping OK, NetBios / VNC DROPPING! Suppa Lamah Cisco 8 12-19-2003 01:15 PM
Cisco 837-837 VPN Confused Cisco 0 07-09-2003 11:13 AM



Advertisments