Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Firefox > Firefox Remembering Passwords

Reply
Thread Tools

Firefox Remembering Passwords

 
 
yogi22
Guest
Posts: n/a
 
      03-19-2007
FF 2.0.0.2 Win2000

Tools > Options > Security > Remember Passwords for sites

I check this box, then go to site with a remembered password, and "All
is Good".

The next time I use FF, it doesn't work, so I look in Options/Security
and the box is unchecked. The happens every time.

In my paranoia, I may have checked some "added security feature" in
another program, and this is causing the problem. Any ideas out there?
kk

Ken Kennedy
London, ON

 
Reply With Quote
 
 
 
 
Peter.Potamus.the.Purple.Hippo@gmail.com
Guest
Posts: n/a
 
      03-19-2007
On Mar 18, 5:53 pm, "yogi22" <(E-Mail Removed)> wrote:
> FF 2.0.0.2 Win2000
>
> Tools > Options > Security > Remember Passwords for sites
>
> I check this box, then go to site with a remembered password, and "All
> is Good".
>
> The next time I use FF, it doesn't work, so I look in Options/Security
> and the box is unchecked. The happens every time.
>
> In my paranoia, I may have checked some "added security feature" in
> another program, and this is causing the problem. Any ideas out there?
> kk
>
> Ken Kennedy
> London, ON



close the program, and take a look in the FF profile. Make sure that
prefs.js, signons.txt [or signon2.txt], and key3.db aren't set to read
only.

 
Reply With Quote
 
 
 
 
yogi22
Guest
Posts: n/a
 
      03-19-2007
On Mar 19, 2:42 am, (E-Mail Removed) wrote:
> On Mar 18, 5:53 pm, "yogi22" <(E-Mail Removed)> wrote:
>
>
>
> > FF 2.0.0.2 Win2000

>
> > Tools > Options > Security > Remember Passwords for sites

>
> > I check this box, then go to site with a remembered password, and "All
> > is Good".

>
> > The next time I use FF, it doesn't work, so I look in Options/Security
> > and the box is unchecked. The happens every time.

>
> > In my paranoia, I may have checked some "added security feature" in
> > another program, and this is causing the problem. Any ideas out there?
> > kk

>
> > Ken Kennedy
> > London, ON

>
> close the program, and take a look in the FF profile. Make sure that
> prefs.js, signons.txt [or signon2.txt], and key3.db aren't set to read
> only.


Here is what I found in my profile

prefs.js Not Read-only
prefs-1.js Not Read-only
key3.db Not Read-only

There was no signons.txt or signon2.txt in the profile.
I thought I might be saved when I found a signons.txt in my Profile
Backup and it was not Read-only, so I copied it over to my profile.

Unfortunately, that did not work. Any other ideas? Thanx.
kk

Ken Kennedy
London, ON

 
Reply With Quote
 
Peter.Potamus.the.Purple.Hippo@gmail.com
Guest
Posts: n/a
 
      03-19-2007
On Mar 19, 6:22 am, "yogi22" <(E-Mail Removed)> wrote:
> On Mar 19, 2:42 am, (E-Mail Removed) wrote:
>
>
>
> > On Mar 18, 5:53 pm, "yogi22" <(E-Mail Removed)> wrote:

>
> > > FF 2.0.0.2 Win2000

>
> > > Tools > Options > Security > Remember Passwords for sites

>
> > > I check this box, then go to site with a remembered password, and "All
> > > is Good".

>
> > > The next time I use FF, it doesn't work, so I look in Options/Security
> > > and the box is unchecked. The happens every time.

>
> > > In my paranoia, I may have checked some "added security feature" in
> > > another program, and this is causing the problem. Any ideas out there?
> > > kk

>
> > > Ken Kennedy
> > > London, ON

>
> > close the program, and take a look in the FF profile. Make sure that
> > prefs.js, signons.txt [or signon2.txt], and key3.db aren't set to read
> > only.

>
> Here is what I found in my profile
>
> prefs.js Not Read-only
> prefs-1.js Not Read-only
> key3.db Not Read-only
>
> There was no signons.txt or signon2.txt in the profile.
> I thought I might be saved when I found a signons.txt in my Profile
> Backup and it was not Read-only, so I copied it over to my profile.
>
> Unfortunately, that did not work. Any other ideas? Thanx.
> kk
>
> Ken Kennedy
> London, ON



you can't copy just the signons.txt file, you also need the key3.db
file that goes with it. The passwords are stored in signons.txt or
signon2.txt file, and key3.db is the "key" to the file.

If you don't have either of those password files, then look for a file
that has an 8 digit number and ends in .s, such as 12345678.s. That
is an old password type of file. Is that marked as read only?

 
Reply With Quote
 
yogi22
Guest
Posts: n/a
 
      03-19-2007
On Mar 19, 1:35 pm, (E-Mail Removed) wrote:
> On Mar 19, 6:22 am, "yogi22" <(E-Mail Removed)> wrote:
>
>
>
> > On Mar 19, 2:42 am, (E-Mail Removed) wrote:

>
> > > On Mar 18, 5:53 pm, "yogi22" <(E-Mail Removed)> wrote:

>
> > > > FF 2.0.0.2 Win2000

>
> > > > Tools > Options > Security > Remember Passwords for sites

>
> > > > I check this box, then go to site with a remembered password, and "All
> > > > is Good".

>
> > > > The next time I use FF, it doesn't work, so I look in Options/Security
> > > > and the box is unchecked. The happens every time.

>
> > > > In my paranoia, I may have checked some "added security feature" in
> > > > another program, and this is causing the problem. Any ideas out there?
> > > > kk

>
> > > > Ken Kennedy
> > > > London, ON

>
> > > close the program, and take a look in the FF profile. Make sure that
> > > prefs.js, signons.txt [or signon2.txt], and key3.db aren't set to read
> > > only.

>
> > Here is what I found in my profile

>
> > prefs.js Not Read-only
> > prefs-1.js Not Read-only
> > key3.db Not Read-only

>
> > There was no signons.txt or signon2.txt in the profile.
> > I thought I might be saved when I found a signons.txt in my Profile
> > Backup and it was not Read-only, so I copied it over to my profile.

>
> > Unfortunately, that did not work. Any other ideas? Thanx.
> > kk

>
> > Ken Kennedy
> > London, ON

>
> you can't copy just the signons.txt file, you also need the key3.db
> file that goes with it. The passwords are stored in signons.txt or
> signon2.txt file, and key3.db is the "key" to the file.
>
> If you don't have either of those password files, then look for a file
> that has an 8 digit number and ends in .s, such as 12345678.s. That
> is an old password type of file. Is that marked as read only?


This time, I replaced both the key3.db and signons.txt in my profile
with the corresponding files from my backup profile. Still the same
negative result. I even tried restarting Windows. I just went back
into my profile, and I notice that there now is no signons.txt file,
but there is a signons2.txt file.

Would a non-geeky get-around be to remove all passwords from Security,
then restart FF and start all over again?

Is it possible that some security program has been inadvertently set
too high, and has modified registry or something to save me from the
folly of having saved passwords available on my desktop computer?
kk

Ken Kennedy
London, ON

 
Reply With Quote
 
yogi22
Guest
Posts: n/a
 
      03-19-2007
On Mar 19, 3:56 pm, "yogi22" <(E-Mail Removed)> wrote:
> On Mar 19, 1:35 pm, (E-Mail Removed) wrote:
>
>
>
> > On Mar 19, 6:22 am, "yogi22" <(E-Mail Removed)> wrote:

>
> > > On Mar 19, 2:42 am, (E-Mail Removed) wrote:

>
> > > > On Mar 18, 5:53 pm, "yogi22" <(E-Mail Removed)> wrote:

>
> > > > > FF 2.0.0.2 Win2000

>
> > > > > Tools > Options > Security > Remember Passwords for sites

>
> > > > > I check this box, then go to site with a remembered password, and "All
> > > > > is Good".

>
> > > > > The next time I use FF, it doesn't work, so I look in Options/Security
> > > > > and the box is unchecked. The happens every time.

>
> > > > > In my paranoia, I may have checked some "added security feature" in
> > > > > another program, and this is causing the problem. Any ideas out there?
> > > > > kk

>
> > > > > Ken Kennedy
> > > > > London, ON

>
> > > > close the program, and take a look in the FF profile. Make sure that
> > > > prefs.js, signons.txt [or signon2.txt], and key3.db aren't set to read
> > > > only.

>
> > > Here is what I found in my profile

>
> > > prefs.js Not Read-only
> > > prefs-1.js Not Read-only
> > > key3.db Not Read-only

>
> > > There was no signons.txt or signon2.txt in the profile.
> > > I thought I might be saved when I found a signons.txt in my Profile
> > > Backup and it was not Read-only, so I copied it over to my profile.

>
> > > Unfortunately, that did not work. Any other ideas? Thanx.
> > > kk

>
> > > Ken Kennedy
> > > London, ON

>
> > you can't copy just the signons.txt file, you also need the key3.db
> > file that goes with it. The passwords are stored in signons.txt or
> > signon2.txt file, and key3.db is the "key" to the file.

>
> > If you don't have either of those password files, then look for a file
> > that has an 8 digit number and ends in .s, such as 12345678.s. That
> > is an old password type of file. Is that marked as read only?

>
> This time, I replaced both the key3.db and signons.txt in my profile
> with the corresponding files from my backup profile. Still the same
> negative result. I even tried restarting Windows. I just went back
> into my profile, and I notice that there now is no signons.txt file,
> but there is a signons2.txt file.
>
> Would a non-geeky get-around be to remove all passwords from Security,
> then restart FF and start all over again?
>
> Is it possible that some security program has been inadvertently set
> too high, and has modified registry or something to save me from the
> folly of having saved passwords available on my desktop computer?
> kk
>
> Ken Kennedy
> London, ON


Having read your recent message recommending mozilla.support.firefox,
I popped over there for a look and there was a question about where
passwords were stored. The answer which I already knew from this
thread is signons.txt or signon2.txt file, and key3.db. I have these
files (or at least old ones) installed in my profile.

When I am in Security and click on "Show Passwords", they are all
there. The problem is the disappearing checkmark in "Remember
passwords for sites". IOW, FF is saving all the data, but is
forgetting that I want it automatically available every time I use FF.
IOW, might the solution lie in amending "about:config" or perhaps
"prefs.js. BTW, any illumination on what "prefs-1.js" is? I just
opened it with notepad, and it is blank. Is it safe to delete it?
kk

Ken Kennedy
London, ON

 
Reply With Quote
 
Peter.Potamus.the.Purple.Hippo@gmail.com
Guest
Posts: n/a
 
      03-19-2007
On Mar 19, 1:26 pm, "yogi22" <(E-Mail Removed)> wrote:
> On Mar 19, 3:56 pm, "yogi22" <(E-Mail Removed)> wrote:
>
>
>
> > On Mar 19, 1:35 pm, (E-Mail Removed) wrote:

>
> > > On Mar 19, 6:22 am, "yogi22" <(E-Mail Removed)> wrote:

>
> > > > On Mar 19, 2:42 am, (E-Mail Removed) wrote:

>
> > > > > On Mar 18, 5:53 pm, "yogi22" <(E-Mail Removed)> wrote:

>
> > > > > > FF 2.0.0.2 Win2000

>
> > > > > > Tools > Options > Security > Remember Passwords for sites

>
> > > > > > I check this box, then go to site with a remembered password, and "All
> > > > > > is Good".

>
> > > > > > The next time I use FF, it doesn't work, so I look in Options/Security
> > > > > > and the box is unchecked. The happens every time.

>
> > > > > > In my paranoia, I may have checked some "added security feature" in
> > > > > > another program, and this is causing the problem. Any ideas out there?
> > > > > > kk

>
> > > > > > Ken Kennedy
> > > > > > London, ON

>
> > > > > close the program, and take a look in the FF profile. Make sure that
> > > > > prefs.js, signons.txt [or signon2.txt], and key3.db aren't set to read
> > > > > only.

>
> > > > Here is what I found in my profile

>
> > > > prefs.js Not Read-only
> > > > prefs-1.js Not Read-only
> > > > key3.db Not Read-only

>
> > > > There was no signons.txt or signon2.txt in the profile.
> > > > I thought I might be saved when I found a signons.txt in my Profile
> > > > Backup and it was not Read-only, so I copied it over to my profile.

>
> > > > Unfortunately, that did not work. Any other ideas? Thanx.
> > > > kk

>
> > > > Ken Kennedy
> > > > London, ON

>
> > > you can't copy just the signons.txt file, you also need the key3.db
> > > file that goes with it. The passwords are stored in signons.txt or
> > > signon2.txt file, and key3.db is the "key" to the file.

>
> > > If you don't have either of those password files, then look for a file
> > > that has an 8 digit number and ends in .s, such as 12345678.s. That
> > > is an old password type of file. Is that marked as read only?

>
> > This time, I replaced both the key3.db and signons.txt in my profile
> > with the corresponding files from my backup profile. Still the same
> > negative result. I even tried restarting Windows. I just went back
> > into my profile, and I notice that there now is no signons.txt file,
> > but there is a signons2.txt file.

>
> > Would a non-geeky get-around be to remove all passwords from Security,
> > then restart FF and start all over again?

>
> > Is it possible that some security program has been inadvertently set
> > too high, and has modified registry or something to save me from the
> > folly of having saved passwords available on my desktop computer?
> > kk

>
> > Ken Kennedy
> > London, ON

>
> Having read your recent message recommending mozilla.support.firefox,
> I popped over there for a look and there was a question about where
> passwords were stored. The answer which I already knew from this
> thread is signons.txt or signon2.txt file, and key3.db. I have these
> files (or at least old ones) installed in my profile.
>
> When I am in Security and click on "Show Passwords", they are all
> there. The problem is the disappearing checkmark in "Remember
> passwords for sites". IOW, FF is saving all the data, but is
> forgetting that I want it automatically available every time I use FF.
> IOW, might the solution lie in amending "about:config" or perhaps
> "prefs.js. BTW, any illumination on what "prefs-1.js" is? I just
> opened it with notepad, and it is blank. Is it safe to delete it?
> kk
>
> Ken Kennedy
> London, ON



ah ha, now we might be getting somewhere. Why do you have more than
one prefs.js file? Are you sure that file isn't marked as Read Only?
Do you also have a prefs.bak, or prefs.moztemp, or prefs.temp, or
something similar? If so, then delete them all, and any other
prefs.js file you may have. Do this with the program closed. Any
difference?

If not, then in the about:config look for this entry:

signon.rememberSignons

and make sure its set to true. Close FF and reopen it. Any
difference?

If not, then close FF, and open the FF profile manager, click on
Start, Run and enter:

firefox.exe -p

create a test profile and start FF. Make sure that the password
setting is set. Close FF and copy over the signons.txt and key3.db
file to the new profile. Restart FF, are things now working?

If not, then I'm out of suggestions.

 
Reply With Quote
 
yogi22
Guest
Posts: n/a
 
      03-19-2007
On Mar 19, 4:51 pm, (E-Mail Removed) wrote:
> On Mar 19, 1:26 pm, "yogi22" <(E-Mail Removed)> wrote:
>
>
>
> > On Mar 19, 3:56 pm, "yogi22" <(E-Mail Removed)> wrote:

>
> > > On Mar 19, 1:35 pm, (E-Mail Removed) wrote:

>
> > > > On Mar 19, 6:22 am, "yogi22" <(E-Mail Removed)> wrote:

>
> > > > > On Mar 19, 2:42 am, (E-Mail Removed) wrote:

>
> > > > > > On Mar 18, 5:53 pm, "yogi22" <(E-Mail Removed)> wrote:

>
> > > > > > > FF 2.0.0.2 Win2000

>
> > > > > > > Tools > Options > Security > Remember Passwords for sites

>
> > > > > > > I check this box, then go to site with a remembered password, and "All
> > > > > > > is Good".

>
> > > > > > > The next time I use FF, it doesn't work, so I look in Options/Security
> > > > > > > and the box is unchecked. The happens every time.

>
> > > > > > > In my paranoia, I may have checked some "added security feature" in
> > > > > > > another program, and this is causing the problem. Any ideas out there?
> > > > > > > kk

>
> > > > > > > Ken Kennedy
> > > > > > > London, ON

>
> > > > > > close the program, and take a look in the FF profile. Make sure that
> > > > > > prefs.js, signons.txt [or signon2.txt], and key3.db aren't set to read
> > > > > > only.

>
> > > > > Here is what I found in my profile

>
> > > > > prefs.js Not Read-only
> > > > > prefs-1.js Not Read-only
> > > > > key3.db Not Read-only

>
> > > > > There was no signons.txt or signon2.txt in the profile.
> > > > > I thought I might be saved when I found a signons.txt in my Profile
> > > > > Backup and it was not Read-only, so I copied it over to my profile.

>
> > > > > Unfortunately, that did not work. Any other ideas? Thanx.
> > > > > kk

>
> > > > > Ken Kennedy
> > > > > London, ON

>
> > > > you can't copy just the signons.txt file, you also need the key3.db
> > > > file that goes with it. The passwords are stored in signons.txt or
> > > > signon2.txt file, and key3.db is the "key" to the file.

>
> > > > If you don't have either of those password files, then look for a file
> > > > that has an 8 digit number and ends in .s, such as 12345678.s. That
> > > > is an old password type of file. Is that marked as read only?

>
> > > This time, I replaced both the key3.db and signons.txt in my profile
> > > with the corresponding files from my backup profile. Still the same
> > > negative result. I even tried restarting Windows. I just went back
> > > into my profile, and I notice that there now is no signons.txt file,
> > > but there is a signons2.txt file.

>
> > > Would a non-geeky get-around be to remove all passwords from Security,
> > > then restart FF and start all over again?

>
> > > Is it possible that some security program has been inadvertently set
> > > too high, and has modified registry or something to save me from the
> > > folly of having saved passwords available on my desktop computer?
> > > kk

>
> > > Ken Kennedy
> > > London, ON

>
> > Having read your recent message recommending mozilla.support.firefox,
> > I popped over there for a look and there was a question about where
> > passwords were stored. The answer which I already knew from this
> > thread is signons.txt or signon2.txt file, and key3.db. I have these
> > files (or at least old ones) installed in my profile.

>
> > When I am in Security and click on "Show Passwords", they are all
> > there. The problem is the disappearing checkmark in "Remember
> > passwords for sites". IOW, FF is saving all the data, but is
> > forgetting that I want it automatically available every time I use FF.
> > IOW, might the solution lie in amending "about:config" or perhaps
> > "prefs.js. BTW, any illumination on what "prefs-1.js" is? I just
> > opened it with notepad, and it is blank. Is it safe to delete it?
> > kk

>
> > Ken Kennedy
> > London, ON

>
> ah ha, now we might be getting somewhere. Why do you have more than
> one prefs.js file? Are you sure that file isn't marked as Read Only?
> Do you also have a prefs.bak, or prefs.moztemp, or prefs.temp, or
> something similar? If so, then delete them all, and any other
> prefs.js file you may have. Do this with the program closed. Any
> difference?
>
> If not, then in the about:config look for this entry:
>
> signon.rememberSignons
>
> and make sure its set to true. Close FF and reopen it. Any
> difference?
>
> If not, then close FF, and open the FF profile manager, click on
> Start, Run and enter:
>
> firefox.exe -p
>
> create a test profile and start FF. Make sure that the password
> setting is set. Close FF and copy over the signons.txt and key3.db
> file to the new profile. Restart FF, are things now working?
>
> If not, then I'm out of suggestions.


I tried it all, with no luck

I went to about:config and found that signon.rememberSignons was set
to False so I reset it to True. I checked Security and Remember
passwords for sites was checked. I closed FF, then restarted, then
checked Security and "Remember passwords for sites" was now UNCHECKED,
so I checked in about:config and it had changed to FALSE, as expected.

The prefs-1.js file is NOT read-only and is empty. I don't know where
it came from, but perhaps a long time ago I was trying something out.
It is now deleted.

There are various prefs files in the extensions and gmanager
subfolders of the profile. However, in the Profile folder itself,
there is just the one prefs.js file. It is NOT Read Only.

After resetting Remember Passwords, then closing FF, then deleting the
prefs-1 file, then restarting FF, it once again turned itself off.

Then I tried a new profile. I opened the new FF, checked off Remember,
then closed it. Before copying anything to the new profile folder, I
reopened the new FF, and the checkmark was gone, gone, gone. After
closing, then copying over the signons file, I reopened the new FF,
found all the passwords had copied over, but despite repeated tries,
could not get the checkmark to stick.

IOW, I have learned a lot but am still stuck. Thanks for your efforts!
kk

Ken Kennedy
London, ON

 
Reply With Quote
 
Peter.Potamus.the.Purple.Hippo@gmail.com
Guest
Posts: n/a
 
      03-19-2007
On Mar 19, 2:42 pm, "yogi22" <(E-Mail Removed)> wrote:
> Then I tried a new profile. I opened the new FF, checked off Remember,
> then closed it. Before copying anything to the new profile folder, I
> reopened the new FF, and the checkmark was gone, gone, gone. After
> closing, then copying over the signons file, I reopened the new FF,
> found all the passwords had copied over, but despite repeated tries,
> could not get the checkmark to stick.


well, I'm stumped. I don't know where to go from here. When you
created a new profile, that clears the slate and starts you at square
one. If the new profile didn't work, then there must be something
else at work. Something within your computer preventing this. Maybe
its a firewall, a virus checker, a spyware scanner, or something
else. I really don't know where to go from here.

You might want to visit the mozilla.support.firefox newsgroup which is
on the news.mozilla.org server. Just tell them everything you have
done and gone through. Maybe someone there can help.

Check one more thing. Look under Privacy and see if you're deleting
the passwords as you close FF.

Otherwise, I'll see you in the other support group.

 
Reply With Quote
 
yogi22
Guest
Posts: n/a
 
      03-20-2007
On Mar 19, 6:29 pm, (E-Mail Removed) wrote:
> On Mar 19, 2:42 pm, "yogi22" <(E-Mail Removed)> wrote:
>
> > Then I tried a new profile. I opened the new FF, checked off Remember,
> > then closed it. Before copying anything to the new profile folder, I
> > reopened the new FF, and the checkmark was gone, gone, gone. After
> > closing, then copying over the signons file, I reopened the new FF,
> > found all the passwords had copied over, but despite repeated tries,
> > could not get the checkmark to stick.

>
> well, I'm stumped. I don't know where to go from here. When you
> created a new profile, that clears the slate and starts you at square
> one. If the new profile didn't work, then there must be something
> else at work. Something within your computer preventing this. Maybe
> its a firewall, a virus checker, a spyware scanner, or something
> else. I really don't know where to go from here.
>
> You might want to visit the mozilla.support.firefox newsgroup which is
> on the news.mozilla.org server. Just tell them everything you have
> done and gone through. Maybe someone there can help.
>
> Check one more thing. Look under Privacy and see if you're deleting
> the passwords as you close FF.
>
> Otherwise, I'll see you in the other support group.


Thank you for your help, Peter. I looked under Privacy, and as
expected that box is unchecked. The already saved passwords are not
disappearing, it's just that unless I manually check off "Remember
passwords for sites", FF doesn't offer to save passwords on new sites,
nor does it fill in the passwords on other sites.

It only started doing this recently, and I can't think of anything
I've done that might cause it. I'll be taking a rest on this for a
while, maybe trying a Restore and/or reporting to the other NG. I
promise to report, for your own edification.
kk

Ken Kennedy
London, ON

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Remembering passwords and bookmarklets History Fan Firefox 7 11-10-2006 12:00 AM
FireFox not saving passwords raindog Firefox 4 09-14-2004 08:25 AM
Remembering passwords to sites? Wizard Computer Information 8 06-29-2004 10:30 AM
Mozilla remembering my passwords coustanis Firefox 1 06-26-2004 01:12 PM
Remembering passwords (IE) joseph minelli Computer Support 1 06-17-2004 06:22 AM



Advertisments