Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Java > Java version & Applet

Reply
Thread Tools

Java version & Applet

 
 
pkoerner@online.de
Guest
Posts: n/a
 
      03-16-2007
Hi

I got some questions dealing with java-version in junction with
Applets.
When i compile an Applet with my jdk1.6 it can only be used when the
client machine also has at least version 1.6, is that correct?

Using the -target and -source-Switches I can force the compiler to
create a classfile matching a lower version, vor example [1] says -
source 1.2 -target 1.1 is the recommended setting for applets. This
disables features like generics, what would be okay, but how is it
about using packages like javax.swing.* od javax.xml.bind.*, which are
not part of i.e. jre1.1.

It seems that an Applet (or an Application either) would run without
having these classfiles present. So i have to pack the needes
classfiles out of the jars of my jre into my own jar-file.

So, if i want to write an Applet, which target version is really
recommended today (1.1 seems some kind of.. too old?) and how can I
find out which packages i have to pack into the jar.

Peter

 
Reply With Quote
 
 
 
 
Knute Johnson
Guest
Posts: n/a
 
      03-16-2007
http://www.velocityreviews.com/forums/(E-Mail Removed) wrote:
> Hi
>
> I got some questions dealing with java-version in junction with
> Applets.
> When i compile an Applet with my jdk1.6 it can only be used when the
> client machine also has at least version 1.6, is that correct?
>
> Using the -target and -source-Switches I can force the compiler to
> create a classfile matching a lower version, vor example [1] says -
> source 1.2 -target 1.1 is the recommended setting for applets. This
> disables features like generics, what would be okay, but how is it
> about using packages like javax.swing.* od javax.xml.bind.*, which are
> not part of i.e. jre1.1.
>
> It seems that an Applet (or an Application either) would run without
> having these classfiles present. So i have to pack the needes
> classfiles out of the jars of my jre into my own jar-file.
>
> So, if i want to write an Applet, which target version is really
> recommended today (1.1 seems some kind of.. too old?) and how can I
> find out which packages i have to pack into the jar.
>
> Peter
>


Since 1.3 has reached 'end of life' you will need to use version 1.4.
Just download the 1.4.2_?? JDK and write your Applets with that. The
-source and -target do not prevent you from using code that is from a
later version. They just create class files that are compatible with
the earlier version.

--

Knute Johnson
email s/nospam/knute/
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Version of JDK to develope the Applet VS version of JRE on client'sbrowser Krist Java 4 05-06-2010 01:20 AM
Re: Where to get stand alone Dot Net Framework version 1.1, version2.0, version 3.0, version 3.5, version 2.0 SP1, version 3.0 SP1 ? MowGreen [MVP] ASP .Net 5 02-09-2008 01:55 AM
Re: Where to get stand alone Dot Net Framework version 1.1, version 2.0, version 3.0, version 3.5, version 2.0 SP1, version 3.0 SP1 ? PA Bear [MS MVP] ASP .Net 0 02-05-2008 03:28 AM
Re: Where to get stand alone Dot Net Framework version 1.1, version 2.0, version 3.0, version 3.5, version 2.0 SP1, version 3.0 SP1 ? V Green ASP .Net 0 02-05-2008 02:45 AM
Java applet failed when I try to load the avi file in my java applet Krista Java 3 09-15-2004 02:53 AM



Advertisments