Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > LoadControl Compilation problem

Reply
Thread Tools

LoadControl Compilation problem

 
 
=?Utf-8?B?U3VzaGlTZWFu?=
Guest
Posts: n/a
 
      03-06-2007
Hello. I have some problem and really need a answer why it happens.
I have asp.net framework 2 site and I use 2 clusters (NLB). They both use
the same network path to source code, the same database, and the same IIS
settings on both.

I use the simplest type of deploying site – just update them in paths which
use IIS from clusters. So after each update it should make recompile of
project and use new version of code. I have terrible problem with it.
Sometimes one of clusters work but others show me some compile error. How can
it be? They use EVERYTHING the same.

It usually crashed on code which use this:
=============================================
LayoutParts_SessionWork pSessionWork = null;
pSessionWork = this.LoadControl("LayoutParts/SessionWork.ascx") as
LayoutParts_SessionWork;
pSessionWork.generate_page();
=============================================

Crashed on line with LoadControl and in trace I write some dll (for example
something like this, sdhajksuw123kll1.dll) wasn’t found.

I can fix it by changing file and put it again ( it should be new recompile)
or reainstall framework on this cluster (should be recompile too).

Why it happends? Why it happends only for ONE of them?? It looks like IIS
have 80% on success building of code and somethimes it works somethimes not.
I have tiread abuot it and really need answer how to fix it.

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LoadControl problem - External Controls lennart ASP .Net 1 04-25-2010 07:51 AM
LoadControl and the PostBack problem jack ASP .Net 2 07-29-2008 06:46 AM
Compilation error with seperate compilation C__chp C++ 4 02-15-2008 03:57 PM
LoadControl comilation problem. SushiSean ASP .Net Building Controls 0 03-05-2007 11:41 PM
LoadControl() problem =?Utf-8?B?UmV4VmFu?= ASP .Net 1 08-31-2004 05:25 AM



Advertisments