Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > C++ > a complie error ?

Reply
Thread Tools

a complie error ?

 
 
William
Guest
Posts: n/a
 
      01-04-2007

I am using mingw and msys, there is a complier error:

c:/cpp/MinGW/bin/../lib/gcc/mingw32/3.4.2/../../../../include/c++/3.4.2/bits/basic_ios.h:
In instantiation of `std::basic_ios<wchar_t, std::char_traits<wchar_t> >':
c:/cpp/MinGW/bin/../lib/gcc/mingw32/3.4.2/../../../../include/c++/3.4.2/ostream:59:
instantiated from `std::basic_ostream<wchar_t, std::char_traits<wchar_t> >'
c:/cpp/MinGW/bin/../lib/gcc/mingw32/3.4.2/../../../../include/c++/3.4.2/sstream:420:
instantiated from `std::basic_ostringstream<wchar_t,
std::char_traits<wchar_t>, std::allocator<wchar_t> >'
c:/cpp/lib-gcc/include/log4cpp/CategoryStream.hh:123: instantiated from
here
c:/cpp/MinGW/bin/../lib/gcc/mingw32/3.4.2/../../../../include/c++/3.4.2/bits/basic_ios.h:67:
error: no type named `pos_type' in `struct std::char_traits<wchar_t>'
c:/cpp/MinGW/bin/../lib/gcc/mingw32/3.4.2/../../../../include/c++/3.4.2/ostream:
In instantiation of `std::basic_ostream<wchar_t, std::char_traits<wchar_t>
> ':

c:/cpp/MinGW/bin/../lib/gcc/mingw32/3.4.2/../../../../include/c++/3.4.2/sstream:420:
instantiated from `std::basic_ostringstream<wchar_t,
std::char_traits<wchar_t>, std::allocator<wchar_t> >'
c:/cpp/lib-gcc/include/log4cpp/CategoryStream.hh:123: instantiated from
here
c:/cpp/MinGW/bin/../lib/gcc/mingw32/3.4.2/../../../../include/c++/3.4.2/ostream:64:
error: no type named `pos_type' in `struct std::char_traits<wchar_t>'
c:/cpp/MinGW/bin/../lib/gcc/mingw32/3.4.2/../../../../include/c++/3.4.2/bits/ostream.tcc:404:
error: no type named `pos_type' in `class std::basic_ostream<wchar_t,
std::char_traits<wchar_t> >'
c:/cpp/MinGW/bin/../lib/gcc/mingw32/3.4.2/../../../../include/c++/3.4.2/bits/ostream.tcc:420:
error: no type named `pos_type' in `struct std::char_traits<wchar_t>'

........

but when I use mingw attached by CodeBlocks, it is OK.

gcc and STL of mingw is 3.4.2, that of ClodeBlocks is 3.4.3
Is there any difference between them ?

thanks in advance !
 
Reply With Quote
 
 
 
 
William
Guest
Posts: n/a
 
      01-04-2007
I copied STL 3.4.4 to mingw, and it's OK now,
it seems a STL incompliant.

On Thu, 04 Jan 2007 10:15:35 +0800, William <(E-Mail Removed)> wrote:

>
> I am using mingw and msys, there is a complier error:


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error shown when I goto complie the application that converted from v1.1. Benny Ng ASP .Net 4 02-04-2006 04:49 PM
Complie ASP.NET 2.0 to Single DLL Yet another C# coder ASP .Net 1 10-12-2005 09:25 AM
complie cs file SAI ASP .Net 1 07-10-2005 11:28 AM
Failed Complie due to locked DLL =?Utf-8?B?Sm9obiBCYW5raGVhZA==?= ASP .Net 5 01-04-2005 03:35 PM
Complie PERL Solaris 9 64-bit problems krigare Perl 0 12-27-2003 05:52 PM



Advertisments