Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Wireless Networking > Peer to peer wifi setup

Reply
Thread Tools

Peer to peer wifi setup

 
 
Patrick Page
Guest
Posts: n/a
 
      09-13-2004
New ipconfig results: The desktop shows:
Description: ...; Physical address: ...; DHCP enabled: Yes;
Autoconfiguration enabled: Yes; IP Address: 4.11.130.172; Subnet Mask:
255.255.248.0; Default Gateway: 4.11.128.1; DHCP Server: 209.244.7.5; DNS
Servers 4.2.2.65 4.2.2.5 4.2.2.6; Lease obtained: ...
--
All mail sent by me is virus-checked with NAV.
Patrick S. Page
Morongo Valley, CA
760-363-0062
"Steve Winograd [MVP]" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
| In article <(E-Mail Removed)>, "Patrick Page"
| <(E-Mail Removed)> wrote:
| >1. I already disabled the firewalls on both machines.
| >
| >2. I already disabled Zone Alarm.
| >
| >3. TCPIP is the only protocol being used.
| >
| >4. I enabled NetBIOS over TCPIP. Note that the instructions are covered
by
| >the example on the web site.
| >
| >5. I found no references to either flavor of PtoP or NodeType. Below are
the
| >Ipconfig results:
| >
| >The desktop shows: Description: ...; Physical address: ...; DHCP enabled:
| >No; IP Address: 192.168.30.1; Subnet Mask: 255.255.255.0; Default
Gateway:
| >( none shown)
| >
| >The notebook shows: Description: ...; Physical address: ...; Dhcp
enabled:
| >Yes; Auto configuration enabled: Yes; IP address:192.168.0.220 Subnet
Mask:
| >255.255.255.0; Default gateway: 192.168.0.1 Dhcp server: 192.168.0.1 DNS
| >servers: 192.168.0.1 Lease obtained: ... Lease expires: ...
| >
| >I hope the above gives you some clues. Many thanks!
|
| If the IP addresses that you listed are right, they're causing the
| problem. With a 255.255.255.0 subnet mask, 192.168.30.1 and
| 192.168.0.1 are in different subnets. so the computers can't
| communicate with each other.
|
| Ipconfig on the desktop shows that the IP address was assigned
| manually. I recommend changing it to assign an IP address
| automatically. Then, the desktop will get a 192.168.0.x IP address
| just like the notebook, and they'll be able to communicate.
| --
| Best Wishes,
| Steve Winograd, MS-MVP (Windows Networking)
|
| Please post any reply as a follow-up message in the news group
| for everyone to see. I'm sorry, but I don't answer questions
| addressed directly to me in E-mail or news groups.
|
| Microsoft Most Valuable Professional Program
| http://mvp.support.microsoft.com

 
Reply With Quote
 
 
 
 
Steve Winograd [MVP]
Guest
Posts: n/a
 
      09-13-2004
In article <e#(E-Mail Removed)>, "Patrick Page"
<(E-Mail Removed)> wrote:
>>>>>I'm trying to network my desktop running XP HE SP2 (Dlink DWL G520 PCI
>>>>>Wireless adapter) with my laptop running XP HE SP1 (Atheros AR5004G wireless
>>>>>adapter). The wireless adapters connect with excellent signal strength and
>>>>>talk to each other, but I can't see any resources from either computer. The
>>>>>desktop shows all its shared resources and the laptop in My Network Places;
>>>>>the laptop shows only its own shared resources. The error messages indicate
>>>>>the roadblock is administrator permission, but this is a ptop network. Help!
>>>>>TIA!

>|>
>| >Ipconfig results:
>| >
>| >The desktop shows: Description: ...; Physical address: ...; DHCP enabled:
>| >No; IP Address: 192.168.30.1; Subnet Mask: 255.255.255.0; Default
>Gateway:
>| >( none shown)
>| >
>| >The notebook shows: Description: ...; Physical address: ...; Dhcp
>enabled:
>| >Yes; Auto configuration enabled: Yes; IP address:192.168.0.220 Subnet
>Mask:
>| >255.255.255.0; Default gateway: 192.168.0.1 Dhcp server: 192.168.0.1 DNS
>| >servers: 192.168.0.1 Lease obtained: ... Lease expires: ...
>| >
>| >I hope the above gives you some clues. Many thanks!
>|
>| If the IP addresses that you listed are right, they're causing the
>| problem. With a 255.255.255.0 subnet mask, 192.168.30.1 and
>| 192.168.0.1 are in different subnets. so the computers can't
>| communicate with each other.
>|
>| Ipconfig on the desktop shows that the IP address was assigned
>| manually. I recommend changing it to assign an IP address
>| automatically. Then, the desktop will get a 192.168.0.x IP address
>| just like the notebook, and they'll be able to communicate.
>
>New ipconfig results: The desktop shows:
>Description: ...; Physical address: ...; DHCP enabled: Yes;
>Autoconfiguration enabled: Yes; IP Address: 4.11.130.172; Subnet Mask:
>255.255.248.0; Default Gateway: 4.11.128.1; DHCP Server: 209.244.7.5; DNS
>Servers 4.2.2.65 4.2.2.5 4.2.2.6; Lease obtained: ...


It seems that I don't understand your setup, Patrick.

The desktop has a public IP address assigned by Verizon DSL. The
laptop has a private IP address assigned by an Internet sharing device
of some sort -- it could be a home broadband router, or it could be
that the desktop has enabled Internet Connection Sharing on a DSL
connection.

Does the desktop have more than one network connection? What exactly
appears in the Network Connections folder? Is there a wireless one
(connecting to the laptop) and a wired and/or PPPoE one (connecting to
DSL)?

Do you have a wireless router? If so, how does each computer connect
to it: wired or wireless?

Do you have an external DSL modem? If so, what does it plug into? If
it plugs into a home broadband router, make sure that it's plugged
into the router's WAN (Internet) port, not into a LAN port.
--
Best Wishes,
Steve Winograd, MS-MVP (Windows Networking)

Please post any reply as a follow-up message in the news group
for everyone to see. I'm sorry, but I don't answer questions
addressed directly to me in E-mail or news groups.

Microsoft Most Valuable Professional Program
http://mvp.support.microsoft.com
 
Reply With Quote
 
 
 
 
Patrick Page
Guest
Posts: n/a
 
      09-13-2004
Thanks for your patience, Steve. The desktop has a simple DSL connection to
Verizon and a wireless adapter through which I want to give my laptop
internet access and be able to share files and printers. The laptop has a
wireless adapter and a disabled ethernet adapter. No router anywhere in the
picture. Both adapters are set to acquire IP addresses automatically. The
c: drives on both systems are set for simple file sharing. The laptop now
shows Node Type: Mixed; IP Routing enabled: No; WINS proxy enabled: No.

--
All mail sent by me is virus-checked with NAV.
Patrick S. Page
Morongo Valley, CA
760-363-0062
"Steve Winograd [MVP]" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
| In article <e#(E-Mail Removed)>, "Patrick Page"
| <(E-Mail Removed)> wrote:
| >>>>>I'm trying to network my desktop running XP HE SP2 (Dlink DWL G520
PCI
| >>>>>Wireless adapter) with my laptop running XP HE SP1 (Atheros AR5004G
wireless
| >>>>>adapter). The wireless adapters connect with excellent signal
strength and
| >>>>>talk to each other, but I can't see any resources from either
computer. The
| >>>>>desktop shows all its shared resources and the laptop in My Network
Places;
| >>>>>the laptop shows only its own shared resources. The error messages
indicate
| >>>>>the roadblock is administrator permission, but this is a ptop
network. Help!
| >>>>>TIA!
| >|>
| >| >Ipconfig results:
| >| >
| >| >The desktop shows: Description: ...; Physical address: ...; DHCP
enabled:
| >| >No; IP Address: 192.168.30.1; Subnet Mask: 255.255.255.0; Default
| >Gateway:
| >| >( none shown)
| >| >
| >| >The notebook shows: Description: ...; Physical address: ...; Dhcp
| >enabled:
| >| >Yes; Auto configuration enabled: Yes; IP address:192.168.0.220 Subnet
| >Mask:
| >| >255.255.255.0; Default gateway: 192.168.0.1 Dhcp server: 192.168.0.1
DNS
| >| >servers: 192.168.0.1 Lease obtained: ... Lease expires: ...
| >| >
| >| >I hope the above gives you some clues. Many thanks!
| >|
| >| If the IP addresses that you listed are right, they're causing the
| >| problem. With a 255.255.255.0 subnet mask, 192.168.30.1 and
| >| 192.168.0.1 are in different subnets. so the computers can't
| >| communicate with each other.
| >|
| >| Ipconfig on the desktop shows that the IP address was assigned
| >| manually. I recommend changing it to assign an IP address
| >| automatically. Then, the desktop will get a 192.168.0.x IP address
| >| just like the notebook, and they'll be able to communicate.
| >
| >New ipconfig results: The desktop shows:
| >Description: ...; Physical address: ...; DHCP enabled: Yes;
| >Autoconfiguration enabled: Yes; IP Address: 4.11.130.172; Subnet Mask:
| >255.255.248.0; Default Gateway: 4.11.128.1; DHCP Server: 209.244.7.5; DNS
| >Servers 4.2.2.65 4.2.2.5 4.2.2.6; Lease obtained: ...
|
| It seems that I don't understand your setup, Patrick.
|
| The desktop has a public IP address assigned by Verizon DSL. The
| laptop has a private IP address assigned by an Internet sharing device
| of some sort -- it could be a home broadband router, or it could be
| that the desktop has enabled Internet Connection Sharing on a DSL
| connection.
|
| Does the desktop have more than one network connection? What exactly
| appears in the Network Connections folder? Is there a wireless one
| (connecting to the laptop) and a wired and/or PPPoE one (connecting to
| DSL)?
|
| Do you have a wireless router? If so, how does each computer connect
| to it: wired or wireless?
|
| Do you have an external DSL modem? If so, what does it plug into? If
| it plugs into a home broadband router, make sure that it's plugged
| into the router's WAN (Internet) port, not into a LAN port.
| --
| Best Wishes,
| Steve Winograd, MS-MVP (Windows Networking)
|
| Please post any reply as a follow-up message in the news group
| for everyone to see. I'm sorry, but I don't answer questions
| addressed directly to me in E-mail or news groups.
|
| Microsoft Most Valuable Professional Program
| http://mvp.support.microsoft.com

 
Reply With Quote
 
Steve Winograd [MVP]
Guest
Posts: n/a
 
      09-13-2004
In article <(E-Mail Removed)>, "Patrick Page"
<(E-Mail Removed)> wrote:
>Thanks for your patience, Steve. The desktop has a simple DSL connection to
>Verizon and a wireless adapter through which I want to give my laptop
>internet access and be able to share files and printers. The laptop has a
>wireless adapter and a disabled ethernet adapter. No router anywhere in the
>picture. Both adapters are set to acquire IP addresses automatically. The
>c: drives on both systems are set for simple file sharing. The laptop now
>shows Node Type: Mixed; IP Routing enabled: No; WINS proxy enabled: No.


You're welcome, Patrick. Thanks for the details of your setup.

You need to set up an Ad-hoc wireless network between the desktop and
laptop computers and enable Internet Connection Sharing on the
desktop's DSL (PPPoE) connection. Barb Bowman has written a web page
that should help you get everything working:

Making the Wireless Home Network Connection in Windows XP Without a
Router
http://www.microsoft.com/windowsxp/u...02april08.mspx

Do you have an external DSL modem? If so, your network setup would be
simpler and more reliable if you got a wireless router, connected the
DSL modem to its WAN port, and connected the computers to it using
either a wired or wireless connection.
--
Best Wishes,
Steve Winograd, MS-MVP (Windows Networking)

Please post any reply as a follow-up message in the news group
for everyone to see. I'm sorry, but I don't answer questions
addressed directly to me in E-mail or news groups.

Microsoft Most Valuable Professional Program
http://mvp.support.microsoft.com
 
Reply With Quote
 
Patrick Page
Guest
Posts: n/a
 
      09-13-2004
Thanks again. I've ordered a router as you suggested, but am eager to get
connected now. I followed Barb Bowman's instructions (very clear), but find
an obstacle at this step:
************************************************** ************************************************** ***************************
Sharing the Connection
Now that a successful ad hoc wireless network has been created, we'll set up
Internet Connection Sharing.

1.
Open Network Connections on the host computer. (Click Start, click
Control Panel, click Switch to classic view, and then click Network
Connections.

2.
Click the connection to be shared, and under Network Tasks, click
Change settings of this connection.

3.
On the Advanced tab, select the Allow other network users to connect
through this computer's Internet connection check box.

4.
If you are not using a third party firewall and have not already set up
the Internet Connection Firewall (ICF), be sure to check the box enabling
this feature. (Read more about why to enable ICF in an earlier column, Don't
Let the Defense Rest.)

5.
Finally, optionally enable the setting to let other users control or
enable this connection.


After completing ICS configuration, the Network Connection window on the
host computer will display the original wired Ethernet connection and
display the status as Shared as well as Enabled. The Network Connection
window on the client computer will display the connection on the host as an
Internet Gateway.

************************************************** ************************************************** ************************

This is where the trouble begins:

The DSL connection simply appears as "Local Area Connection" with no status
of Shared or Enabled, and the client does not see the Internet Gateway.


--
All mail sent by me is virus-checked with NAV.
Patrick S. Page
Morongo Valley, CA
760-363-0062
"Steve Winograd [MVP]" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
| In article <(E-Mail Removed)>, "Patrick Page"
| <(E-Mail Removed)> wrote:
| >Thanks for your patience, Steve. The desktop has a simple DSL connection
to
| >Verizon and a wireless adapter through which I want to give my laptop
| >internet access and be able to share files and printers. The laptop has a
| >wireless adapter and a disabled ethernet adapter. No router anywhere in
the
| >picture. Both adapters are set to acquire IP addresses automatically.
The
| >c: drives on both systems are set for simple file sharing. The laptop now
| >shows Node Type: Mixed; IP Routing enabled: No; WINS proxy enabled: No.
|
| You're welcome, Patrick. Thanks for the details of your setup.
|
| You need to set up an Ad-hoc wireless network between the desktop and
| laptop computers and enable Internet Connection Sharing on the
| desktop's DSL (PPPoE) connection. Barb Bowman has written a web page
| that should help you get everything working:
|
| Making the Wireless Home Network Connection in Windows XP Without a
| Router
|
http://www.microsoft.com/windowsxp/u...02april08.mspx
|
| Do you have an external DSL modem? If so, your network setup would be
| simpler and more reliable if you got a wireless router, connected the
| DSL modem to its WAN port, and connected the computers to it using
| either a wired or wireless connection.
| --
| Best Wishes,
| Steve Winograd, MS-MVP (Windows Networking)
|
| Please post any reply as a follow-up message in the news group
| for everyone to see. I'm sorry, but I don't answer questions
| addressed directly to me in E-mail or news groups.
|
| Microsoft Most Valuable Professional Program
| http://mvp.support.microsoft.com

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
strange setup for small peer to peer mdb Wireless Networking 1 01-10-2007 09:08 PM
Extended Peer to Peer Setup. =?Utf-8?B?U2ltb24=?= Wireless Networking 1 08-25-2006 04:15 AM
Trouble installing the peer-to-peer component =?Utf-8?B?TWFya28=?= Wireless Networking 1 12-28-2004 03:41 AM
peer to peer linking and sharing =?Utf-8?B?QmlsbEM=?= Wireless Networking 2 08-23-2004 08:23 PM
Need help with peer to peer no hub network Doug A Moller Wireless Networking 3 06-24-2004 01:48 AM



Advertisments