Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Simple(?) QoS question

Reply
Thread Tools

Simple(?) QoS question

 
 
spork
Guest
Posts: n/a
 
      01-25-2007
Hello,

I have a problem that I though would be very easy to solve.

I have a Cisco 1721 that has a frame-relay T1 to the internet, and I
have three vlans hanging of of fa0.

One vlan is for voice traffic and needs absolute priority to the
internet.
One vlan is for general office traffic and should have less priority
than the voice vlan.
One vlan is for public wireless access and should have the lowest
priority.

I've fiddled with CBWFQ, LLQ and a few others. None of them seem to
work with Frame - the command to apply the policy to the subinterface
either doesn't exist or I get a line similar to: CBWFQ : Not supported
on subinterfaces
Applying to the main interface has no effect.

This should be pretty easy, what am I missing?

 
Reply With Quote
 
 
 
 
Scooby
Guest
Posts: n/a
 
      01-25-2007
"spork" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) oups.com...
> Hello,
>
> I have a problem that I though would be very easy to solve.
>
> I have a Cisco 1721 that has a frame-relay T1 to the internet, and I
> have three vlans hanging of of fa0.
>
> One vlan is for voice traffic and needs absolute priority to the
> internet.
> One vlan is for general office traffic and should have less priority
> than the voice vlan.
> One vlan is for public wireless access and should have the lowest
> priority.
>
> I've fiddled with CBWFQ, LLQ and a few others. None of them seem to
> work with Frame - the command to apply the policy to the subinterface
> either doesn't exist or I get a line similar to: CBWFQ : Not supported
> on subinterfaces
> Applying to the main interface has no effect.
>
> This should be pretty easy, what am I missing?
>


Here's an article on VoIP over Frame-Relay that should offer some tips:

http://www.cisco.com/en/US/tech/tk65...80094af9.shtml

Hope that helps,

Jim


 
Reply With Quote
 
 
 
 
vty 0 4
Guest
Posts: n/a
 
      01-26-2007
define a map-class, apply service policies to map-class, apply
map-class under "frame-relay interface dlc1 xx"

From experience, 1721 + CBWFQ = problems

On 25 Jan 2007 12:22:52 -0800, "spork" <(E-Mail Removed)>
wrote:

>Hello,
>
>I have a problem that I though would be very easy to solve.
>
>I have a Cisco 1721 that has a frame-relay T1 to the internet, and I
>have three vlans hanging of of fa0.
>
>One vlan is for voice traffic and needs absolute priority to the
>internet.
>One vlan is for general office traffic and should have less priority
>than the voice vlan.
>One vlan is for public wireless access and should have the lowest
>priority.
>
>I've fiddled with CBWFQ, LLQ and a few others. None of them seem to
>work with Frame - the command to apply the policy to the subinterface
>either doesn't exist or I get a line similar to: CBWFQ : Not supported
>on subinterfaces
>Applying to the main interface has no effect.
>
>This should be pretty easy, what am I missing?


 
Reply With Quote
 
spork
Guest
Posts: n/a
 
      02-01-2007
On Jan 25, 6:02 pm, "Scooby" <(E-Mail Removed)> wrote:
> "spork" <(E-Mail Removed)> wrote in message
>
> news:(E-Mail Removed) oups.com...
>
> > Hello,

>
> > I have a problem that I though would be very easy to solve.

>
> > I have a Cisco 1721 that has a frame-relay T1 to the internet, and I
> > have three vlans hanging of of fa0.

>
> > One vlan is for voice traffic and needs absolute priority to the
> > internet.
> > One vlan is for general office traffic and should have less priority
> > than the voice vlan.
> > One vlan is for public wireless access and should have the lowest
> > priority.

>
> > I've fiddled with CBWFQ, LLQ and a few others. None of them seem to
> > work with Frame - the command to apply the policy to the subinterface
> > either doesn't exist or I get a line similar to: CBWFQ : Not supported
> > on subinterfaces
> > Applying to the main interface has no effect.

>
> > This should be pretty easy, what am I missing?

>
> Here's an article on VoIP over Frame-Relay that should offer some tips:
>
> http://www.cisco.com/en/US/tech/tk65...s_configuratio...


That's got me stumped. I've got the following to differentiate the 3
vlans:

policy-map inet-out
class studio-out
priority 400
class office-out
bandwidth 800
class class-default
fair-queue

class-map match-all office-out
match access-group 2
class-map match-all wireless-out
match access-group 3
class-map match-all studio-out
match access-group 1

!
interface Serial0.1 point-to-point
bandwidth 1490
ip address x.x.x.233 255.255.255.0
ip nat outside
frame-relay interface-dlci 16
class frame-out
!
map-class frame-relay frame-out
service-policy output inet-out
!
access-list 1 permit 216.220.105.24 0.0.0.7
access-list 2 permit 192.168.0.0 0.0.0.255
access-list 3 permit 192.168.1.0 0.0.0.255

Now when I go to the main frame interface and add the "frame-relay
traffic-shaping", it gives me this:

evradio(config-if)#frame-relay traffic-shaping
I/f Serial0.1 DLCI 16 class studio-out requested bandwidth 400 (kbps),
available only 1 (kbps)
Traffic shaping not enabled due to invalid policy in map-class frame-
out

Where is this 1Kb/s limit coming from? I do have bandwidth statements
on both the main serial interface and the frame subinterface (1536).

> Hope that helps,
>
> Jim



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[QOS] minimal hardware and IOS requirement for QOS dominix Cisco 2 02-06-2007 10:19 AM
QOS for VOIP using 768k of FR / Auto QOS Andrew Albert Cisco 7 02-09-2005 07:42 PM
Re: QoS Policy Question & Recommendations Ben Cisco 1 11-18-2004 04:46 AM
Question About Configuring QoS c Cisco 1 07-07-2004 05:48 PM
Nachi is for the devil! Flow QoS question Smash Cisco 2 11-26-2003 02:45 PM



Advertisments