Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > EIGRP on Lanlink interfaces

Reply
Thread Tools

EIGRP on Lanlink interfaces

 
 
andre.wisniewski@gmx.de
Guest
Posts: n/a
 
      12-14-2006
Hello all

I am runnning two Cisco 2801 with IOS 12.3(T6. Both Routers are
connected (fa0/0) to network 10.10.10.0 and 170.11.1.0 (fa0/1). HSRP
and EIGRP are configured this way

Router A

interface FastEthernet0/0
ip address 10.10.10.3 255.255.255.0
speed 100
full-duplex
standby 150 ip 10.10.10.5
standby 150 timers 1 3
standby 150 priority 110
standby 150 preempt
standby 150 track FastEthernet0/1

interface FastEthernet0/1
ip address 170.11.1.253 255.255.255.0
standby 152 ip 170.11.1.1
standby 152 timers 1 3
standby 152 priority 110
standby 152 preempt
standby 152 track FastEthernet0/0

router eigrp 150
redistribute static
network 10.0.0.0
network 170.11.0.0
no auto-summary

ip route 0.0.0.0 0.0.0.0 10.10.10.1
ip route 172.19.70.0 255.255.255.0 170.11.1.4
ip route 172.25.11.0 255.255.255.0 170.11.1.4

Router B

interface FastEthernet0/0
ip address 10.10.10.4 255.255.255.0
speed 100
full-duplex
standby 150 ip 10.10.10.5
standby 150 timers 1 3
standby 150 priority 105
standby 150 preempt
standby 150 track FastEthernet0/1

interface FastEthernet0/1
ip address 170.11.1.254 255.255.255.0
standby 152 ip 170.11.1.1
standby 152 timers 1 3
standby 152 priority 105
standby 152 preempt
standby 152 track FastEthernet0/0

router eigrp 150
redistribute static
network 10.0.0.0
network 170.11.0.0
no auto-summary

ip route 0.0.0.0 0.0.0.0 10.10.10.1
ip route 172.19.70.0 255.255.255.0 170.11.1.4
ip route 172.25.11.0 255.255.255.0 170.11.1.4

Interfaces fa0/1 are connected to a switch via Lanlink on remote side,
fa0/0 is connected to a switch on local side.
If Lanlink on Router A fails interface fa0/1 stays up because
connection to modem is still ok but remote network is not reachable any
more via this interface.
HSRP doesn't switch of course. I can't see any eigrp route "sh ip route
eigrp".
What can i do to fix this issue?

Thanks in advance.

Andre Wisniewski

 
Reply With Quote
 
 
 
 
stephen
Guest
Posts: n/a
 
      12-14-2006
<(E-Mail Removed)> wrote in message
news:(E-Mail Removed) ups.com...
> Hello all
>
> I am runnning two Cisco 2801 with IOS 12.3(T6. Both Routers are
> connected (fa0/0) to network 10.10.10.0 and 170.11.1.0 (fa0/1). HSRP
> and EIGRP are configured this way
>
> Router A
>
> interface FastEthernet0/0
> ip address 10.10.10.3 255.255.255.0
> speed 100
> full-duplex
> standby 150 ip 10.10.10.5
> standby 150 timers 1 3
> standby 150 priority 110
> standby 150 preempt
> standby 150 track FastEthernet0/1
>
> interface FastEthernet0/1
> ip address 170.11.1.253 255.255.255.0
> standby 152 ip 170.11.1.1
> standby 152 timers 1 3
> standby 152 priority 110
> standby 152 preempt
> standby 152 track FastEthernet0/0
>
> router eigrp 150
> redistribute static
> network 10.0.0.0
> network 170.11.0.0
> no auto-summary
>
> ip route 0.0.0.0 0.0.0.0 10.10.10.1
> ip route 172.19.70.0 255.255.255.0 170.11.1.4
> ip route 172.25.11.0 255.255.255.0 170.11.1.4
>
> Router B
>
> interface FastEthernet0/0
> ip address 10.10.10.4 255.255.255.0
> speed 100
> full-duplex
> standby 150 ip 10.10.10.5
> standby 150 timers 1 3
> standby 150 priority 105
> standby 150 preempt
> standby 150 track FastEthernet0/1
>
> interface FastEthernet0/1
> ip address 170.11.1.254 255.255.255.0
> standby 152 ip 170.11.1.1
> standby 152 timers 1 3
> standby 152 priority 105
> standby 152 preempt
> standby 152 track FastEthernet0/0
>
> router eigrp 150
> redistribute static
> network 10.0.0.0
> network 170.11.0.0
> no auto-summary
>
> ip route 0.0.0.0 0.0.0.0 10.10.10.1
> ip route 172.19.70.0 255.255.255.0 170.11.1.4
> ip route 172.25.11.0 255.255.255.0 170.11.1.4
>
> Interfaces fa0/1 are connected to a switch via Lanlink on remote side,
> fa0/0 is connected to a switch on local side.
> If Lanlink on Router A fails interface fa0/1 stays up because
> connection to modem is still ok but remote network is not reachable any
> more via this interface.
> HSRP doesn't switch of course. I can't see any eigrp route "sh ip route
> eigrp".
> What can i do to fix this issue?


i am not sure i understand your topology - are the 2801 on the same or
different sites?

use "object tracking" to let HSRP switch based on access to an address or
routing table contents.
http://www.cisco.com/en/US/products/...0801d2d74.html

maybe the 2 routers should be exchanging routes over the HSRP interface, so
they should have a routed path between them - that will also "fix" some
transitional forwarding black holes when the network topology changes.

personally i would use OSPF instead - at least you can predict what it will
do

>
> Thanks in advance.
>
> Andre Wisniewski
>

--
Regards

http://www.velocityreviews.com/forums/(E-Mail Removed) - replace xyz with ntl


 
Reply With Quote
 
 
 
 
Andre
Guest
Posts: n/a
 
      12-15-2006


On 14 Dez., 22:23, "stephen" <(E-Mail Removed)> wrote:
> <(E-Mail Removed)> wrote in messagenews:(E-Mail Removed) oglegroups.com...
>
>
>
> > Hello all

>
> > I am runnning two Cisco 2801 with IOS 12.3(T6. Both Routers are
> > connected (fa0/0) to network 10.10.10.0 and 170.11.1.0 (fa0/1). HSRP
> > and EIGRP are configured this way

>
> > Router A

>
> > interface FastEthernet0/0
> > ip address 10.10.10.3 255.255.255.0
> > speed 100
> > full-duplex
> > standby 150 ip 10.10.10.5
> > standby 150 timers 1 3
> > standby 150 priority 110
> > standby 150 preempt
> > standby 150 track FastEthernet0/1

>
> > interface FastEthernet0/1
> > ip address 170.11.1.253 255.255.255.0
> > standby 152 ip 170.11.1.1
> > standby 152 timers 1 3
> > standby 152 priority 110
> > standby 152 preempt
> > standby 152 track FastEthernet0/0

>
> > router eigrp 150
> > redistribute static
> > network 10.0.0.0
> > network 170.11.0.0
> > no auto-summary

>
> > ip route 0.0.0.0 0.0.0.0 10.10.10.1
> > ip route 172.19.70.0 255.255.255.0 170.11.1.4
> > ip route 172.25.11.0 255.255.255.0 170.11.1.4

>
> > Router B

>
> > interface FastEthernet0/0
> > ip address 10.10.10.4 255.255.255.0
> > speed 100
> > full-duplex
> > standby 150 ip 10.10.10.5
> > standby 150 timers 1 3
> > standby 150 priority 105
> > standby 150 preempt
> > standby 150 track FastEthernet0/1

>
> > interface FastEthernet0/1
> > ip address 170.11.1.254 255.255.255.0
> > standby 152 ip 170.11.1.1
> > standby 152 timers 1 3
> > standby 152 priority 105
> > standby 152 preempt
> > standby 152 track FastEthernet0/0

>
> > router eigrp 150
> > redistribute static
> > network 10.0.0.0
> > network 170.11.0.0
> > no auto-summary

>
> > ip route 0.0.0.0 0.0.0.0 10.10.10.1
> > ip route 172.19.70.0 255.255.255.0 170.11.1.4
> > ip route 172.25.11.0 255.255.255.0 170.11.1.4

>
> > Interfaces fa0/1 are connected to a switch via Lanlink on remote side,
> > fa0/0 is connected to a switch on local side.
> > If Lanlink on Router A fails interface fa0/1 stays up because
> > connection to modem is still ok but remote network is not reachable any
> > more via this interface.
> > HSRP doesn't switch of course. I can't see any eigrp route "sh ip route
> > eigrp".
> > What can i do to fix this issue?i am not sure i understand your topology - are the 2801 on the same or

> different sites?

They are on the same site.
>
> use "object tracking" to let HSRP switch based on access to an address or
> routing table contents.http://www.cisco.com/en/US/products/...products_featu...
>

OK. I will have a look at it
> maybe the 2 routers should be exchanging routes over the HSRP interface, so
> they should have a routed path between them - that will also "fix" some
> transitional forwarding black holes when the network topology changes.
>
> personally i would use OSPF instead - at least you can predict what it will
> do

It's worth thinking about it. Thanks so far.
>
>
>
> > Thanks in advance.

>
> > Andre Wisniewski--

> Regards
>
> (E-Mail Removed) - replace xyz with ntl


 
Reply With Quote
 
Andre
Guest
Posts: n/a
 
      01-09-2007


On 14 Dez. 2006, 22:23, "stephen" <(E-Mail Removed)> wrote:
> <(E-Mail Removed)> wrote in messagenews:(E-Mail Removed) oglegroups.com...
>
>
>
> > Hello all

>
> > I am runnning two Cisco 2801 with IOS 12.3(T6. Both Routers are
> > connected (fa0/0) to network 10.10.10.0 and 170.11.1.0 (fa0/1). HSRP
> > and EIGRP are configured this way

>
> > Router A

>
> > interface FastEthernet0/0
> > ip address 10.10.10.3 255.255.255.0
> > speed 100
> > full-duplex
> > standby 150 ip 10.10.10.5
> > standby 150 timers 1 3
> > standby 150 priority 110
> > standby 150 preempt
> > standby 150 track FastEthernet0/1

>
> > interface FastEthernet0/1
> > ip address 170.11.1.253 255.255.255.0
> > standby 152 ip 170.11.1.1
> > standby 152 timers 1 3
> > standby 152 priority 110
> > standby 152 preempt
> > standby 152 track FastEthernet0/0

>
> > router eigrp 150
> > redistribute static
> > network 10.0.0.0
> > network 170.11.0.0
> > no auto-summary

>
> > ip route 0.0.0.0 0.0.0.0 10.10.10.1
> > ip route 172.19.70.0 255.255.255.0 170.11.1.4
> > ip route 172.25.11.0 255.255.255.0 170.11.1.4

>
> > Router B

>
> > interface FastEthernet0/0
> > ip address 10.10.10.4 255.255.255.0
> > speed 100
> > full-duplex
> > standby 150 ip 10.10.10.5
> > standby 150 timers 1 3
> > standby 150 priority 105
> > standby 150 preempt
> > standby 150 track FastEthernet0/1

>
> > interface FastEthernet0/1
> > ip address 170.11.1.254 255.255.255.0
> > standby 152 ip 170.11.1.1
> > standby 152 timers 1 3
> > standby 152 priority 105
> > standby 152 preempt
> > standby 152 track FastEthernet0/0

>
> > router eigrp 150
> > redistribute static
> > network 10.0.0.0
> > network 170.11.0.0
> > no auto-summary

>
> > ip route 0.0.0.0 0.0.0.0 10.10.10.1
> > ip route 172.19.70.0 255.255.255.0 170.11.1.4
> > ip route 172.25.11.0 255.255.255.0 170.11.1.4

>
> > Interfaces fa0/1 are connected to a switch via Lanlink on remote side,
> > fa0/0 is connected to a switch on local side.
> > If Lanlink on Router A fails interface fa0/1 stays up because
> > connection to modem is still ok but remote network is not reachable any
> > more via this interface.
> > HSRP doesn't switch of course. I can't see any eigrp route "sh ip route
> > eigrp".
> > What can i do to fix this issue?i am not sure i understand your topology - are the 2801 on the same or

> different sites?
>
> use "object tracking" to let HSRP switch based on access to an address or
> routing table contents.http://www.cisco.com/en/US/products/...products_featu...


Very helpful answer. Thanks a lot.
Here is my solution.

I added ...

track 100 rtr 1 reachability
delay down 3 up 3

interface FastEthernet0/0
standby 150 track 100 decrement 50

ip sla 1
icmp-echo 170.11.1.23
request-data-size 512
timeout 1000
threshold 2
frequency 3

ip sla schedule 1 life forever start-time now

>
> maybe the 2 routers should be exchanging routes over the HSRP interface, so
> they should have a routed path between them - that will also "fix" some
> transitional forwarding black holes when the network topology changes.
>
> personally i would use OSPF instead - at least you can predict what it will
> do
>
>
>
> > Thanks in advance.

>
> > Andre Wisniewski--

> Regards
>
> (E-Mail Removed) - replace xyz with ntl


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
EIGRP, Want to prevent any EIGRP traffic to a interface BG Cisco 3 02-09-2006 08:05 PM
EIGRP fails on nonbroadcast interfaces Ghazan Haider Cisco 10 01-03-2004 01:48 PM
Re: EiGRP authentication question Hansang Bae Cisco 3 10-16-2003 05:19 AM
Redistribution between IS-IS, EIGRP & OSPF Sam Soh Cisco 5 08-15-2003 02:03 AM
dialer watch eigrp and custom queueing Kenny D Cisco 1 07-14-2003 11:20 AM



Advertisments