Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Cisco 1721 ADSL configuration Advice

Reply
Thread Tools

Cisco 1721 ADSL configuration Advice

 
 
martin.stenner@gmail.com
Guest
Posts: n/a
 
      12-08-2006
Hi there,

I'm relatively new to Cisco, and have been trying to configure a Cisco
1721 router for PPPoA ADSL with static settings.
The config that I've pieced together (see below) connects to the ADSL
service, and allows me to ping internet addresses by IP and hostname.
As you can see from the setting, the router allocates clients an IP
address from a DHCP pool, but a connected client cannot ping any
internet addresses. I'm wondering if this is something to do with an
access-list or routing issue. I'd really appreciate any help with this.

Thanks,

Martin

service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname MyRouter
!
ip cef
ip name-server w.x.y.z
ip name-server w.x.y.z
!
enable password password
!
ip subnet-zero
no shutdown
!
ip dhcp excluded-address 10.112.4.254
!
ip dhcp pool MyDHCPPool
network 10.112.4.0 255.255.255.0
default-router 10.112.4.254
dns-server 10.112.4.254
!
ip audit notify log
ip audit po max-events 100
!
interface ATM0
no shutdown
no ip address
atm ilmi-keepalive
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
!
interface BRI0
no ip address
shutdown
!
interface FastEthernet0
no shutdown
ip address 10.112.4.254 255.255.255.0
no ip redirects
no ip proxy-arp
ip nat inside
speed auto
!
interface Dialer1
ip address w.x.y.z 255.255.255.0 <--IP Address and subnet allocated by
ISP (static)
ip nat outside
encapsulation ppp
dialer pool 1
ppp chap hostname http://www.velocityreviews.com/forums/(E-Mail Removed)
ppp chap password 0 password
ppp pap sent-username (E-Mail Removed) password 0 password
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
ip nat inside source list 1 interface Dialer1 overload
ip pim bidir-enable
!
ip access-list extended nat-out
permit ip 10.112.4.0 0.0.0.255 any
!
!
line con 0
exec-timeout 0 0
stopbits 1
line aux 0
line vty 0 4
exec-timeout 5 0
password password
login
!
no scheduler allocate
end

 
Reply With Quote
 
 
 
 
Carlo Poggiarelli
Guest
Posts: n/a
 
      12-09-2006
Hi Martin
If you have " ip nat inside source list 1 interface Dialer1 overload" in
your configuration, you should have an
"access-list 1 permit 10.112.4.0 0.0.0.255 " and not
"ip access-list extended nat-out
permit ip 10.112.4.0 0.0.0.255 any"

because the access-list "nat-out" is not defined in your NAT rule but the
"source list 1" which refers to an access-list 1

HTH

Bye

Carlo


<(E-Mail Removed)> ha scritto nel messaggio
news:(E-Mail Removed) ps.com...
> Hi there,
>
> I'm relatively new to Cisco, and have been trying to configure a Cisco
> 1721 router for PPPoA ADSL with static settings.
> The config that I've pieced together (see below) connects to the ADSL
> service, and allows me to ping internet addresses by IP and hostname.
> As you can see from the setting, the router allocates clients an IP
> address from a DHCP pool, but a connected client cannot ping any
> internet addresses. I'm wondering if this is something to do with an
> access-list or routing issue. I'd really appreciate any help with this.
>
> Thanks,
>
> Martin
>
> service timestamps debug datetime msec
> service timestamps log datetime msec
> no service password-encryption
> !
> hostname MyRouter
> !
> ip cef
> ip name-server w.x.y.z
> ip name-server w.x.y.z
> !
> enable password password
> !
> ip subnet-zero
> no shutdown
> !
> ip dhcp excluded-address 10.112.4.254
> !
> ip dhcp pool MyDHCPPool
> network 10.112.4.0 255.255.255.0
> default-router 10.112.4.254
> dns-server 10.112.4.254
> !
> ip audit notify log
> ip audit po max-events 100
> !
> interface ATM0
> no shutdown
> no ip address
> atm ilmi-keepalive
> pvc 0/38
> encapsulation aal5mux ppp dialer
> dialer pool-member 1
> !
> dsl operating-mode auto
> !
> interface BRI0
> no ip address
> shutdown
> !
> interface FastEthernet0
> no shutdown
> ip address 10.112.4.254 255.255.255.0
> no ip redirects
> no ip proxy-arp
> ip nat inside
> speed auto
> !
> interface Dialer1
> ip address w.x.y.z 255.255.255.0 <--IP Address and subnet allocated by
> ISP (static)
> ip nat outside
> encapsulation ppp
> dialer pool 1
> ppp chap hostname (E-Mail Removed)
> ppp chap password 0 password
> ppp pap sent-username (E-Mail Removed) password 0 password
> !
> ip classless
> ip route 0.0.0.0 0.0.0.0 Dialer1
> no ip http server
> ip nat inside source list 1 interface Dialer1 overload
> ip pim bidir-enable
> !
> ip access-list extended nat-out
> permit ip 10.112.4.0 0.0.0.255 any
> !
> !
> line con 0
> exec-timeout 0 0
> stopbits 1
> line aux 0
> line vty 0 4
> exec-timeout 5 0
> password password
> login
> !
> no scheduler allocate
> end
>
>




 
Reply With Quote
 
 
 
 
martin.stenner@gmail.com
Guest
Posts: n/a
 
      12-11-2006
Carlo - Thanks for the advice. I'll give it a try.

Cheers,
Martin

> Carlo Poggiarelli wrote:


> Hi Martin
> If you have " ip nat inside source list 1 interface Dialer1 overload" in
> your configuration, you should have an
> "access-list 1 permit 10.112.4.0 0.0.0.255 " and not
> "ip access-list extended nat-out
> permit ip 10.112.4.0 0.0.0.255 any"
>
> because the access-list "nat-out" is not defined in your NAT rule but the
> "source list 1" which refers to an access-list 1
>
> HTH
>
> Bye
>
> Carlo


 
Reply With Quote
 
martin.stenner@gmail.com
Guest
Posts: n/a
 
      12-11-2006
Carlo - Yes, this worked! Thanks very much for the help. I don't
suppose you would have any pointers, or reference for configuring VPN
on this device? We have the necessary module in the router.

Thanks again for the help.

>Carlo Poggiarelli wrote:


> Hi Martin
> If you have " ip nat inside source list 1 interface Dialer1 overload" in
> your configuration, you should have an
> "access-list 1 permit 10.112.4.0 0.0.0.255 " and not
> "ip access-list extended nat-out
> permit ip 10.112.4.0 0.0.0.255 any"
>
> because the access-list "nat-out" is not defined in your NAT rule but the
> "source list 1" which refers to an access-list 1
>
> HTH
>
> Bye
>
> Carlo
>
>
> <(E-Mail Removed)> ha scritto nel messaggio
> news:(E-Mail Removed) ps.com...
> > Hi there,
> >
> > I'm relatively new to Cisco, and have been trying to configure a Cisco
> > 1721 router for PPPoA ADSL with static settings.
> > The config that I've pieced together (see below) connects to the ADSL
> > service, and allows me to ping internet addresses by IP and hostname.
> > As you can see from the setting, the router allocates clients an IP
> > address from a DHCP pool, but a connected client cannot ping any
> > internet addresses. I'm wondering if this is something to do with an
> > access-list or routing issue. I'd really appreciate any help with this.
> >
> > Thanks,
> >
> > Martin
> >
> > service timestamps debug datetime msec
> > service timestamps log datetime msec
> > no service password-encryption
> > !
> > hostname MyRouter
> > !
> > ip cef
> > ip name-server w.x.y.z
> > ip name-server w.x.y.z
> > !
> > enable password password
> > !
> > ip subnet-zero
> > no shutdown
> > !
> > ip dhcp excluded-address 10.112.4.254
> > !
> > ip dhcp pool MyDHCPPool
> > network 10.112.4.0 255.255.255.0
> > default-router 10.112.4.254
> > dns-server 10.112.4.254
> > !
> > ip audit notify log
> > ip audit po max-events 100
> > !
> > interface ATM0
> > no shutdown
> > no ip address
> > atm ilmi-keepalive
> > pvc 0/38
> > encapsulation aal5mux ppp dialer
> > dialer pool-member 1
> > !
> > dsl operating-mode auto
> > !
> > interface BRI0
> > no ip address
> > shutdown
> > !
> > interface FastEthernet0
> > no shutdown
> > ip address 10.112.4.254 255.255.255.0
> > no ip redirects
> > no ip proxy-arp
> > ip nat inside
> > speed auto
> > !
> > interface Dialer1
> > ip address w.x.y.z 255.255.255.0 <--IP Address and subnet allocated by
> > ISP (static)
> > ip nat outside
> > encapsulation ppp
> > dialer pool 1
> > ppp chap hostname (E-Mail Removed)
> > ppp chap password 0 password
> > ppp pap sent-username (E-Mail Removed) password 0 password
> > !
> > ip classless
> > ip route 0.0.0.0 0.0.0.0 Dialer1
> > no ip http server
> > ip nat inside source list 1 interface Dialer1 overload
> > ip pim bidir-enable
> > !
> > ip access-list extended nat-out
> > permit ip 10.112.4.0 0.0.0.255 any
> > !
> > !
> > line con 0
> > exec-timeout 0 0
> > stopbits 1
> > line aux 0
> > line vty 0 4
> > exec-timeout 5 0
> > password password
> > login
> > !
> > no scheduler allocate
> > end
> >
> >


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cisco configuration 1721 gooker Cisco 5 07-14-2006 02:47 AM
1721 connect to Pix 515 - which IOS for 1721? Scooter Cisco 1 02-25-2005 08:06 PM
Cisco 1721 Router configuration T1 HELP, new to this dr_rockstar66 Cisco 2 02-05-2005 10:11 PM
Cisco 1721 ADSL (dynamic) + ISDN failover (is it possibile ??) Marcus Cisco 0 10-11-2004 09:27 PM
Cisco 1721 lost configuration Said SIM Cisco 4 04-28-2004 12:49 PM



Advertisments