Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > VLANs with 2950 switches

Reply
Thread Tools

VLANs with 2950 switches

 
 
Tomasz Paszkowski
Guest
Posts: n/a
 
      07-11-2005
W artykule <(E-Mail Removed). com> cb napisał(a):

> I can't seem to figure why this third switch isn't working like the
> other two?
>
> all three switches are in Server VTP operating mode.


Please show us the configuration ot this third switch (sh ru).

TP
 
Reply With Quote
 
 
 
 
cb
Guest
Posts: n/a
 
      07-11-2005
Hi,

I've been setting up a second vlan on my 2950 switches and i have some
questions about the nature of communication between switches that have
the same vlans. I have one switch that has two vlans:
1 default
2 vlan2

I have another switch with the same configuration and these switches
are connected via a gigabit fiber cross connect.

These two can communicate back and forth between each other on both
vlans no problem. I'm not referring to communication btwn the vlans
just each vlan can communicate within it's own IP segment (192.168.25.x
& 192.168.28.x)

If I take a third 2950 switch and create a second vlan (2 vlan2) and
connect to one of these two switches via a cross-over cable, vlan1 is
fine no problems, but any machine connected to vlan2 can't communicate
with a machine connected to vlan2 on any of the other switches.

I can't seem to figure why this third switch isn't working like the
other two?

all three switches are in Server VTP operating mode.

I'm fairly new to all this, so thank you for your patience. If there's
more pertinent information i need to supply please tell me.

TIA,
cb

 
Reply With Quote
 
 
 
 
cb
Guest
Posts: n/a
 
      07-11-2005
Thanks TP for your reply.

Here are the three running configs from all 3 switches.

****Switch 1****
Building configuration...

Current configuration : 2381 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log datetime
no service password-encryption
service sequence-numbers
!
hostname NYSwitch1
!
enable secret 5 $1$WFoj$vc6dMm1s5T0qb00UUVjkk0
enable password xxxxx
!
ip subnet-zero
cluster enable istarsw 0
cluster member 1 mac-address 000d.2857.f800
cluster member 2 mac-address 000d.ed3f.9b40
cluster member 3 mac-address 000e.3843.0780
cluster member 4 mac-address 0011.5c24.5cc0
cluster member 6 mac-address 0011.5ce8.0800
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
interface FastEthernet0/1
no ip address
duplex full
speed 100
!
interface FastEthernet0/2
no ip address
duplex full
speed 100
!
interface FastEthernet0/3
no ip address
duplex full
speed 10
!
interface FastEthernet0/4
no ip address
!
interface FastEthernet0/5
no ip address
!
interface FastEthernet0/6
no ip address
!
interface FastEthernet0/7
no ip address
!
interface FastEthernet0/8
no ip address
!
interface FastEthernet0/9
no ip address
!
interface FastEthernet0/10
no ip address
!
interface FastEthernet0/11
no ip address
!
interface FastEthernet0/12
no ip address
duplex full
speed 100
!
interface FastEthernet0/13
no ip address
!
interface FastEthernet0/14
no ip address
!
interface FastEthernet0/15
no ip address
!
interface FastEthernet0/16
no ip address
duplex full
speed 100
!
interface FastEthernet0/17
no ip address
!
interface FastEthernet0/18
no ip address
!
interface FastEthernet0/19
no ip address
!
interface FastEthernet0/20
no ip address
!
interface FastEthernet0/21
switchport access vlan 2
no ip address
!
interface FastEthernet0/22
switchport access vlan 2
no ip address
!
interface FastEthernet0/23
no ip address
!
interface FastEthernet0/24
no ip address
!
interface GigabitEthernet0/1
no ip address
!
interface GigabitEthernet0/2
no ip address
!
interface Vlan1
ip address 192.168.25.240 255.255.255.0
no ip route-cache
!
ip default-gateway 192.168.25.1
ip http server
!
ip access-list extended CMP-NAT-ACL
dynamic Cluster-HSRP deny ip any any
dynamic Cluster-NAT permit ip any any
!
snmp-server community VRTest RO
snmp-server community VRTest@es0 RO
snmp-server location MDF
snmp-server contact Chris Beach
!
line con 0
line vty 0 4
password xxxxx
login
line vty 5 15
password xxxxx
login
!
end

****Switch 2****
Building configuration...

Current configuration : 2100 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname NYSwitch2
!
enable secret 5 $1$WFoj$vc6dMm1s5T0qb00UUVjkk0
!
ip subnet-zero
!
cluster commander-address 000d.2857.f0c0 member 1 name istarsw
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
interface FastEthernet0/1
no ip address
!
interface FastEthernet0/2
no ip address
!
interface FastEthernet0/3
no ip address
!
interface FastEthernet0/4
no ip address
!
interface FastEthernet0/5
no ip address
!
interface FastEthernet0/6
no ip address
!
interface FastEthernet0/7
no ip address
!
interface FastEthernet0/8
no ip address
!
interface FastEthernet0/9
no ip address
!
interface FastEthernet0/10
switchport access vlan 2
no ip address
!
interface FastEthernet0/11
switchport access vlan 2
no ip address
!
interface FastEthernet0/12
switchport access vlan 2
no ip address
!
interface FastEthernet0/13
switchport access vlan 2
no ip address
!
interface FastEthernet0/14
switchport access vlan 2
no ip address
!
interface FastEthernet0/15
switchport access vlan 2
no ip address
!
interface FastEthernet0/16
switchport access vlan 2
no ip address
duplex full
speed 10
!
interface FastEthernet0/17
no ip address
!
interface FastEthernet0/18
no ip address
!
interface FastEthernet0/19
no ip address
!
interface FastEthernet0/20
no ip address
!
interface FastEthernet0/21
no ip address
!
interface FastEthernet0/22
no ip address
!
interface FastEthernet0/23
no ip address
!
interface FastEthernet0/24
no ip address
!
interface GigabitEthernet0/1
no ip address
!
interface GigabitEthernet0/2
no ip address
!
interface Vlan1
ip address 192.168.25.241 255.255.255.0
no ip route-cache
!
ip default-gateway 192.168.25.1
ip http server
!
snmp-server community VRTest RO
snmp-server community $15tar$ RO
snmp-server community VRTest@es1 RO
snmp-server location IDF
snmp-server contact Chris Beach
!
line con 0
line vty 0 4
password xxxxx
login
line vty 5 15
password xxxxx
login
!
end

****Switch 3****
Building configuration...

Current configuration : 1309 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname NYSwitch8
!
enable secret 5 $1$JMtm$/dwTsRQNVduawQtjq2SDG/
enable password xxxxx
!
ip subnet-zero
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
switchport access vlan 2
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
ip address 192.168.25.247 255.255.255.0
no ip route-cache
!
ip default-gateway 192.168.25.1
ip http server
snmp-server community !istar! RO
!
line con 0
line vty 0 4
password xxxxx
login
line vty 5 15
password xxxxx
login
!
!
end

 
Reply With Quote
 
Tomasz Paszkowski
Guest
Posts: n/a
 
      07-11-2005
W artykule <(E-Mail Removed). com> cb napisał(a):

What are the ports connecting switch2 with switch3 ?

TP
 
Reply With Quote
 
cb
Guest
Posts: n/a
 
      07-11-2005
Thanks again for your reply TP.

I ended up creating another vlan all together and everything works fine
now. I don't know what the problem was with the second vlan, but I
couldn't find anything particular about it that was mis-configured. I
now have vlan3 and it all works, no issues.

I wish I knew what was wrong with vlan2 only because whatever happened
maybe could happen again to vlan3, but maybe not?

Thanks again for your help.

cb

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Confused - VLANs, 3550 and 2950 switches The Other Mike Cisco 5 11-10-2006 08:22 PM
Windows - Browsing across vlans and also DC's on separate vlans punisher Cisco 2 11-17-2005 03:41 PM
Traffic Across Wireless Bridge w/ 2 VLANs using 2 Cisco 2950 Switches? Jack Taugher Cisco 2 09-20-2005 05:49 AM
question about Mapping 802.1Q VLANs to ISL VLANs ilya@3ka.mipt.ru Cisco 0 01-11-2005 02:42 PM
Help on Routing/VLANs with new 1712 and a 2950 switch Peter Rowe Cisco 0 11-17-2003 02:54 PM



Advertisments