Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Simple issue on NAT

Reply
Thread Tools

Simple issue on NAT

 
 
Peppe C
Guest
Posts: n/a
 
      06-24-2005
I'm sorry for the silly issue, but I have a very basic knowledge of Cisco
and today I've lost many hours without seeing the light.
The configuration is very simple: I have a couple of 803 linked via ISDN
line named Rome and Naples.
In Rome my subnet is 167.228.167.xxx, in Naples is 192.168.0.xxx
Unfortunately I cant call the subnet 192.168.0.xxx from Rome because it's
already used in the WAN I'm connected.

So I have to use a static NAT to translate the only address I'm interested
192.168.0.134 in 192.168.15.134

On the NAPLES router I've configured the BRI0 isdn port as inside and the
ethernet (where is connected the remote host) as outside.
When I ping 192.168.15.134 from naples the IP is correctly converted in
192.168.0.134 and everything goes fine.

00:03:06: IP: tableid=0, s=192.168.0.133 (local), d=192.168.15.134
(Ethernet0), routed via RIB
00:03:06: IP: s=192.168.0.133 (local), d=192.168.15.134 (Ethernet0), len
100, sending
00:03:06: NAT: s=192.168.0.133, d=192.168.15.134->192.168.0.134 [11]
00:03:06: IP: tableid=0, s=192.168.0.134 (Ethernet0), d=192.168.0.133
(Ethernet0), routed via RIB
00:03:06: IP: s=192.168.0.134 (Ethernet0), d=192.168.0.133 (Ethernet0), len
100, rcvd 3


When I ping from rome, the router dials and connects to naples, but ping
fails.
Debugging on Naples I see all this encapsulation errors and no NAT
translation!!!

00:04:22: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 061234567
ROME
00:04:23: IP: tableid=0, s=167.228.167.113 (Dialer1), d=192.168.15.133
(Ethernet0), routed via RIB
00:04:23: IP: s=167.228.167.113 (Dialer1), d=192.168.15.133 (Ethernet0),
g=192.168.15.133, len 100, forward
00:04:23: IP: s=167.228.167.113 (Dialer1), d=192.168.15.133 (Ethernet0), len
100, encapsulation failed


What can it be? I know its a missing route but I can't find it !!!
As you can see from the router the configuration is quite simple...
Could you be so kind to point me in the right direction?

Many thanks
Giuseppe

version 12.3
!
hostname NAPLES
!
boot-start-marker
boot-end-marker
!
username ROME password 7 asdasdasdas
!
no aaa new-model
ip subnet-zero
no ip domain lookup
!
isdn switch-type basic-net3
!
interface Ethernet0
description connected to EthernetLAN_1
ip address 192.168.0.133 255.255.255.0
ip nat outside
no keepalive
!
interface BRI0
description connected to ROME
no ip address
ip nat inside
encapsulation ppp
dialer rotary-group 1
dialer-group 1
isdn switch-type basic-net3
no cdp enable
!
interface Dialer1
description connected to ROME
ip unnumbered Ethernet0
encapsulation ppp
no ip split-horizon
dialer in-band
dialer map ip 167.228.167.113 name ROME broadcast 01234567
dialer hold-queue 10
dialer-group 1
no cdp enable
ppp authentication chap
!
ip nat outside source static 192.168.0.134 192.168.15.134
ip route 192.168.15.0 255.255.255.0 Ethernet0
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
snmp-server engineID local 00000009020001308003F817
snmp-server community public RO


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VPN, from nat without VPN to nat with it Allan Wilson Cisco 1 07-05-2004 10:51 PM
Identity Nat v Exemption NAT Kenny D Cisco 1 05-08-2004 03:11 PM
NAT exemption versus Static NAT. Where is the difference? Anonymous Poster Cisco 0 04-26-2004 04:29 AM
Attn: NAT Experts - 2611XM and NAT pool JCVD Cisco 1 02-13-2004 12:30 PM
NAT or Not to NAT; how to do an Internet connection for a 100-PC company ? Al Dykes Cisco 8 10-29-2003 12:34 AM



Advertisments