Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Need help in configuring WRED using TOS/DiffServ

Reply
Thread Tools

Need help in configuring WRED using TOS/DiffServ

 
 
masterbit
Guest
Posts: n/a
 
      06-03-2005
Hello,

ive got a big problem in understanding the documentation related to
WRED/RED-configuration on the CCO...

The priorization of VoIP-traffic on the WAN-side is doing well with
this configuration, but im trying to "tune" this basic configuration
for better voice-quality.
I need this feature for VoIP-Traffic-Priorization on the LAN-Interface,
but dont understand how to do it right, especially the options of the
IOS-command "random-detect dscp-based" mentioned by cisco in the
documents i read.

To specify my needs:
I want to prioritize traffic with the TOS/DiffServ value of 3, as this
is the relevant traffic of the voice-components. Also i have to mention
that i cannot alter this setting, so i have to work with it.
The idea is to set this, as an important traffic, to a very high
priorization level on the LAN-interface, so in no condition a voice
packet will be dropped.

Also i would thank you much if you could give me a short explanation/
configuration example of doing this based on my begun configuration as
seen below (see e0/0).

Sorry for my perhaps "dumb" question, but im very new in configuring
qos-networking, my main former experience was
tokenring/DLSW/Bridging/SNA, and as a result of this, i hadnt the
need for qos since now...

Thanks a lot in advance,

Peter

PS:
If you could write it in german, it would help me a lot further, since
its my motherlanguage


CONFIGURATION OF THE ROUTER IN THE OFFICE
-----------------------------------------


xxxxxxx#sh ver
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-I-M), Version 12.2(19), RELEASE SOFTWARE
(fc3)
Copyright (c) 1986-2003 by cisco Systems, Inc.
Compiled Tue 12-Aug-03 23:36 by kellmill
Image text-base: 0x8000808C, data-base: 0x80A183F0

ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

kaiserstrasse uptime is 1 year, 3 weeks, 6 days, 8 hours, 6 minutes
System returned to ROM by reload
System restarted at 05:58:31 METDST Sat May 8 2004
System image file is "flash:c2600-i-mz.122-19.bin"

cisco 2612 (MPC860) processor (revision 0x102) with 20480K/4096K bytes
of memory
..
Processor board ID JAB03490404 (2201902424)
M860 processor: part number 0, mask 49
Bridging software.
X.25 software, Version 3.0.0.
1 Ethernet/IEEE 802.3 interface(s)
1 Token Ring/IEEE 802.5 interface(s)
1 Serial network interface(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

xxxxxxx#


xxxxxxx#sh conf
Using 2739 out of 29688 bytes
!
! Last configuration change at 22:46:47 METDST Fri Jun 3 2005
! NVRAM config last updated at 22:46:48 METDST Fri Jun 3 2005
!
version 12.2
service timestamps debug datetime msec localtime
service timestamps log datetime localtime
service password-encryption
!
hostname xxxxxxx
!
logging buffered 4096 debugging
enable secret xxxxxxx
enable password xxxxxxx
!
clock timezone MET 1
clock summer-time METDST recurring last Sun Mar 2:00 last Sun Oct 3:00
ip subnet-zero
!
!
no ip domain-lookup
!
!
!
class-map match-all VOICE-xxxxxxx
match access-group name VOICE-xxxxxxx
!
!
policy-map VOICE-xxxxxxx
class VOICE-xxxxxxx
priority 900
!
!
!
interface Loopback1
ip address 123.123.32.132 255.255.255.255
!
interface Ethernet0/0
description Lokales Ethernet
ip address 123.123.38.129 255.255.255.128 secondary
ip address 123.123.38.1 255.255.255.128
ip helper-address 123.123.23.250
full-duplex
random-detect dscp-based
!
interface Serial0/0
description 2048k Verbindung -> Router xxxxxxx
bandwidth 2048
ip address 123.123.32.18 255.255.255.252
service-policy output VOICE-xxxxxxx
!
interface TokenRing0/0
shutdown
!
router ospf 70
log-adjacency-changes
passive-interface TokenRing0/0
network 123.123.32.16 0.0.0.3 area 32
network 123.123.32.132 0.0.0.0 area 32
network 123.123.38.0 0.0.0.255 area 32
!
ip classless
no ip http server
!
!
ip access-list extended VOICE-xxxxxxx
permit ip host 123.123.38.170 any
permit ip host 123.123.38.171 any
permit ip host 123.123.38.172 any
permit ip host 123.123.38.173 any
permit ip host 123.123.38.174 any
permit ip host 123.123.38.175 any
permit ip host 123.123.38.176 any
permit ip host 123.123.38.177 any
permit ip host 123.123.38.178 any
permit ip host 123.123.38.180 any
permit ip host 123.123.38.185 any
permit ip host 123.123.38.195 any
logging 123.123.70.36
snmp-server community xxxxxxxxxxx RO
snmp-server location xxxxxxxxxxx
snmp-server enable traps tty
!
line con 0
line aux 0
transport input all
line vty 0 4
exec-timeout 30 0
password xxxxxxxxxxxx
login
!
ntp clock-period 17180001
ntp server 123.123.12.250
end

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help configuring security and role management settings for website Philipp Lenz ASP .Net 1 12-02-2005 04:04 AM
how to implement RED or WRED vickysmile@hotmail.com Cisco 0 04-05-2005 02:57 AM
Need help configuring router Les Cisco 0 06-24-2004 08:20 PM
Re: Need help configuring cisco 2610xm ibs Cisco 0 04-03-2004 09:57 AM
Need help configuring PIX 501 for proxy arp Bobby Kuzma Cisco 6 12-31-2003 04:42 AM



Advertisments