Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > rate limiting an ethernet subinterface?

Reply
Thread Tools

rate limiting an ethernet subinterface?

 
 
dexx
Guest
Posts: n/a
 
      06-03-2005
My telco is able to handle vlan tagging and dot1q encapsulation. They
present their services via ethernet fibre or copper. What would be the
easiest way to configure my router to limit the traffic rate on each
subinterface?

Eg, my router has a 10mb copper ethernet connection to the telco and
two remote sites route through. The actual barer speed is 4mb. What
would be the easiest way to limit the traffic on both remotes to 2mbs
each?

interface fastethernet0/1.2
encapsulation dot1q 2
ip address 192.168.101.1 255.255.255.252

interface fastethernet0/1.3
encapsulation dot1q 3
ip address 192.168.101.9 255.255.255.252

 
Reply With Quote
 
 
 
 
pg.ijpelaar@home.nl
Guest
Posts: n/a
 
      06-03-2005

Depending on the type of L3 switch / router, I would use the following
for a 3550:

!
mls qos
!
class-map match-all allip
match access-group 100
!
policy-map 2mbps
class allip
police 2000000 32000 exceed-action drop
!
int fa0/1.2
encapsulation dot1q 2
ip address 192.168.101.1 255.255.255.252
service policy input 2mpps
service policy output 2mbps

int fa0/1.3
encapsulation dot1q 2
ip address 192.168.101.9 255.255.255.252
service policy input 2mpps
service policy output 2mbps
!
access-list 100 permit ip any any
!


Goodluck!

Paul

On 2 Jun 2005 22:22:23 -0700, "dexx" <(E-Mail Removed)> wrote:

>My telco is able to handle vlan tagging and dot1q encapsulation. They
>present their services via ethernet fibre or copper. What would be the
>easiest way to configure my router to limit the traffic rate on each
>subinterface?
>
>Eg, my router has a 10mb copper ethernet connection to the telco and
>two remote sites route through. The actual barer speed is 4mb. What
>would be the easiest way to limit the traffic on both remotes to 2mbs
>each?
>
>interface fastethernet0/1.2
> encapsulation dot1q 2
> ip address 192.168.101.1 255.255.255.252
>
>interface fastethernet0/1.3
> encapsulation dot1q 3
> ip address 192.168.101.9 255.255.255.252



 
Reply With Quote
 
 
 
 
dexx
Guest
Posts: n/a
 
      06-08-2005
Thanks for that reply. Ive since read that using 'match ip dscp 0' in
the class map also works well. Can you (or others) offer advice on
choosing the 'burst bytes' value for the 'police' line? For my 2mb
ethernet-delivered fibre link you've specified 32000 for the token
bucket size. What is a good way of determining this?

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rate limiting with 3550 and 3750 troubles Rick Cisco 10 12-17-2008 11:21 AM
6500: User-Based Rate Limiting AND Total Rate Limiting Patrick Cervicek Cisco 0 08-07-2007 03:07 PM
rate-limiting cisco 1760 sdsl-wic Jeroen Cisco 0 01-05-2004 11:46 AM
Can 803 (ISDN-ethernet) work ethernet-ethernet? Peter Cisco 2 12-11-2003 11:24 PM
Rate Limiting on a 3550/2950 combo Craig Whitmore Cisco 0 07-20-2003 01:49 AM



Advertisments