Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Question: Reverse telnet with a 2509 : does not work on switches

Reply
Thread Tools

Question: Reverse telnet with a 2509 : does not work on switches

 
 
Voitec
Guest
Posts: n/a
 
      05-27-2005
Hi,

I just set up reverse telnet on my 2509 to connect to 3 switches and 5
routers. I can access each router OK but none of the switches. Is there
something extra I should do for the switches? They are all 1900s.

Thanks,
V


Pls see the following config outputs:
Router#sh run
Building configuration...

Current configuration : 745 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
ip subnet-zero
ip host 2503-1 2008 172.21.1.1
ip host 2514-1 2007 172.21.1.1
ip host 2504-3 2006 172.21.1.1
ip host 2504-2 2005 172.21.1.1
ip host 2504-1 2004 172.21.1.1
ip host Cat-3 2003 172.21.1.1
ip host Cat-2 2002 172.21.1.1
ip host Cat-1 2001 172.21.1.1
!
!
!
!
interface Loopback0
ip address 172.21.1.1 255.0.0.0
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
ip classless
ip http server
!
!
!
line con 0
line 1 8
exec-timeout 0 0
no exec
transport input all
flowcontrol hardware
line aux 0
line vty 0 4
!
end




Router#sh line
Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns
Int
* 0 CTY - - - - - 4 1
0 -
* 1 TTY 9600/9600 - - - - - 0 0
0 -
* 2 TTY 9600/9600 - - - - - 0 1
6/230 -
* 3 TTY 9600/9600 - - - - - 0 0
4/584 -
4 TTY 9600/9600 - - - - - 1 1
0 -
* 5 TTY 9600/9600 - - - - - 0 0
9 -
6 TTY 9600/9600 - - - - - 1 2
0 -
7 TTY 9600/9600 - - - - - 2 2
0 -
8 TTY 9600/9600 - - - - - 0 0
0 -
9 AUX 9600/9600 - - - - - 0 0
0 -
10 VTY - - - - - 0 0
0 -
11 VTY - - - - - 0 0
0 -
12 VTY - - - - - 0 0
0 -
13 VTY - - - - - 0 0
0 -
14 VTY - - - - - 0 0
0 -

Router#sh ip int br
Interface IP-Address OK? Method Status
Prot
ocol
Ethernet0 unassigned YES unset administratively down
down

Loopback0 172.21.1.1 YES manual up
up

Serial0 unassigned YES unset administratively down
down

Serial1 unassigned YES unset administratively down
down

Router#

Router#telnet Cat-1
Trying Cat-1 (172.21.1.1, 2001)...
% Connection refused by remote host

Router#telnet 172.21.1.1 2001
Trying 172.21.1.1, 2001 ...
% Connection refused by remote host

Router#telnet 172.21.1.1 2002
Trying 172.21.1.1, 2002 ...
% Connection refused by remote host

Router#telnet 172.21.1.1 2003
Trying 172.21.1.1, 2003 ...
% Connection refused by remote host

Router#telnet 172.21.1.1 2004
Trying 172.21.1.1, 2004 ... Open


 
Reply With Quote
 
 
 
 
datakazam
Guest
Posts: n/a
 
      05-27-2005
I reccomend taking a look at the line con configuration for the
switches. router looks ok.

 
Reply With Quote
 
 
 
 
Voitec
Guest
Posts: n/a
 
      05-27-2005
Hi,

Can you be more specific?

I did not have to set anything up on the individual routers so I'm not sure
why I should set anything up on the switches.
AFAIK the 'line 1 8' statements are the same for all devices.



"datakazam" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) ups.com...
> I reccomend taking a look at the line con configuration for the
> switches. router looks ok.
>



 
Reply With Quote
 
Hansang Bae
Guest
Posts: n/a
 
      05-29-2005
Voitec wrote:

> Hi,
>
> I just set up reverse telnet on my 2509 to connect to 3 switches and 5
> routers. I can access each router OK but none of the switches. Is
> there something extra I should do for the switches? They are all
> 1900s.


Maybe. First, remove the hardware flow control as console ports cannot
use it. Also, depending on the model, you may need to introduce a null
modem adapter (or its wiring equivalent)

But *just* to be sure, I'm assuming you took a known-good one and tried
it on the switch console port?

--

hsb


"Somehow I imagined this experience would be more rewarding" Calvin
**************************ROT13 MY ADDRESS*************************
Due to the volume of email that I receive, I may not not be able to
reply to emails sent to my account. Please post a followup instead.
************************************************** ******************
 
Reply With Quote
 
Voitec
Guest
Posts: n/a
 
      05-30-2005
Thank you HSB. HW flow control was the culprit!



"Hansang Bae" <(E-Mail Removed)> wrote in message
newsB8me.14764$(E-Mail Removed)...
> Voitec wrote:
>
> > Hi,
> >
> > I just set up reverse telnet on my 2509 to connect to 3 switches and 5
> > routers. I can access each router OK but none of the switches. Is
> > there something extra I should do for the switches? They are all
> > 1900s.

>
> Maybe. First, remove the hardware flow control as console ports cannot
> use it. Also, depending on the model, you may need to introduce a null
> modem adapter (or its wiring equivalent)
>
> But *just* to be sure, I'm assuming you took a known-good one and tried
> it on the switch console port?
>
> --
>
> hsb
>
>
> "Somehow I imagined this experience would be more rewarding" Calvin
> **************************ROT13 MY ADDRESS*************************
> Due to the volume of email that I receive, I may not not be able to
> reply to emails sent to my account. Please post a followup instead.
> ************************************************** ******************



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2509 console not responiding jaddi_asad Cisco 0 03-14-2008 02:55 AM
Telnet - attempting to initiate a telnet session within an established telnet session Carcarius Ruby 0 12-06-2007 03:26 AM
2509 asy port can not receive all data at speed of 9600 shark Cisco 0 08-12-2004 01:14 AM
"ip addr dhcp" is not available for my IOS release, who has latest IOS for 2514 and 2509? Ed Kideys, Tech-Train Cisco 3 04-30-2004 07:51 PM



Advertisments