Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > how to make linux bridge's 802.1q STP packet across cisco switch?

Reply
Thread Tools

how to make linux bridge's 802.1q STP packet across cisco switch?

 
 
hansyin@gmail.com
Guest
Posts: n/a
 
      05-19-2005
I'm testing linux redhat fedora 3 bridge STP function. don't enable stp
on cisco switch.
I found linux send BPDU packet with 802.1Q tag, and then cisco 3550
switch block the packet. then, if linux had two cable connected to
cisco switch's same vlan(one is using 802.1q trunk), althrough I have
STP enabled on linux, linux will let all two ports working as
forwarding state, then it will cause broadcast storm.
the problem may be based on two points: one is Linux shouldn't add
802.1q tag for its BPDU packet although it's using 802.1q trunk,
another one is that cisco should not block the BPDU packet, it should
broadcast it after untagging it. which one is the real problem?

linux use 01:80:c2:00:00:00 as destination mac address for its BPDU
packets, maybe cisco doesn't recognize this packet in its non-native
vlan. (according cisco's pvst+ knowledge, it only recognize this mac
address in its native vlan, in its non-native vlan, it use
01:00:0c:cc:cc:cd as BPDU's mac address.) how can i workaround this
problem?

Thanks.


Hans Yin

 
Reply With Quote
 
 
 
 
Erik Tamminga
Guest
Posts: n/a
 
      05-21-2005
Sounds to me you have a native-vlan mismatch. Try to either change the linux
or cisco switch to properly tag the vlans.
If you're not able to change the native-vlan on the linux machine, configure
the cisco to use an unused vlan as native vlan

Erik

<(E-Mail Removed)> wrote in message
news:(E-Mail Removed) oups.com...
> I'm testing linux redhat fedora 3 bridge STP function. don't enable stp
> on cisco switch.
> I found linux send BPDU packet with 802.1Q tag, and then cisco 3550
> switch block the packet. then, if linux had two cable connected to
> cisco switch's same vlan(one is using 802.1q trunk), althrough I have
> STP enabled on linux, linux will let all two ports working as
> forwarding state, then it will cause broadcast storm.
> the problem may be based on two points: one is Linux shouldn't add
> 802.1q tag for its BPDU packet although it's using 802.1q trunk,
> another one is that cisco should not block the BPDU packet, it should
> broadcast it after untagging it. which one is the real problem?
>
> linux use 01:80:c2:00:00:00 as destination mac address for its BPDU
> packets, maybe cisco doesn't recognize this packet in its non-native
> vlan. (according cisco's pvst+ knowledge, it only recognize this mac
> address in its native vlan, in its non-native vlan, it use
> 01:00:0c:cc:cc:cd as BPDU's mac address.) how can i workaround this
> problem?
>
> Thanks.
>
>
> Hans Yin
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
import packet.module without importing packet.__init__ ? Gelonida N Python 4 09-11-2011 02:17 PM
convert the ip packet to and from RS-232 packet Li Han Python 2 02-09-2009 02:43 PM
Security: rec'd packet not an ipsec packet ! mediumkuriboh Cisco 0 02-09-2009 12:14 AM
%PIX-4-402106: Rec'd packet not an IPSEC packet. lfnetworking Cisco 3 08-27-2006 05:30 AM
Cisco IP phones deregistering/registering sporadically (STP switch problem).... wr Cisco 1 05-24-2004 04:36 AM



Advertisments