Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Java > rmi problems

Reply
Thread Tools

rmi problems

 
 
boyScout
Guest
Posts: n/a
 
      02-20-2007
hi I need help, I'm learning rmi and when trying to run the server
code I get an error:
Exception in thread "main"
java.lang.UnsupportedClassVersionError:srcEcho(Uns upported major.minor
version 50.0):
at ....
at ....
at ....
and I'm using java 1.3.1_01.

What should I do? Thanks

 
Reply With Quote
 
 
 
 
rajatag
Guest
Posts: n/a
 
      02-20-2007
On Feb 20, 12:01 pm, "boyScout" <(E-Mail Removed)> wrote:
> hi I need help, I'm learning rmi and when trying to run the server
> code I get an error:
> Exception in thread "main"
> java.lang.UnsupportedClassVersionError:srcEcho(Uns upported major.minor
> version 50.0):
> at ....
> at ....
> at ....
> and I'm using java 1.3.1_01.
>
> What should I do? Thanks


You are probably using two different versions of Java for compiling /
executing.

 
Reply With Quote
 
 
 
 
Sanjay
Guest
Posts: n/a
 
      02-20-2007
boyScout wrote:
> hi I need help, I'm learning rmi and when trying to run the server
> code I get an error:
> Exception in thread "main"
> java.lang.UnsupportedClassVersionError:srcEcho(Uns upported major.minor
> version 50.0):
> at ....
> at ....
> at ....
> and I'm using java 1.3.1_01.
>
> What should I do? Thanks
>


I guess your rmi server needs 1.5 rather than 1.3
 
Reply With Quote
 
Lew
Guest
Posts: n/a
 
      02-20-2007
"boyScout" wrote:
>> hi I need help, I'm learning rmi and when trying to run the server
>> code I get an error:
>> Exception in thread "main"
>> java.lang.UnsupportedClassVersionError:srcEcho(Uns upported major.minor
>> version 50.0):
>> at ....
>> at ....
>> at ....
>> and I'm using java 1.3.1_01.
>>
>> What should I do? Thanks


Java 1.3 is obsolete. Java 1.4 is getting ancient. Java 5 is the previous
version. Java 6 is the current version.

The class was compiled with a version of Java that uses classfile version
50.0. I am not sure, I leave the Googling to you, but I think that is a class
file generated by Java 6. You tried to run it under the obsolete, unsupported
Java 1.3 and it failed.

Either compile the class with "-target 1.3" or upgrade to a current,
non-obsolete version of Java.

- Lew
 
Reply With Quote
 
boyScout
Guest
Posts: n/a
 
      02-20-2007
sorry I don't understand, last week I installed java 6 and now if i
did understand you're trying to tell to install java 5. I'm still
confused. Why is my class version of 1.3 when I have java 6. I have
both jdk 1.6.0 and jre 1.6.6. I can't understand why it don't work.

 
Reply With Quote
 
Jujo
Guest
Posts: n/a
 
      02-20-2007
"Lew" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> "boyScout" wrote:
>>> hi I need help, I'm learning rmi and when trying to run the server
>>> code I get an error:
>>> Exception in thread "main"
>>> java.lang.UnsupportedClassVersionError:srcEcho(Uns upported major.minor
>>> version 50.0):
>>> at ....
>>> at ....
>>> at ....
>>> and I'm using java 1.3.1_01.
>>>
>>> What should I do? Thanks

>
> Java 1.3 is obsolete. Java 1.4 is getting ancient. Java 5 is the previous
> version. Java 6 is the current version.
>
> The class was compiled with a version of Java that uses classfile version
> 50.0. I am not sure, I leave the Googling to you, but I think that is a
> class file generated by Java 6. You tried to run it under the obsolete,
> unsupported Java 1.3 and it failed.
>
> Either compile the class with "-target 1.3" or upgrade to a current,
> non-obsolete version of Java.
>
> - Lew
>


Hmm not true Java 1.4 is geeting ancient - in fact it`s still used in most
business projects...

Jujo



 
Reply With Quote
 
Nigel Wade
Guest
Posts: n/a
 
      02-20-2007
boyScout wrote:

> sorry I don't understand, last week I installed java 6 and now if i
> did understand you're trying to tell to install java 5.


No, Lew didn't suggest that, I don't know where you got that idea from.

> I'm still
> confused. Why is my class version of 1.3 when I have java 6. I have
> both jdk 1.6.0 and jre 1.6.6. I can't understand why it don't work.


The other way around. Your compiler is Java 6. The JRE you are using to execute
the byte-code (maybe either java or rmiregistry if you are using that) is from
an older version of Java and cannot use the 50.0 version classfiles.

--
Nigel Wade, System Administrator, Space Plasma Physics Group,
University of Leicester, Leicester, LE1 7RH, UK
E-mail : http://www.velocityreviews.com/forums/(E-Mail Removed)
Phone : +44 (0)116 2523548, Fax : +44 (0)116 2523555
 
Reply With Quote
 
Chris Uppal
Guest
Posts: n/a
 
      02-20-2007
Jujo wrote:

> Hmm not true Java 1.4 is geeting ancient - in fact it`s still used in most
> business projects...


Both can be true at once

Businesses often like to use the oldest available version of software that
still works. So often the most popular version is also ancient...

-- chris



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why does java.rmi.Naming not implement interface java.rmi.Registry? Jan Schulze Java 1 03-26-2005 07:45 AM
RMI Vs RMI over IIOP JScoobyCed Java 1 01-28-2005 09:54 AM
RMI problems Max Mustermann Java 3 11-25-2004 08:21 AM
RMI, JINI or RMI/IIOP Buu Nguyen Java 1 08-25-2004 11:28 AM
RMI problems Jeremy Brooks Java 1 09-24-2003 02:12 AM



Advertisments