Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > link type is force-up

Reply
Thread Tools

link type is force-up

 
 
Erik Tamminga
Guest
Posts: n/a
 
      05-05-2005
Hi,

On a Catalyst 4500 with SX-GBICs what does "link type is force-up" mean
(show interface gi1/2, sx-gbic)?
We're having troubles bringing up a link between a Cat4500 and Cat2950-sx24.
Link light on 2950 doesn't light up. Link light on 4500-side does light up.
We already exchanged ports / gbics / ... .

Cisco.com doesn't have an explanation of the "force-up" state (or I can't
find it).

Erik


 
Reply With Quote
 
 
 
 
anybody43@hotmail.com
Guest
Posts: n/a
 
      05-05-2005
Please post the configs for the relevant ports.

I have had a look too and can't find anything much.


There is a thread in:

de.comp.hardware.netzwerke.misc

"E1000 bekommt keinen Link zum Catalyst-Switch"

Altavista babelfish helped slightly.

One of the 4500's that I look after says:

interface GigabitEthernet2/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,201-204
switchport mode trunk
udld port
flowcontrol send on
channel-group 1 mode desirable
!
interface GigabitEthernet2/2
!
interface GigabitEthernet3/1
spanning-tree portfast
!
interface GigabitEthernet3/2
spanning-tree portfast
!
interface GigabitEthernet3/3
spanning-tree portfast
!
interface GigabitEthernet3/4
spanning-tree portfast
......

bcm-sw1#sh int | inc duplex
Full-duplex, 1000Mb/s, link type is auto, media type is SX
Auto-duplex, Auto-speed
Full-duplex, 1000Mb/s, link type is auto, media type is SX
Auto-duplex, Auto-speed
Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
Auto-duplex, Auto-speed
Auto-duplex, Auto-speed
Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
Full-duplex, 100Mb/s
Auto-duplex, Auto-speed


bcm-sw1#sh ip int br
Interface IP-Address OK? Method Status
Protocol
Vlan1 192.168.20.248 YES NVRAM up
up
Vlan201 10.20.1.248 YES NVRAM up
up
Vlan202 10.20.2.248 YES NVRAM up
up
Vlan203 10.20.3.248 YES NVRAM up
up
Vlan204 10.20.4.248 YES manual up
up
GigabitEthernet1/1 unassigned YES unset up
up
GigabitEthernet1/2 unassigned YES unset down
down
GigabitEthernet2/1 unassigned YES unset up
up
GigabitEthernet2/2 unassigned YES unset down
down
GigabitEthernet3/1 unassigned YES unset up
up
GigabitEthernet3/2 unassigned YES unset up
up
GigabitEthernet3/3 unassigned YES unset up
up
GigabitEthernet3/4 unassigned YES unset down
down
GigabitEthernet3/5 unassigned YES unset down
down
GigabitEthernet3/6 unassigned YES unset up
up
GigabitEthernet3/7 unassigned YES unset up
up

 
Reply With Quote
 
 
 
 
anybody43@hotmail.com
Guest
Posts: n/a
 
      05-05-2005
Please post the configs for the relevant ports.

I have had a look too and can't find anything much.


There is a thread in:

de.comp.hardware.netzwerke.misc

"E1000 bekommt keinen Link zum Catalyst-Switch"

Altavista babelfish helped slightly.

One of the 4500's that I look after says:

interface GigabitEthernet2/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,201-204
switchport mode trunk
udld port
flowcontrol send on
channel-group 1 mode desirable
!
interface GigabitEthernet2/2
!
interface GigabitEthernet3/1
spanning-tree portfast
!
interface GigabitEthernet3/2
spanning-tree portfast
!
interface GigabitEthernet3/3
spanning-tree portfast
!
interface GigabitEthernet3/4
spanning-tree portfast
......

bcm-sw1#sh int | inc duplex
Full-duplex, 1000Mb/s, link type is auto, media type is SX
Auto-duplex, Auto-speed
Full-duplex, 1000Mb/s, link type is auto, media type is SX
Auto-duplex, Auto-speed
Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
Auto-duplex, Auto-speed
Auto-duplex, Auto-speed
Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
Full-duplex, 100Mb/s
Auto-duplex, Auto-speed


bcm-sw1#sh ip int br
Interface IP-Address OK? Method Status
Protocol
Vlan1 192.168.20.248 YES NVRAM up
up
Vlan201 10.20.1.248 YES NVRAM up
up
Vlan202 10.20.2.248 YES NVRAM up
up
Vlan203 10.20.3.248 YES NVRAM up
up
Vlan204 10.20.4.248 YES manual up
up
GigabitEthernet1/1 unassigned YES unset up
up
GigabitEthernet1/2 unassigned YES unset down
down
GigabitEthernet2/1 unassigned YES unset up
up
GigabitEthernet2/2 unassigned YES unset down
down
GigabitEthernet3/1 unassigned YES unset up
up
GigabitEthernet3/2 unassigned YES unset up
up
GigabitEthernet3/3 unassigned YES unset up
up
GigabitEthernet3/4 unassigned YES unset down
down
GigabitEthernet3/5 unassigned YES unset down
down
GigabitEthernet3/6 unassigned YES unset up
up
GigabitEthernet3/7 unassigned YES unset up
up

 
Reply With Quote
 
Erik Tamminga
Guest
Posts: n/a
 
      05-06-2005
Hi,

The config on both switches is actually quite easy:

interface GigabitEthernetX/Y
switchport mode access
!

In order to rule out any mis-configuration we stripped the config to the
bare minimum. My first goal is to see an up/up state on both sides of the
link.
Cat4500 says in show interface output "link type is force-up" and
administrative- and operational status "up".
Cat2950 says in show interface output operational status "down". Interface
is not in shutdown state.

I do not have physical access to the switches right now so I can't give you
more details.

Erik


<(E-Mail Removed)> wrote in message
news:(E-Mail Removed) oups.com...
> Please post the configs for the relevant ports.
>
> I have had a look too and can't find anything much.
>
>
> There is a thread in:
>
> de.comp.hardware.netzwerke.misc
>
> "E1000 bekommt keinen Link zum Catalyst-Switch"
>
> Altavista babelfish helped slightly.
>
> One of the 4500's that I look after says:
>
> interface GigabitEthernet2/1
> switchport trunk encapsulation dot1q
> switchport trunk allowed vlan 1,201-204
> switchport mode trunk
> udld port
> flowcontrol send on
> channel-group 1 mode desirable
> !
> interface GigabitEthernet2/2
> !
> interface GigabitEthernet3/1
> spanning-tree portfast
> !
> interface GigabitEthernet3/2
> spanning-tree portfast
> !
> interface GigabitEthernet3/3
> spanning-tree portfast
> !
> interface GigabitEthernet3/4
> spanning-tree portfast
> .....
>
> bcm-sw1#sh int | inc duplex
> Full-duplex, 1000Mb/s, link type is auto, media type is SX
> Auto-duplex, Auto-speed
> Full-duplex, 1000Mb/s, link type is auto, media type is SX
> Auto-duplex, Auto-speed
> Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
> Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
> Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
> Auto-duplex, Auto-speed
> Auto-duplex, Auto-speed
> Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
> Full-duplex, 100Mb/s
> Auto-duplex, Auto-speed
>
>
> bcm-sw1#sh ip int br
> Interface IP-Address OK? Method Status
> Protocol
> Vlan1 192.168.20.248 YES NVRAM up
> up
> Vlan201 10.20.1.248 YES NVRAM up
> up
> Vlan202 10.20.2.248 YES NVRAM up
> up
> Vlan203 10.20.3.248 YES NVRAM up
> up
> Vlan204 10.20.4.248 YES manual up
> up
> GigabitEthernet1/1 unassigned YES unset up
> up
> GigabitEthernet1/2 unassigned YES unset down
> down
> GigabitEthernet2/1 unassigned YES unset up
> up
> GigabitEthernet2/2 unassigned YES unset down
> down
> GigabitEthernet3/1 unassigned YES unset up
> up
> GigabitEthernet3/2 unassigned YES unset up
> up
> GigabitEthernet3/3 unassigned YES unset up
> up
> GigabitEthernet3/4 unassigned YES unset down
> down
> GigabitEthernet3/5 unassigned YES unset down
> down
> GigabitEthernet3/6 unassigned YES unset up
> up
> GigabitEthernet3/7 unassigned YES unset up
> up
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
#define ALLOCIT(Type) ((Type*) malloc (sizeof (Type))) Yevgen Muntyan C Programming 10 02-13-2007 02:52 AM
RE: Link Link Link =?Utf-8?B?REw=?= Windows 64bit 0 05-17-2005 12:15 PM
Re: Link Link Link DANGER WILL ROBINSON!!! Kevin Spencer ASP .Net 0 05-17-2005 10:41 AM
Re: Type casting- a larger type to a smaller type pete C Programming 4 04-02-2004 05:19 PM
Re: Type casting- a larger type to a smaller type heyo C Programming 3 04-01-2004 06:35 PM



Advertisments