Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Java > Cannot launch an exported standalone rcp application.

Reply
Thread Tools

Cannot launch an exported standalone rcp application.

 
 
Thibnes
Guest
Posts: n/a
 
      12-18-2006
Hi there,
I'm experiencing a problem when exporting a RCP product through
eclipse.
Could you take a look and tell me where I'm wrong please.

First, here is the arborescence of my project :
http://img83.imageshack.us/my.php?image=eclipse1yy6.png

For my project I've some libraries (external jars) , I need to select
them in the "Properties" of the projet in the section "Libraries" using
the "Add external Jar" button.
With that configuration, I could launch the project and all works fine.

To export my project, I saw that the export wizard can't find my
libraries (when they are selected in "properties" of the project). So,
I delete them from here and I add the libraries in the "plugin.xml /
Build / Extra classpath entries" section.
At this time, I can't launch the project anymore but the export "works
fine"


Then, this is what I'm doing to export my product :

Open the plug-in editor and switch to the Build page and add all the
files need.
Then I create a new Product file.
In the Overview tab I select the "Product ID", the "Application" and
set a name to my product
In the configuration and add my first element "net.witrack.manager" and
the click on "Add required plugins" to add others RCP plugin needed.

At this point, all the configuration is done.
But the "Launch the product" don't work, cause of the required
libraries missing in the "properties" of the project.
So lets try the export...
I export on a directory... no errors
In my directory I've some files, I launch the application and got this
error in the log file :

------------------------------
!SESSION 2006-12-18 11:42:17.546
-----------------------------------------------
eclipse.buildId=unknown
java.version=1.5.0_06
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.core.runtime 2006-12-18 11:42:18.484
!MESSAGE Product net.witrack.manager.managerID42 could not be found.

!ENTRY org.eclipse.osgi 2006-12-18 11:42:18.484
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at
org.eclipse.core.internal.runtime.PlatformActivato r$1.run(PlatformActivator.java:204)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.ru n(EclipseStarter.java:376)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.ru n(EclipseStarter.java:163)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknow n Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Un known Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.core.launcher.Main.invokeFramework(Mai n.java:334)
at org.eclipse.core.launcher.Main.basicRun(Main.java: 27
at org.eclipse.core.launcher.Main.run(Main.java:973)
at org.eclipse.core.launcher.Main.main(Main.java:94
------------------------------


Please enlighten me.
Thanks.

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Eclipse standalone RCP plugin application does not start in WinXP Gerd Rother Java 4 03-31-2006 09:33 PM
Cannot read exported XML File Zodiac ASP .Net 5 05-10-2005 12:27 PM
RCP through a Cisco with IP inspect enabled Abbie Normal Cisco 1 03-22-2005 08:54 PM
ANNOUNCE: RCP Server HeadsUp Support Cisco 0 10-27-2004 02:00 AM
Xml exported text Bob Perl 0 03-05-2004 11:25 PM



Advertisments