Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Problem with Login Control and Custom Membership provider

Reply
Thread Tools

Problem with Login Control and Custom Membership provider

 
 
=?ISO-8859-1?Q?Carlos_Guzm=E1n_=C1lvarez?=
Guest
Posts: n/a
 
      01-22-2007
Hello:

I have custom Membership and Role providers for an ASP.NET application,
the problem comes when the Authentication gets done ( and i'm using the
Login control, it finished properly ) but looks like the user is not
really logged in ( Verified using the LoginView control )

żż What could be the possible reasons for that problem ??

Thanks in advance !!!

P.S.: My web.config file for authenticaction and autorization looks like
this:

<!--
The <authentication> section enables configuration
of the security authentication mode used by
ASP.NET to identify an incoming user.
-->
<authentication mode="Forms">
<forms loginUrl="Renovacion.aspx"
protection="All"
timeout="30"
name=".ASPXFORMSAUTH"
path="/FormsAuth"
requireSSL="false"
slidingExpiration="true"
defaultUrl="Acceso.aspx"
cookieless="UseCookies"
enableCrossAppRedirects="false"/>
</authentication>

<membership
defaultProvider="MembershipProvider"
userIsOnlineTimeWindow="15">
<providers>
<add
connectionStringName="ConnectionString"
applicationName="XXX"
minRequiredPasswordLength="5"
minRequiredNonalphanumericCharacters="0"
enablePasswordRetrieval="true"
passwordFormat="Clear"
name="MembershipProvider"
type="XXX.XXXMembershipProvider"
/>
</providers>
</membership>

<roleManager
enabled="true"
cacheRolesInCookie="true"
defaultProvider="RoleProvider"
cookieName=".ASPXROLES"
cookiePath="/"
cookieTimeout="30"
cookieRequireSSL="false"
cookieSlidingExpiration="true"
createPersistentCookie="false"
cookieProtection="All">

<providers>
<clear />
<add
connectionStringName="ConnectionString"
applicationName="CaixanovaRenovacion"
writeExceptionsToEventLog="false"
name="XXX"
type="XXX.XXXRenovacionRoleProvider"
/>
</providers>
</roleManager>

<authorization>
<allow users="*"/>
</authorization>
 
Reply With Quote
 
 
 
 
=?ISO-8859-1?Q?Carlos_Guzm=E1n_=C1lvarez?=
Guest
Posts: n/a
 
      01-22-2007
Hello:

Got it working yet, thanks !!!
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Custom Membership Provider - Custom Error Messages Brett Ossman ASP .Net Security 0 03-11-2009 09:33 PM
Membership or Role Provider // Provider Model // Factories .. How does MS do it? sloan ASP .Net 1 07-03-2007 08:17 PM
Unable to redirect when using custom 'Login' with custom 'Membership provider' asnowfall@gmail.com ASP .Net 0 06-05-2007 05:15 PM
Deploying 2.0 app on a Service Provider .. Membership Provider sloan ASP .Net 5 06-03-2006 11:20 PM
How to use membership provider with login control ad ASP .Net 1 01-26-2006 09:49 PM



Advertisments