Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > CEF and EIGRP

Reply
Thread Tools

CEF and EIGRP

 
 
t0100980@hotmail.com
Guest
Posts: n/a
 
      04-04-2005
Hello all!

Sorry about my english. I'm trying to get CEF per-packet balancing to
work with EIGRP in a lab network. I have two unequal routes I want to
share packets (same source and destination). I have understood that CEF
makes its decisions based on routing table and EIGRP only keeps
successors in its routing table. It started to work when I added two
static routes.

I see both routes in topology table. So is it possible to get CEF
per-packet to work with EIGRP or should I do with static routes? The
network I want to load balance to is 172.16.5.0.
------------------------------------------------------------------------------
interface Ethernet0
description connected to SW1
ip address 172.16.4.1 255.255.255.0
no ip directed-broadcast
ip load-sharing per-packet
no ip mroute-cache
!
interface Serial0
description connected to LABA
ip address 172.16.1.1 255.255.255.0
no ip directed-broadcast
--More--   ip load-sharing per-packet
encapsulation ppp
no ip mroute-cache
!
interface Serial1
description connected to LABD
ip address 172.16.2.1 255.255.255.
no ip directed-broadcast
ip load-sharing per-packet
encapsulation ppp
no ip mroute-cache
clockrate 4000000
!
router eigrp 1
variance 10
redistribute connected
network 172.16.0.0

routing table:
----------------------------------------------------------------------------
172.16.0.0/16 is variably subnetted, 14 subnets, 2 masks
D 172.16.6.2/32 [90/2323456] via 172.16.1.2, 01:25:04, Serial0
[90/2809856] via 172.16.2.2, 01:25:04, Serial1
C 172.16.4.0/24 is directly connected, Ethernet0
D 172.16.5.0/24 [90/2195456] via 172.16.2.2, 01:25:04, Serial1
C 172.16.6.3/32 is directly connected, Loopback0
D 172.16.6.1/32 [90/2297856] via 172.16.1.2, 01:25:04, Serial0
C 172.16.2.2/32 is directly connected, Serial1
D 172.16.0.0/24 [90/2195456] via 172.16.1.2, 01:25:04, Serial0
D 172.16.3.2/32 [90/2681856] via 172.16.2.2, 01:25:04, Serial1
C 172.16.1.0/24 is directly connected, Serial0
C 172.16.2.0/24 is directly connected, Serial1
D 172.16.6.4/32 [90/2297856] via 172.16.2.2, 01:25:05, Serial1
------------------------------------------------------------------------------
topology table:

P 172.16.5.0/24, 1 successors, FD is 2195456, serno 168
via 172.16.2.2 (2195456/281600), Serial1
via 172.16.1.2 (2733056/2221056), Serial0

 
Reply With Quote
 
 
 
 
Andrey Tarasov
Guest
Posts: n/a
 
      04-04-2005
Hello, http://www.velocityreviews.com/forums/(E-Mail Removed)!
You wrote on 4 Apr 2005 07:03:59 -0700:

t> Sorry about my english. I'm trying to get CEF per-packet balancing
t> to work with EIGRP in a lab network. I have two unequal routes I
t> want to share packets (same source and destination). I have
t> understood that CEF makes its decisions based on routing table and
t> EIGRP only keeps successors in its routing table. It started to
t> work when I added two static routes.

t> topology table:

t> P 172.16.5.0/24, 1 successors, FD is 2195456, serno 168
t> via 172.16.2.2 (2195456/281600), Serial1
t> via 172.16.1.2 (2733056/2221056), Serial0

I don't think it's going to work. 2221056 (reported distance through Serial 0)
is more than 2195456 (feasible distance). From EIGRP point of view path through
Serial 0 might be a loop. You have to have reported distance to be lower than
feasible distance for both interfaces. Than you can play with variance to put
both paths into routing table even if they have different cost.

With best regards,
Andrey.

 
Reply With Quote
 
 
 
 
Jesper Skriver
Guest
Posts: n/a
 
      04-04-2005
On 4 Apr 2005 07:03:59 -0700, (E-Mail Removed) wrote:
> Hello all!
>
> Sorry about my english. I'm trying to get CEF per-packet balancing to
> work with EIGRP in a lab network. I have two unequal routes I want to
> share packets (same source and destination). I have understood that CEF
> makes its decisions based on routing table and EIGRP only keeps
> successors in its routing table. It started to work when I added two
> static routes.


If the routing table present multiple paths to CEF with the same
or different share weights, CEF will build loadbalance objects in
accordance with these weights, and use that for both per-packet
and per-destination load balancing.

/Jesper

--
Jesper Skriver, CCIE #5456, FreeBSD committer
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HARDWARE cef or SOFTWARE cef ? comp.dcom.sys.cisco Cisco 2 03-23-2006 01:09 PM
EIGRP, Want to prevent any EIGRP traffic to a interface BG Cisco 3 02-09-2006 08:05 PM
When only central CEF (not distributed CEF) is enabled on 7500-series router... ETLALAR Cisco 2 01-19-2004 10:39 AM
CEF and Dynamic Routing Chris Ames-Farrow Cisco 2 10-20-2003 01:49 PM
CEF and Dynamic Routing Chris Ames-Farrow Cisco 0 10-17-2003 09:48 PM



Advertisments