Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Switching before routing. (Diverting a VLAN.)

Reply
Thread Tools

Switching before routing. (Diverting a VLAN.)

 
 
professorguy professorguy is offline
Member
Join Date: Sep 2006
Posts: 39
 
      01-17-2007
I have a 3750 that is acting as a switch (no ip routing) which has trunks with vlan 17, 18 & 19 on them. I want all traffic tagged as 18 & 19 to go to the default gateway (core router) for routing. But I want the vlan 17 traffic to go directly to the vlan 17 server (10.17.17.1) on port 17.

If the trunk to the core does not allow vlan 17, those packets won't get to the core, and the switching function should allow the packets to get untagged and sent to the server. Correct?

Here's kind of what I mean:

interface GigabitEthernet1/0/15
description Trunk to Core
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 18,19
switchport mode trunk
!
interface GigabitEthernet1/0/16
description Trunk from Access Switch
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 17,18,19
switchport mode trunk
!
interface GigabitEthernet1/0/17
description VLAN 17 Server (10.17.17.1)
switchport access vlan 17
!

Will vlan17 packets coming in on Gi1/0/16 end up going out (de-tagged) on Gi1/0/17 ? Remember, this is a switch with no ip routing....
 
Reply With Quote
 
 
 
 
swapnendu swapnendu is offline
Member
Join Date: Sep 2006
Posts: 57
 
      01-18-2007
any traffic that belongs to Vlan 17 (source IP belongs to Vlan 17 subnet) and with a destination IP of 10.17.17.1 will always go via GigabitEthernet1/0/17.
 
Reply With Quote
 
 
 
 
professorguy professorguy is offline
Member
Join Date: Sep 2006
Posts: 39
 
      01-19-2007
Yesterday we moved our server room to a new wing and our new network relies on this "manual vlan pruning" to prevent loops and efficiently dedicate trunk bandwidth. So far, so good....

Thanks everyone for your helpful feedback.
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Process Switching vs. Fast/CEF Switching? asdf Cisco 7 05-29-2007 05:26 PM
Before Sunset & Before Sunrise matt r DVD Video 2 11-25-2004 08:37 AM
Switching AC to Battery loses wireless IP address =?Utf-8?B?c2tpYnVtNDQy?= Wireless Networking 6 10-28-2004 02:43 AM
Re: auto switching from LAN to Wifi connection Jeff Durham Wireless Networking 0 09-22-2004 05:39 PM
auto switching from LAN to Wifi connection =?Utf-8?B?Tml2ZWs=?= Wireless Networking 0 09-22-2004 03:37 PM



Advertisments