Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > DHCP relay problem

Reply
Thread Tools

DHCP relay problem

 
 
Iggy
Guest
Posts: n/a
 
      02-10-2005
My Windows XP SP2 client is unable to acquire IP address from Windows 2003
DHCP server. I configured ip helper-address on SVI... ip forward-protocol
udp has been entered. I tried this on Catalyst3750 and 2811 router and there
is no success...please help...
My windows client always acquire address from dhcp server when they are both
in the same VLAN. Of course, interVLAN routing works properly...

Is there something else to be configured?

B.R.
Igor


 
Reply With Quote
 
 
 
 
merv.hrabi@rogers.com
Guest
Posts: n/a
 
      02-10-2005

post the config without passwords

 
Reply With Quote
 
 
 
 
Iggy
Guest
Posts: n/a
 
      02-11-2005
Here is my show run output:

------------------ show running-config ------------------


Building configuration...

Current configuration : 6301 bytes
!
! Last configuration change at 10:06:48 CET Fri Feb 11 2005 by manager
! NVRAM config last updated at 17:47:56 CET Wed Feb 9 2005 by manager
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log datetime localtime
service password-encryption
no service dhcp
!
hostname INEM_c3750
!
logging buffered informational
enable secret ********
!
username ******* password *******
clock timezone CET 1
ip subnet-zero
ip routing
!
!
policy-map test
!
cluster enable Koncar 0
cluster member 2 mac-address 0011.21f7.0b40
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
spanning-tree vlan 1 priority 24576
!
! <irrelevant ports for the case removed for brevity>
!

interface GigabitEthernet1/0/15
description This is where DHCP client connects
switchport access vlan 3
no mdix auto
no cdp enable
spanning-tree portfast
spanning-tree guard root

interface Vlan1
description This is SVI for DHCP Server's VLAN
ip address 192.168.73.2 255.255.255.0
!

!
interface Vlan3
description SVI for DHCP client's VLAN
ip address 192.168.74.1
ip helper-address 192.168.73.6
!
router eigrp 1
redistribute static metric 1000000 20 255 1 1500
network 192.168.6.0
network 192.168.34.0
network 192.168.71.0
network 192.168.73.0
auto-summary
no eigrp log-neighbor-changes
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.71.1
ip route 192.168.70.0 255.255.255.0 192.168.71.1
ip http server
!
ip access-list extended CMP-NAT-ACL
dynamic Cluster-HSRP deny ip any any
dynamic Cluster-NAT permit ip any any
!
logging 192.168.73.13
snmp-server community <removed> RO
snmp-server community <removed> RO

!
line con 0
line vty 0 4
exec-timeout 0 0
login local
line vty 5 15
exec-timeout 0 0
login local
!
ntp clock-period 36028942
ntp server 192.168.73.68
end

------------------------------------------
B.R.
Igor


<(E-Mail Removed)> wrote in message
news:(E-Mail Removed) ups.com...
>
> post the config without passwords
>



 
Reply With Quote
 
merv.hrabi@rogers.com
Guest
Posts: n/a
 
      02-11-2005
The command "no service dhcp" maybe disabling the DHCP relay agent.

Try removing that command to see if the router will perform the
required DHCP realy agent function.

Please post outccome.

 
Reply With Quote
 
Iggy
Guest
Posts: n/a
 
      02-11-2005
I tried to enable DHCP service, but there is still nothing... I checked
what's happening using 'debug ip dhcp server packets' and discovered that my
switch actually do dhcp bootp messages forwarding to the ip helper
address... So, it seems that there is a problem with DHCP server config.

I suppose that the following is happening:
- switch forwards bootp message and rewrites 'giaddr ' field (with value of
client's SVI ip address)
- DHCP server receives this message and reads that according to 'giaddr'
field' client is not on the subnet for which server has a range (this is my
production DHCP server, so it has a range on single subnet and VLAN for
client is testing environment).
- DHCP server refuses to send DHCP offer.

If this is a cause of my problem then it's obvious that I'm expecting the
impossible I hoped that my DHCP server will issue a production range (just
to test if my dhcp relay is working), but I overlooked 'giaddr' field...

Next week I will create an additional scope on my DHCP server and then try
again...

Of course, I'll post outcome

B.R.
Igor

<(E-Mail Removed)> wrote in message
news:(E-Mail Removed) ps.com...
> The command "no service dhcp" maybe disabling the DHCP relay agent.
>
> Try removing that command to see if the router will perform the
> required DHCP realy agent function.
>
> Please post outccome.
>



 
Reply With Quote
 
M.C. van den Bovenkamp
Guest
Posts: n/a
 
      02-11-2005
Iggy wrote:

> If this is a cause of my problem then it's obvious that I'm expecting the
> impossible


Yep. That's your problem.

> Next week I will create an additional scope on my DHCP server and then try
> again...


That'll work.

Regards,

Marco.

 
Reply With Quote
 
Iggy
Guest
Posts: n/a
 
      02-16-2005
Hi,

As I thought today I created additional scope on my DHCP server and dhcp
relay is now functioning.

Thanks everyone for support...

B.R.
Igor

"Iggy" <(E-Mail Removed)> wrote in message
news:cug5i4$nss$(E-Mail Removed)...
> My Windows XP SP2 client is unable to acquire IP address from Windows 2003
> DHCP server. I configured ip helper-address on SVI... ip forward-protocol
> udp has been entered. I tried this on Catalyst3750 and 2811 router and
> there is no success...please help...
> My windows client always acquire address from dhcp server when they are
> both in the same VLAN. Of course, interVLAN routing works properly...
>
> Is there something else to be configured?
>
> B.R.
> Igor
>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dhcp Relay Agent And Acl On Sw 3750, DHCP Relay Agent and ACL on Sw 3750 Vimokh Cisco 3 09-06-2006 02:16 AM
aironet 1200 dhcp relay problem John Smith Cisco 2 01-26-2005 06:03 PM
Cisco VPN 3005 and DHCP relay Rutger Blom Cisco 0 05-25-2004 07:58 PM
Re: DHCP Relay with same IP subnet on remote network Javier Cisco 8 05-15-2004 12:29 PM
dhcp-relay: ip helper address fails tgot Cisco 2 02-13-2004 12:57 PM



Advertisments