Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Frame-Relay class based shaping

Reply
Thread Tools

Frame-Relay class based shaping

 
 
Andrew Smith
Guest
Posts: n/a
 
      02-05-2005
Hi,

We need some help or advice is it possible or not. Let me explain
our situation:

We have a client, which is connected through a frame-relay PVC with
CIR 512kbps. Through this PVC client gets internet and intranet
traffic.

We want to limit/shape internet traffic to 256kbps and within these
256kbps we want to reserve/prioritize some bandwidth (for example
32kbps) for voice gw. We have tried following configuration, but it
doesn't work. It doesn't complains about anything, just don't let us
to attach a class to PVC. Here's config we tried:
cta-22#sh run class-map
Building configuration...

!
class-map match-all not-intra
description -- nets not in intranet
match access-group 101
class-map match-all voice
description -- voice
match access-group name voice.acl
!
end
cta-22#sh run policy-map
Building configuration...

!
policy-map aral
class voice
priority 32
class class-default
fair-queue
policy-map aral-inet
class not-intra
shape average 256000
service-policy aral
class class-default
fair-queue
policy-map aral-512
description Shape aral to 512kbps
class class-default
shape average 512000
service-policy aral-inet
!
end

cta-22#sh run map
Building configuration...

Current configuration:
!
map-class frame-relay aral-512
service-policy output aral-512
frame-relay fragment 96
!
end
cta-22#sh run int ser 0/0
Building configuration...

Current configuration : 230 bytes
!
interface Serial0/0
description --Uplink
bandwidth 8192
no ip address
encapsulation frame-relay
ip route-cache policy
load-interval 30
no fair-queue
no frame-relay inverse-arp
frame-relay lmi-type cisco
end

cta-22#sh run int ser 0/0.640
Building configuration...

Current configuration : 166 bytes
!
interface Serial0/0.640 point-to-point
description --aral
bandwidth 512
ip address x.x.x.34 255.255.255.248
frame-relay interface-dlci 640
end

trying to attach map-class w/o success:
cta-22#conf t
Enter configuration commands, one per line. End with CNTL/Z.
cta-22(config)#int ser 0/0.640
cta-22(config-subif)#fram
cta-22(config-subif)#frame-relay cl
cta-22(config-subif)#frame-relay class aral-512
cta-22(config-subif)#exi
cta-22(config)#exi
cta-22#sh run int ser 0/0.640
Building configuration...

Current configuration : 166 bytes
!
interface Serial0/0.640 point-to-point
description --aral
bandwidth 512
ip address x.x.x.34 255.255.255.248
frame-relay interface-dlci 640
end

cta-22#

it is 2620 router running c260-j1s3-mz.122-15.T14 ios.

Any help would be apreciated.
Thanks in advance!
 
Reply With Quote
 
 
 
 
Ben
Guest
Posts: n/a
 
      02-07-2005
Hi Andrew,

To my understanding there is no reason why you shouldn't use the
service-policy command with frame-relay, i.e:

> cta-22(config)#int ser 0/0.640
> cta-22(config-subif)#service-policy input aral-512


But I am not familiar with map-class command.

cheers,

Ben

Andrew Smith wrote:
> Hi,
>
> We need some help or advice is it possible or not. Let me explain
> our situation:
>
> We have a client, which is connected through a frame-relay PVC with
> CIR 512kbps. Through this PVC client gets internet and intranet
> traffic.
>
> We want to limit/shape internet traffic to 256kbps and within these
> 256kbps we want to reserve/prioritize some bandwidth (for example
> 32kbps) for voice gw. We have tried following configuration, but it
> doesn't work. It doesn't complains about anything, just don't let us
> to attach a class to PVC. Here's config we tried:
> cta-22#sh run class-map
> Building configuration...
>
> !
> class-map match-all not-intra
> description -- nets not in intranet
> match access-group 101
> class-map match-all voice
> description -- voice
> match access-group name voice.acl
> !
> end
> cta-22#sh run policy-map
> Building configuration...
>
> !
> policy-map aral
> class voice
> priority 32
> class class-default
> fair-queue
> policy-map aral-inet
> class not-intra
> shape average 256000
> service-policy aral
> class class-default
> fair-queue
> policy-map aral-512
> description Shape aral to 512kbps
> class class-default
> shape average 512000
> service-policy aral-inet
> !
> end
>
> cta-22#sh run map
> Building configuration...
>
> Current configuration:
> !
> map-class frame-relay aral-512
> service-policy output aral-512
> frame-relay fragment 96
> !
> end
> cta-22#sh run int ser 0/0
> Building configuration...
>
> Current configuration : 230 bytes
> !
> interface Serial0/0
> description --Uplink
> bandwidth 8192
> no ip address
> encapsulation frame-relay
> ip route-cache policy
> load-interval 30
> no fair-queue
> no frame-relay inverse-arp
> frame-relay lmi-type cisco
> end
>
> cta-22#sh run int ser 0/0.640
> Building configuration...
>
> Current configuration : 166 bytes
> !
> interface Serial0/0.640 point-to-point
> description --aral
> bandwidth 512
> ip address x.x.x.34 255.255.255.248
> frame-relay interface-dlci 640
> end
>
> trying to attach map-class w/o success:
> cta-22#conf t
> Enter configuration commands, one per line. End with CNTL/Z.
> cta-22(config)#int ser 0/0.640
> cta-22(config-subif)#fram
> cta-22(config-subif)#frame-relay cl
> cta-22(config-subif)#frame-relay class aral-512
> cta-22(config-subif)#exi
> cta-22(config)#exi
> cta-22#sh run int ser 0/0.640
> Building configuration...
>
> Current configuration : 166 bytes
> !
> interface Serial0/0.640 point-to-point
> description --aral
> bandwidth 512
> ip address x.x.x.34 255.255.255.248
> frame-relay interface-dlci 640
> end
>
> cta-22#
>
> it is 2620 router running c260-j1s3-mz.122-15.T14 ios.
>
> Any help would be apreciated.
> Thanks in advance!

 
Reply With Quote
 
 
 
 
Andrew Smith
Guest
Posts: n/a
 
      02-07-2005
Hi Ben,

I've tried to apply service policy directly to sub interface, but it
just won't apply, without any warning. I think it is not possible to
shape traffic within already shaped traffic IMHO.

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
child jitter vs parent shaping vs child class-default on 871 and 1841 Robertas Cisco 0 02-23-2007 01:28 PM
Azereus, Traffic shaping (avoid traffic shaping in with azereus) Nova NZ Computing 2 03-20-2006 09:03 AM
Nested Class, Member Class, Inner Class, Local Class, Anonymous Class E11 Java 1 10-12-2005 03:34 PM
Flow-Based traffic shaping / policing with MS Terminal Server Josh Cisco 0 05-28-2004 01:57 AM
Frame Relay Traffic shaping, adaptive shaping Kenny D Cisco 1 12-05-2003 05:15 PM



Advertisments