Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Wireless Networking > "NWLink IPX/SPX/Netbios compatible transport protocol" for LAN traffic?

Reply
Thread Tools

"NWLink IPX/SPX/Netbios compatible transport protocol" for LAN traffic?

 
 
Leanin' Cedar
Guest
Posts: n/a
 
      10-15-2006
Does this seem like it is worth the effort, my home LAN is slow? Three
WinXP PC's
Thanks
Bob


>Like most of you, I have experienced (!) very slow local networking using
> "TCPIP only" once I introduced an XP box on my LAN (the traffic was
> excruciatingly slow from the XP box but not from the my Win98 boxes). For
> whatever reason, it seems that the TCPIP implementation in XP is routing
> local traffic through the Internet, which slows down LAN traffic to a
> crawl.
>
> I have 3 boxes: 1 XP Pro and 2 Win98. I use a network Hub (Intel Office
> Connect) and a Hardware Firewall (SonicWall SOHO/10) with cable modem
> access
> (Motorola CyberSurfer). My cable modem hooks to the firewall which itself
> is
> hooked to the Hub.Of course, each box is also hooked to the Hub. The
> hardware firewall serves as a router and a DHCP server. Each box accesses
> the Net directly. I do not use ICS (Internet Connection Sharing) or XP's
> software firewall. My LAN is setup as peer to peer as opposed to
> client/server. Peer to Peer seems to be the default setup.
>
> As a result of the difficulties encountered with "TCPIP only" for LAN
> traffic, I decided to use "NWLink IPX/SPX/Netbios compatible transport
> protocol" for LAN traffic. There are general rules to follow for any LAN
> setup. First, configure each box to use the same workgroup, such as "Home"
> or "House" or whatever else you want as long as it's the same for each
> box.
> Each box must also be configured with the same network protocols. Shares
> must be enabled for the files and printers you wish to share on each box.
> Software firewalls such as ZoneAlarm should be disabled until the LAN is
> configured and working. Once the LAN is configured and working, software
> firewalls can be re-activated but configured to allow local traffic
> otherwise local traffic will be blocked.
>
> To disable XP's software firewall, click on "Start" then "My Network
> places", then "View Network connections" on the top left pane, then click
> on
> your "Local Area Connection" to hi-light it, click "Change Settings of
> this
> connection" on the top left pane, click on the "Advanced" tab on top and
> uncheck the box next to "Protect my computer and network...". There you
> go,
> XP's software firewall is disabled!
>
> While you're still in the "Local Area Connection Properties" dialog box
> (on
> the XP machine), take a look at the window under "This connection uses the
> following items:", you'll see a list of protocols that are installed. If
> "NWLink IPX/SPX/Netbios compatible transport protocol" does not appear in
> this window, click on the "Install" button, then "Protocol", then
> "Microsoft" than "IPX/SPX/NetBios Compatible Transport Protocol" and take
> it
> from there!
>
> You must also install this protocol on each Win98 machines by clicking
> "Settings", then "Control Panel", then "Network", then the "Add" button,
> then "Protocol", then "Microsoft", then the "IPX/SPX Compatible Protocol".
> To get IPX/SPX to work on a network that includes an XP machine, you must
> activate NetBios and bind the NetBios protocol to "File and Printer
> sharing
> for Microsoft Network" as well as "Client for Microsoft Network" on each
> box
> on the network. I have uninstalled QOS on my XP machine as it serves no
> purpose. It seems that XP installs NetBios for IPX/SPX automatically once
> IPX/SPX is installed. IT'S NOT THE SAME WITH WIN98. In Win98, after
> installing the IPX/SPX protocol and re-booting, you have to click "Start",
> then "Settings", then "Control Panel", then "Network" and then, hi-light
> the
> "IPX/SPX protocol", click "Properties", click on the "NetBios" Tab on top
> and check the box "I want to enable NetBios over IPX/SPX". You must do
> this
> for each Win98 machines on your LAN. I don't know about WinMe, but I
> suspect
> that it is pretty much the same as in Win98.
>
> To look at bindings in XP, click on "Start", then "My network places",
> then
> "View Network Connections", then click on your "local area connection" to
> hi-light it. Once there, click on "Advanced" on the top menu bar and then
> on
> "Advanced Settings". You'll then see a tab on top called "Adapters and
> bindings". There you are! You'll see "File and Printer Sharing for
> Microsoft
> Networks" with the protocols that are bound to it. Ensure IPX/SPX is there
> and checked. Also, ensure TCPIP is unchecked as you do not want TCPIP for
> your LAN once you decide to use IPX/SPX. You will also see "Client for
> Microsoft Networks". It's the same thing there also: check IPX/SPX and
> uncheck TCPIP.
>
> Now close this dialog box. Hi-light your "local area connection" again and
> click "Change settings of this connection" on the top left hand pane.
> Click
> on "Internet Protocol (TCP/IP)", click on "Properties", click on the
> "Advanced" button on the General Tab page, click on the "WINS" tab on top,
> check the box that says "Disable NetBios over TCPIP". Remember, you do not
> need NetBios over TCPIP for your LAN if you use IPX/SPX. While you're
> there
> ("Advanced TCPIP Settings"), you might want to add a default gateway if
> your
> LAN is anything like mine by clicking on the "Ip Settings" tab on top,
> then
> the "Add" button and add your default gateway in the dialog box for this
> purpose (Mine is set at 192.168.168.16. Check the box entitled
> "Automatic
> Metric", if you do need to add a default gateway.
>
> To look at the bindings in Win98, click on "Start", then "Settings", then
> "Control Panel", then "Network", hi-light each protocol involved, then
> click
> "Properties", then click on the "Bindings" tab on top. For instance,
> hi-light the the "IPX/SPX compatible transport protocol", click on
> "Properties" and then click on the "Bindings" tab on top and ensure that
> the
> box next to each of "Client for Microsoft Network", "File and printer
> sharing for Microsoft network" and "NETBIOS support for IPX/SPX compatible
> protocol" is checked. While you're there, click on the "Netbios" tab on
> top
> and ensure that the box next to "I want to enable Netbios over IPX/SPX" is
> also checked. On each Win98 machine, do not forget to unbind the TCPIP
> protocol for LAN traffic. To do this, hi-light the "TCPIP protocol", click
> "Properties", click the "Bindings" tab on top and ensure the box next to
> "Client for Microsoft Networks" and "File and printer sharing for
> Microsoft
> Networks" is unchecked. Once you do this, you will get a dialog box
> stating
> "You have not selected any drivers to bind with. Would you like to select
> one now?", click "No". While you're in the "TCPIP Properties" dialog box,
> click on the "Netbios" tab on top and ensure that the box next to "I want
> to
> enable NetBios over TCPIP" is unchecked. You might also want to configure
> a
> default gateway by clicking on the "Gateway" tab on top.
>
> I'm not using NetBeui as IPX/SPX seems to work adequately in XP for File
> and Printer sharing on my > LAN.
>
> I hope this helps! For an OS that's supposed to be so great at Networking,
> XP requires all of us to become instant experts in Networking, which is
> way
> too much for your average users, including me, before I installed XP.
> Necessity is the mother of invention!
>



 
Reply With Quote
 
 
 
 
Jack \(MVP-Networking\).
Guest
Posts: n/a
 
      10-15-2006
Hi
Nope, using additional protocols would not make it faster.
May be this can Help, http://www.ezlan.net/Internet_Speed.html
Jack (MVP-Networking).


"Leanin' Cedar" <(E-Mail Removed)> wrote in message
news:upgbl9$(E-Mail Removed)...
> Does this seem like it is worth the effort, my home LAN is slow? Three
> WinXP PC's
> Thanks
> Bob
>
>
>>Like most of you, I have experienced (!) very slow local networking using
>> "TCPIP only" once I introduced an XP box on my LAN (the traffic was
>> excruciatingly slow from the XP box but not from the my Win98 boxes). For
>> whatever reason, it seems that the TCPIP implementation in XP is routing
>> local traffic through the Internet, which slows down LAN traffic to a
>> crawl.
>>
>> I have 3 boxes: 1 XP Pro and 2 Win98. I use a network Hub (Intel Office
>> Connect) and a Hardware Firewall (SonicWall SOHO/10) with cable modem
>> access
>> (Motorola CyberSurfer). My cable modem hooks to the firewall which itself
>> is
>> hooked to the Hub.Of course, each box is also hooked to the Hub. The
>> hardware firewall serves as a router and a DHCP server. Each box accesses
>> the Net directly. I do not use ICS (Internet Connection Sharing) or XP's
>> software firewall. My LAN is setup as peer to peer as opposed to
>> client/server. Peer to Peer seems to be the default setup.
>>
>> As a result of the difficulties encountered with "TCPIP only" for LAN
>> traffic, I decided to use "NWLink IPX/SPX/Netbios compatible transport
>> protocol" for LAN traffic. There are general rules to follow for any LAN
>> setup. First, configure each box to use the same workgroup, such as
>> "Home"
>> or "House" or whatever else you want as long as it's the same for each
>> box.
>> Each box must also be configured with the same network protocols. Shares
>> must be enabled for the files and printers you wish to share on each box.
>> Software firewalls such as ZoneAlarm should be disabled until the LAN is
>> configured and working. Once the LAN is configured and working, software
>> firewalls can be re-activated but configured to allow local traffic
>> otherwise local traffic will be blocked.
>>
>> To disable XP's software firewall, click on "Start" then "My Network
>> places", then "View Network connections" on the top left pane, then click
>> on
>> your "Local Area Connection" to hi-light it, click "Change Settings of
>> this
>> connection" on the top left pane, click on the "Advanced" tab on top and
>> uncheck the box next to "Protect my computer and network...". There you
>> go,
>> XP's software firewall is disabled!
>>
>> While you're still in the "Local Area Connection Properties" dialog box
>> (on
>> the XP machine), take a look at the window under "This connection uses
>> the
>> following items:", you'll see a list of protocols that are installed. If
>> "NWLink IPX/SPX/Netbios compatible transport protocol" does not appear in
>> this window, click on the "Install" button, then "Protocol", then
>> "Microsoft" than "IPX/SPX/NetBios Compatible Transport Protocol" and take
>> it
>> from there!
>>
>> You must also install this protocol on each Win98 machines by clicking
>> "Settings", then "Control Panel", then "Network", then the "Add" button,
>> then "Protocol", then "Microsoft", then the "IPX/SPX Compatible
>> Protocol".
>> To get IPX/SPX to work on a network that includes an XP machine, you must
>> activate NetBios and bind the NetBios protocol to "File and Printer
>> sharing
>> for Microsoft Network" as well as "Client for Microsoft Network" on each
>> box
>> on the network. I have uninstalled QOS on my XP machine as it serves no
>> purpose. It seems that XP installs NetBios for IPX/SPX automatically once
>> IPX/SPX is installed. IT'S NOT THE SAME WITH WIN98. In Win98, after
>> installing the IPX/SPX protocol and re-booting, you have to click
>> "Start",
>> then "Settings", then "Control Panel", then "Network" and then, hi-light
>> the
>> "IPX/SPX protocol", click "Properties", click on the "NetBios" Tab on top
>> and check the box "I want to enable NetBios over IPX/SPX". You must do
>> this
>> for each Win98 machines on your LAN. I don't know about WinMe, but I
>> suspect
>> that it is pretty much the same as in Win98.
>>
>> To look at bindings in XP, click on "Start", then "My network places",
>> then
>> "View Network Connections", then click on your "local area connection" to
>> hi-light it. Once there, click on "Advanced" on the top menu bar and then
>> on
>> "Advanced Settings". You'll then see a tab on top called "Adapters and
>> bindings". There you are! You'll see "File and Printer Sharing for
>> Microsoft
>> Networks" with the protocols that are bound to it. Ensure IPX/SPX is
>> there
>> and checked. Also, ensure TCPIP is unchecked as you do not want TCPIP for
>> your LAN once you decide to use IPX/SPX. You will also see "Client for
>> Microsoft Networks". It's the same thing there also: check IPX/SPX and
>> uncheck TCPIP.
>>
>> Now close this dialog box. Hi-light your "local area connection" again
>> and
>> click "Change settings of this connection" on the top left hand pane.
>> Click
>> on "Internet Protocol (TCP/IP)", click on "Properties", click on the
>> "Advanced" button on the General Tab page, click on the "WINS" tab on
>> top,
>> check the box that says "Disable NetBios over TCPIP". Remember, you do
>> not
>> need NetBios over TCPIP for your LAN if you use IPX/SPX. While you're
>> there
>> ("Advanced TCPIP Settings"), you might want to add a default gateway if
>> your
>> LAN is anything like mine by clicking on the "Ip Settings" tab on top,
>> then
>> the "Add" button and add your default gateway in the dialog box for this
>> purpose (Mine is set at 192.168.168.16. Check the box entitled
>> "Automatic
>> Metric", if you do need to add a default gateway.
>>
>> To look at the bindings in Win98, click on "Start", then "Settings", then
>> "Control Panel", then "Network", hi-light each protocol involved, then
>> click
>> "Properties", then click on the "Bindings" tab on top. For instance,
>> hi-light the the "IPX/SPX compatible transport protocol", click on
>> "Properties" and then click on the "Bindings" tab on top and ensure that
>> the
>> box next to each of "Client for Microsoft Network", "File and printer
>> sharing for Microsoft network" and "NETBIOS support for IPX/SPX
>> compatible
>> protocol" is checked. While you're there, click on the "Netbios" tab on
>> top
>> and ensure that the box next to "I want to enable Netbios over IPX/SPX"
>> is
>> also checked. On each Win98 machine, do not forget to unbind the TCPIP
>> protocol for LAN traffic. To do this, hi-light the "TCPIP protocol",
>> click
>> "Properties", click the "Bindings" tab on top and ensure the box next to
>> "Client for Microsoft Networks" and "File and printer sharing for
>> Microsoft
>> Networks" is unchecked. Once you do this, you will get a dialog box
>> stating
>> "You have not selected any drivers to bind with. Would you like to select
>> one now?", click "No". While you're in the "TCPIP Properties" dialog box,
>> click on the "Netbios" tab on top and ensure that the box next to "I want
>> to
>> enable NetBios over TCPIP" is unchecked. You might also want to configure
>> a
>> default gateway by clicking on the "Gateway" tab on top.
>>
>> I'm not using NetBeui as IPX/SPX seems to work adequately in XP for File
>> and Printer sharing on my > LAN.
>>
>> I hope this helps! For an OS that's supposed to be so great at
>> Networking,
>> XP requires all of us to become instant experts in Networking, which is
>> way
>> too much for your average users, including me, before I installed XP.
>> Necessity is the mother of invention!
>>

>
>



 
Reply With Quote
 
 
 
 
Leanin' Cedar
Guest
Posts: n/a
 
      10-15-2006

"Jack (MVP-Networking)." <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Hi
> Nope, using additional protocols would not make it faster.
> May be this can Help, http://www.ezlan.net/Internet_Speed.html
> Jack (MVP-Networking).


Thanks for the reply, I am on dialup so not much hope of optimizing
internet, but was wondering about file and print sharing with the PC's,
looks like this may help.

Bob


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
want to replace a read only cd transport with read / write transport larya Computer Support 7 09-11-2006 10:21 PM
making ie compatible code firefox compatible using Greasemonkey? pantagruel Javascript 0 02-17-2006 02:26 PM
Can't connect wired linksys lan to wireless belkin lan Tom D Wireless Networking 4 01-24-2005 02:06 PM
lan-to-lan vpn over adsl blaj Cisco 0 11-19-2003 08:32 PM
IPSec - Lan to Lan - Nat routers - 1 Static and 1 Dynamic ip Sharqy_5 Cisco 0 07-20-2003 09:35 PM



Advertisments