Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Java > WebLogic 9.2: SSPI impl required when Extension-Name is in MANIFEST.MF

Reply
Thread Tools

WebLogic 9.2: SSPI impl required when Extension-Name is in MANIFEST.MF

 
 
Karl Uppiano
Guest
Posts: n/a
 
      09-20-2006
When my RAR MANIFEST.MF contains the following entries,

Extension-Name: my-ra
Specification-Vendor: my-vendor
Implementation-Vendor: my-vendor
Implementation-Title: my-ra
Implementation-Version: my-version

WebLogic 9.2 throws the exception:

weblogic.connector.exception.RAException: Trying to version a resource
adapter that is not versionable
at
weblogic.connector.common.RAInstanceManager.initia lize(RAInstanceManager.java:1141)
...

..when I attempt to activate changes to my newly installed application
archive.

It seems supremely presumptuous of WebLogic to assume that I intend to
implement versionable support simply because Maven elects to include
versioning information in all archives that it generates. My question is,
does anyone know how I might either

a) Make an entry in the RA deployment descriptor to disable the appserver
from attempting to version the RA, or
b) Inhibit the Maven archiver from making the entries that are inciting
WebLogic to attempt to version the RA



 
Reply With Quote
 
 
 
 
Karl Uppiano
Guest
Posts: n/a
 
      09-23-2006

"Karl Uppiano" <(E-Mail Removed)> wrote in message
news:eJ4Qg.6582$uj3.4654@trnddc08...
> When my RAR MANIFEST.MF contains the following entries,
>
> Extension-Name: my-ra
> Specification-Vendor: my-vendor
> Implementation-Vendor: my-vendor
> Implementation-Title: my-ra
> Implementation-Version: my-version
>
> WebLogic 9.2 throws the exception:
>
> weblogic.connector.exception.RAException: Trying to version a resource
> adapter that is not versionable
> at
> weblogic.connector.common.RAInstanceManager.initia lize(RAInstanceManager.java:1141)
> ...
>
> .when I attempt to activate changes to my newly installed application
> archive.
>
> It seems supremely presumptuous of WebLogic to assume that I intend to
> implement versionable support simply because Maven elects to include
> versioning information in all archives that it generates. My question is,
> does anyone know how I might either
>
> a) Make an entry in the RA deployment descriptor to disable the appserver
> from attempting to version the RA, or
> b) Inhibit the Maven archiver from making the entries that are inciting
> WebLogic to attempt to version the RA


Bump...

Lest anyone suspect that I have not done my research, let me allay your
fears.

1. I subscribe to the Maven mailing list, and it seems to be the consensus
over there that the manifest versioning entries occur by default with
earlier archiver plug-ins, but the Maven 2.1 archiver is supposed to omit
those entries. However, the 2.1 RAR plug-in apparently still puts them in.
2. I am still waiting to hear back from BEA tech support.
3. I have Googled the snot out of this, and turned up next to nothing about
how to get WebLogic 9.2 to ignore the manifest versioning entries. WebLogic
9.1 works fine with or without them.

I would be interested to hear from anyone who has any experience with this.


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Could not add QuickStart user to SQL Server.: Invalid SSPI packet size. oaksong@hotmail.com ASP .Net 0 10-26-2005 07:24 PM
Cannot generate SSPI context Diego F. ASP .Net 2 06-06-2005 03:11 PM
Cannot initialize SSPI Package =?Utf-8?B?UGV0ZXI=?= ASP .Net 0 06-08-2004 06:01 AM
still need help - CANNOT GENERATE SSPI CONTEXT news.microsoft.com ASP .Net 0 01-19-2004 01:32 PM
"CANNOT GENERATE SSPI CONTEXT" news.microsoft.com ASP .Net 1 01-16-2004 01:46 PM



Advertisments