Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Upgrading IOS on 2514 router

Reply
Thread Tools

Upgrading IOS on 2514 router

 
 
Ahmed
Guest
Posts: n/a
 
      01-13-2005
Hello all,
I have two 2514 routers. The IOS on them are respectively version 10.2 and
12.2 I would like to upgrade the 10.2 to 12.2. Below is what I did and what
I got:
============
2514 connected to laptop through console and NIC to AUI0 (Xover cable).
in Hyperterminal:
config t
int e0
ip address 192.168.2.1 255.255.255.0
no shut
the TFTP SolarWinds has the ip 192.168.2.2 255.255.255.0
I gave the laptop ip 192.168.2.3 255.255.255.0 with default gateway ip
192.168.2.1 255.255.255.0
from router:
Good2514>en
Good2514#ping 192.168.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.2, timeout is 2 seconds:
......
Success rate is 0 percent (0/5)
Good2514#ping 192.168.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
Good2514#ping 192.168.2.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.3, timeout is 2 seconds:
......
Success rate is 0 percent (0/5)
Good2514#
======================
Here is a sho run:
Good2514#sh run
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Good2514
!
!
!
!
!
!
ip subnet-zero
!
!
!
!
!
!
interface Ethernet0
ip address 192.168.2.1 255.255.255.0
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
ip classless
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end
--More--
Do I need to tell the router that there is a TFTP server and give it its ip?
Remember guys that what is obvious to those who know is ? to the new
comers..(I think that the people who write study guides should remember that
and show the readers all the steps: from connections, to cables, to ports
used, to commands etc.)In the book I am using, all it says is: before
starting the backup, make sure you have a solid connection to the TFTP by
pinging it. Here I am pinging it for 3 days
All the help is highly appreciated.
Ahmed.


 
Reply With Quote
 
 
 
 
Walter Roberson
Guest
Posts: n/a
 
      01-13-2005
In article <zukFd.8594$(E-Mail Removed)> ,
Ahmed <(E-Mail Removed)> wrote:
:I have two 2514 routers. The IOS on them are respectively version 10.2 and
:12.2 I would like to upgrade the 10.2 to 12.2. Below is what I did and what
:I got:

o I need to tell the router that there is a TFTP server and give it its ip?

Sort of, but not in the way you were likely thinking.

All you have to do, once you have given the appropriate
interface an IP address, is to

copy running-configuration tftp

and then follow the prompts. You will be asked for the tftp IP
and for the destination file, and then the current running
configuration will be written to the place you designated.

If you get a message about the destination being unreachable,
you have a problem

If you get a message about 'access violation' then it was
able to contact a tftp server on the destination, but it was
not given permission to write the file. There are a few things
you need to keep in mind about that.

I don't know about SolarWinds in particular, but on -most-
(but not -all-) tftp servers, the file must exist,
and the tftp daemon or service must have permission to
write the file, before you are allowed to perform the
transfer. In unix terms, this would be

touch DESTINATION; chmod go+w DESTINATION

In Windows terms, if the tftp server is not running as you
and is not running as a System service, then the user that
it is running as must be given write authorization by
going to Properties to Security and adding the appropriate
user or group and clicking the boxes to give that group
read and write authorization.

On a unix system (and possibly others), there is another
consideration, which is that the tftp server is normally
configured (/etc/inetd.conf for most unix) with an explicit
list of directories that the tftp client is allowed to access.
If the destination file is not in one of those directories,
then no matter what the permissions you just wouldn't be allowed
to write there.

Something else for future reference is that on a unix system
when you are configuring the tftp service list of authorized
directories, then the first directory in the list is the default
directory that will be used if a relative pathname is requested
by the client. For example if that first directory was
/var/spool/tftp then if you asked to write to 2501backup.txt
then it would try to write to /var/spool/tftp/2501backup.txt
However, if you asked to write to /tmp/2501backup.txt
then if /tmp was on the list of authorized directories and
the permissions were correct, then it would write directly to
/tmp/2501backup.txt and -not- to
/var/spool/tftp/tmp/2501backup.txt

It looks for a leading / to decide whether the path is an absolute one
or a relative one. You should, by the way, usually use unix directory
format with / as the delimiter and not \ as the delimiter even if you
are writing to a windows tftp server -- / is the standard character for
tftp. Of course with Windows your milage may vary... peoeple who
write WIndows programs often don't adhere strictly to standards.

There is a further twist on the absolute vs relative directory
point. If you follow the procedure I indicated above, where you
just give the destination and then follow the prompts, then a
filename starting with / will be treated as an absolute filename.
However, there is an alternate URL-like syntax that you can
use to put everything on one line. It's been awhile since I've
done one under IOS, but my recollection is that the format is like so:
copy running-configuration tftp://HOSTIP/DESTINATION
such as
copy running-configuraiton tftp://192.168.1.2/2501backup.txt
There is a gotcha involved here, and that is that the first
slash after the host ip is just the separator between the IP
and the filename, and will be stripped off in determining the
destination filename. Therefore if you want to specify an
absolute pathname, you still need the leading slash, *after*
the slash that marks the end of the IP address. Like this:

copy running-configuration tftp://192.168.1.2//var/spool/tftp/2501backup.txt

if you were to instead have given the more normal looking

copy running-configuration tftp://192.168.1.2/var/spool/tftp/2501backup.txt
then the tftp server would be handed var/spool/tftp/2501backup.txt
as the pathname, and it would interpret that relative to the
first directory on the list of authorized directories.
--
Cottleston, Cottleston, Cottleston pie.
A bird can't whistle and neither can I. -- Pooh
 
Reply With Quote
 
 
 
 
M.C. van den Bovenkamp
Guest
Posts: n/a
 
      01-13-2005
Walter Roberson wrote:

> All you have to do, once you have given the appropriate
> interface an IP address, is to
>
> copy running-configuration tftp

....
> destination filename. Therefore if you want to specify an
> absolute pathname, you still need the leading slash, *after*
> the slash that marks the end of the IP address. Like this:
>
> copy running-configuration tftp://192.168.1.2//var/spool/tftp/2501backup.txt
>
> if you were to instead have given the more normal looking
>
> copy running-configuration tftp://192.168.1.2/var/spool/tftp/2501backup.txt
> then the tftp server would be handed var/spool/tftp/2501backup.txt
> as the pathname, and it would interpret that relative to the
> first directory on the list of authorized directories.


All true, but he is backing up a box running IOS *10.2*.

I think 'write net' is all that's going to work for him.

Works the same as far as prompting and having to create the file first
on the TFTP server and all the other thing you mentioned, but not to
confuse the guy any further...

Regards,

Marco.

 
Reply With Quote
 
Walter Roberson
Guest
Posts: n/a
 
      01-13-2005
In article <41e6498c$0$4434$(E-Mail Removed)4all.nl> ,
M.C. van den Bovenkamp <(E-Mail Removed)> wrote:

:All true, but he is backing up a box running IOS *10.2*.

Ah...

:I think 'write net' is all that's going to work for him.

http://www.cisco.com/warp/public/477/SNMP/11_7910.shtml

shows how to do it with SNMP as of 10.2.

http://www.cisco.com/univercd/cc/td/...4271.htm#31799

shows how to 'copy startup-config rcp' in 10.2.

But the odd thing in that documentation is that tftp is supported
as a source in a copy command, and as a destination for flash,
but they show 'write terminal' still as the command for
writing the configuration to tftp.

I'm afraid I don't have a 10.2 IOS system to try out
copy startup-config tftp on. It would work by analogy...

Looks like it was 11.2 when the url-like syntax was introduced.
--
When your posts are all alone / and a user's on the phone/
there's one place to check -- / Upstream!
When you're in a hurry / and propagation is a worry/
there's a place you can post -- / Upstream!
 
Reply With Quote
 
M.C. van den Bovenkamp
Guest
Posts: n/a
 
      01-13-2005
Walter Roberson wrote:

> :I think 'write net' is all that's going to work for him.
>
> http://www.cisco.com/warp/public/477/SNMP/11_7910.shtml
>
> shows how to do it with SNMP as of 10.2.


I was thinking 'from the CLI'. Doing it through SNMP hadn't crossed my mind.

> http://www.cisco.com/univercd/cc/td/...4271.htm#31799
>
> shows how to 'copy startup-config rcp' in 10.2.


You're right; didn't remember you could do that as far back as 10.2.

> I'm afraid I don't have a 10.2 IOS system to try out
> copy startup-config tftp on. It would work by analogy...


Probably a dangerous assumption where the orthogonality of the IOS CLI
is involved . But yes, you'd think so.

Regards,

Marco.


 
Reply With Quote
 
Ahmed
Guest
Posts: n/a
 
      01-14-2005
Hi Walter,
Thanks for the reply.
You wrote: If you get a message about the destination being unreachable,
you have a problem
========
That is exactly my problem. I can't ping my TFTP server. Therefore I didn't
even try to backup my IOS. And I don't know what I am doing wrong. Please
review my config and tell me if you see anything wrong with it.
BTW: I am very new to Cisco networking. So keep things on the simple side
Thanks a lot,
Ahmed.


"Walter Roberson" <(E-Mail Removed)-cnrc.gc.ca> wrote in message
news:cs4sbi$b6e$(E-Mail Removed)...
> In article <zukFd.8594$(E-Mail Removed)> ,
> Ahmed <(E-Mail Removed)> wrote:
> :I have two 2514 routers. The IOS on them are respectively version 10.2
> and
> :12.2 I would like to upgrade the 10.2 to 12.2. Below is what I did and
> what
> :I got:
>
> o I need to tell the router that there is a TFTP server and give it its
> ip?
>
> Sort of, but not in the way you were likely thinking.
>
> All you have to do, once you have given the appropriate
> interface an IP address, is to
>
> copy running-configuration tftp
>
> and then follow the prompts. You will be asked for the tftp IP
> and for the destination file, and then the current running
> configuration will be written to the place you designated.
>
> If you get a message about the destination being unreachable,
> you have a problem
>
> If you get a message about 'access violation' then it was
> able to contact a tftp server on the destination, but it was
> not given permission to write the file. There are a few things
> you need to keep in mind about that.
>
> I don't know about SolarWinds in particular, but on -most-
> (but not -all-) tftp servers, the file must exist,
> and the tftp daemon or service must have permission to
> write the file, before you are allowed to perform the
> transfer. In unix terms, this would be
>
> touch DESTINATION; chmod go+w DESTINATION
>
> In Windows terms, if the tftp server is not running as you
> and is not running as a System service, then the user that
> it is running as must be given write authorization by
> going to Properties to Security and adding the appropriate
> user or group and clicking the boxes to give that group
> read and write authorization.
>
> On a unix system (and possibly others), there is another
> consideration, which is that the tftp server is normally
> configured (/etc/inetd.conf for most unix) with an explicit
> list of directories that the tftp client is allowed to access.
> If the destination file is not in one of those directories,
> then no matter what the permissions you just wouldn't be allowed
> to write there.
>
> Something else for future reference is that on a unix system
> when you are configuring the tftp service list of authorized
> directories, then the first directory in the list is the default
> directory that will be used if a relative pathname is requested
> by the client. For example if that first directory was
> /var/spool/tftp then if you asked to write to 2501backup.txt
> then it would try to write to /var/spool/tftp/2501backup.txt
> However, if you asked to write to /tmp/2501backup.txt
> then if /tmp was on the list of authorized directories and
> the permissions were correct, then it would write directly to
> /tmp/2501backup.txt and -not- to
> /var/spool/tftp/tmp/2501backup.txt
>
> It looks for a leading / to decide whether the path is an absolute one
> or a relative one. You should, by the way, usually use unix directory
> format with / as the delimiter and not \ as the delimiter even if you
> are writing to a windows tftp server -- / is the standard character for
> tftp. Of course with Windows your milage may vary... peoeple who
> write WIndows programs often don't adhere strictly to standards.
>
> There is a further twist on the absolute vs relative directory
> point. If you follow the procedure I indicated above, where you
> just give the destination and then follow the prompts, then a
> filename starting with / will be treated as an absolute filename.
> However, there is an alternate URL-like syntax that you can
> use to put everything on one line. It's been awhile since I've
> done one under IOS, but my recollection is that the format is like so:
> copy running-configuration tftp://HOSTIP/DESTINATION
> such as
> copy running-configuraiton tftp://192.168.1.2/2501backup.txt
> There is a gotcha involved here, and that is that the first
> slash after the host ip is just the separator between the IP
> and the filename, and will be stripped off in determining the
> destination filename. Therefore if you want to specify an
> absolute pathname, you still need the leading slash, *after*
> the slash that marks the end of the IP address. Like this:
>
> copy running-configuration
> tftp://192.168.1.2//var/spool/tftp/2501backup.txt
>
> if you were to instead have given the more normal looking
>
> copy running-configuration
> tftp://192.168.1.2/var/spool/tftp/2501backup.txt
> then the tftp server would be handed var/spool/tftp/2501backup.txt
> as the pathname, and it would interpret that relative to the
> first directory on the list of authorized directories.
> --
> Cottleston, Cottleston, Cottleston pie.
> A bird can't whistle and neither can I. -- Pooh



 
Reply With Quote
 
Walter Roberson
Guest
Posts: n/a
 
      01-14-2005
In article <zukFd.8594$(E-Mail Removed)> ,
Ahmed <(E-Mail Removed)> wrote:
:2514 connected to laptop through console and NIC to AUI0 (Xover cable).
:in Hyperterminal:
:config t
:int e0
:ip address 192.168.2.1 255.255.255.0
:no shut
:the TFTP SolarWinds has the ip 192.168.2.2 255.255.255.0
:I gave the laptop ip 192.168.2.3 255.255.255.0 with default gateway ip
:192.168.2.1 255.255.255.0

If you are using a crossover cable between the NIC of your laptop
and AUI0 of the router (which is presumably interface Ethernet0)
then where is the SolarWinds server connected?
--
This signature intentionally left... Oh, darn!
 
Reply With Quote
 
Ahmed
Guest
Posts: n/a
 
      01-16-2005

"Walter Roberson" <(E-Mail Removed)-cnrc.gc.ca> wrote in message
news:cs7dtp$lku$(E-Mail Removed)...
> In article <zukFd.8594$(E-Mail Removed)> ,
> Ahmed <(E-Mail Removed)> wrote:
> :2514 connected to laptop through console and NIC to AUI0 (Xover cable).
> :in Hyperterminal:
> :config t
> :int e0
> :ip address 192.168.2.1 255.255.255.0
> :no shut
> :the TFTP SolarWinds has the ip 192.168.2.2 255.255.255.0
> :I gave the laptop ip 192.168.2.3 255.255.255.0 with default gateway ip
> :192.168.2.1 255.255.255.0
>
> If you are using a crossover cable between the NIC of your laptop
> and AUI0 of the router (which is presumably interface Ethernet0)
> then where is the SolarWinds server connected?
> --
> This signature intentionally left... Oh, darn!
>===================

Hi Walter,
I was able to figure out what was going on and was able to do what I needed
to do which is the following:
I have one 2514 with IOS version 12.2 and another 2514 version 10.2. I
backed up both IOS's on the TFTP server then upgraded the router with the
10.2 to the version 12.2. Because I didn't check the amount of flash memory,
now my router (that I just upgraded) can't boot up and I get the error:
SYSTEM INIT: INSUFFISANT MEMORY TO BOOT IMAGE! and it just keeps doing that.
When I perform a "ctrl-break", I get the following:

>o (I typed the o and hit enter)

Configuration register = 0xFFFF2102 at last boot
Bit# Configuration register option settings:
15 Diagnostic mode disabled
14 IP broadcasts do not have network numbers
13 Boot default ROM software if network boot fails
12-11 Console speed is 9600 baud
10 IP broadcasts with ones
08 Break disabled
07 OEM disabled
06 Ignore configuration disabled
03-00 Boot file is cisco2-2500 (or 'boot system' command)
> (What do I do now?)

Thanks.
Ahmed.


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
instructions on how to perform an IOS upgrade on a Catalyst 6500 switch (IOS to IOS) Mike Rahl Cisco 1 05-30-2007 05:22 PM
Cisco 2514 IOS Help jsmith12@gmail.com Cisco 2 10-17-2006 02:22 AM
upgrading Cisco 2514 from console manishsm@gmail.com Cisco 2 09-25-2005 08:04 AM
"ip addr dhcp" is not available for my IOS release, who has latest IOS for 2514 and 2509? Ed Kideys, Tech-Train Cisco 3 04-30-2004 07:51 PM
Need Help setting routes on Cisco 2514 router Jeff Lane Cisco 1 04-28-2004 09:32 PM



Advertisments