Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Problem with Cisco 837: can't upload over 128KB of data

Reply
Thread Tools

Problem with Cisco 837: can't upload over 128KB of data

 
 
Jean-Yves Avenard
Guest
Posts: n/a
 
      01-11-2005
Hello

I'm experiencing a very strange issue with our Cisco 837.

It connects fine, can browse the internet fine ..

However, when someone tries to upload over the DSL interface (ftp or
scp) it will transfer the first 128KB fine, then will stop and sit there
forever.
No such problem occur from DSL->LAN

Any ideas?
Thank you heaps in advance
Jean-Yves

#show ver
Cisco Internetwork Operating System Software
IOS (tm) C837 Software (C837-K9O3SY6-M), Version 12.3(2)XC2, EARLY
DEPLOYMENT RELEASE SOFTWARE (fc1)
Synched to technology version 12.3(1.6)T
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2004 by cisco Systems, Inc.
Compiled Thu 04-Mar-04 01:03 by ealyon
Image text-base: 0x800131E8, data-base: 0x80CCB8C0

ROM: System Bootstrap, Version 12.2(8r)YN, RELEASE SOFTWARE (fc1)
ROM: C837 Software (C837-K9O3SY6-M), Version 12.3(2)XC2, EARLY
DEPLOYMENT RELEASE SOFTWARE (fc1)

gw2 uptime is 57 minutes
System returned to ROM by reload
System image file is "flash:c837-k9o3sy6-mz.123-2.XC2.bin"

CISCO C837 (MPC857DSL) processor (revision 0x500) with 44237K/4915K
bytes of memory.
Processor board ID AMB082807VM (1292500482), with hardware revision 0000
CPU rev number 7
Bridging software.
1 Ethernet/IEEE 802.3 interface(s)
4 FastEthernet/IEEE 802.3 interface(s)
1 ATM network interface(s)
128K bytes of non-volatile configuration memory.
12288K bytes of processor board System flash (Read/Write)
2048K bytes of processor board Web flash (Read/Write)


Here is the configuration used:

!
version 12.3
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname gw2
!
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 51200 warnings
enable secret 5 $1$1blah
!
username root privilege 15 secret 5 $1$blah
clock timezone PCTime 10
clock summer-time PCTime date Mar 30 2003 3:00 Oct 26 2003 2:00
no aaa new-model
ip subnet-zero
no ip source-route
ip domain name private.hydrix.com
ip name-server 192.168.0.6
ip name-server 192.168.0.1
ip name-server 218.214.17.1
!
!
no ip bootp server
ip cef
ip audit notify log
ip audit po max-events 100
no ftp-server write-enable
!
!
!
!
!
!
!
interface Null0
no ip unreachables
!
interface Ethernet0
description $ETH-LAN$$FW_INSIDE$
ip address 192.168.0.10 255.255.254.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip route-cache flow
no cdp enable
hold-queue 100 out
!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.2 point-to-point
no ip redirects
no ip unreachables
no ip proxy-arp
pvc 8/35
oam-pvc manage
pppoe-client dial-pool-number 1
!
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer1
description $FW_OUTSIDE$
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1492
ip nat outside
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname login@isp
ppp chap password 7 password
!
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source static tcp 192.168.0.234 22 interface Dialer1 22
ip nat inside source static tcp 192.168.0.191 10000 interface Dialer1 10000
ip nat inside source static tcp 192.168.0.187 10001 interface Dialer1 10001
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 192.168.1.0 255.255.255.0 192.168.0.1 permanent
ip route 218.214.210.72 255.255.255.248 192.168.0.1 permanent
!
ip http server
ip http access-class 2
ip http authentication local
ip http secure-server
!
access-list 1 remark INSIDE_IF=Ethernet0
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.0.0 0.0.1.255
access-list 2 remark HTTP Access-class list
access-list 2 remark SDM_ACL Category=1
access-list 2 permit 192.168.0.0 0.0.1.255
access-list 2 deny any
access-list 100 remark VTY Access-class list
access-list 100 remark SDM_ACL Category=1
access-list 100 permit ip 192.168.0.0 0.0.1.255 any
access-list 100 deny ip any any
dialer-list 1 protocol ip permit
snmp-server community public RO
snmp-server location Carnegie
snmp-server contact JYA
snmp-server enable traps tty
no cdp run
banner login All access are monitored
!
line con 0
login local
no modem enable
transport output telnet
line aux 0
login local
transport output telnet
line vty 0 4
access-class 100 in
privilege level 15
login local
transport input telnet ssh
!
scheduler max-task-time 5000
scheduler interval 500
sntp server 192.168.0.1
!
end
 
Reply With Quote
 
 
 
 
Cisco Fan
Guest
Posts: n/a
 
      01-14-2005
Jean-Yves Avenard wrote:
> However, when someone tries to upload over the DSL interface (ftp or
> scp) it will transfer the first 128KB fine, then will stop and sit there
> forever.
> No such problem occur from DSL->LAN


I've usually had this before with problems concerning MTU size ... don't
know if that applies to your case ... try to do some different size
pings to your next hop or the one after ... if it fails for an MTU that
is still valid as to your local settings, you might need to adjust ...

-garry
 
Reply With Quote
 
 
 
 
Jean-Yves Avenard
Guest
Posts: n/a
 
      01-15-2005
Cisco Fan wrote:

> I've usually had this before with problems concerning MTU size ... don't
> know if that applies to your case ... try to do some different size
> pings to your next hop or the one after ... if it fails for an MTU that
> is still valid as to your local settings, you might need to adjust ...


Hello.
You're right, I'm also convinced it is a MTU problem.
Using PPPoA fixed the problem.

Now as to why it fails with PPPoE is weird though, if you look in my
original post you'll see that I did set up the MTU to 1492.
Should I configure MTU path discovery somewhere too?

Thanks for your answer...

Jean-Yves
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VOIP over VPN over TCP over WAP over 3G Theo Markettos UK VOIP 2 02-14-2008 03:27 PM
internet data over VoIP over GSM - cheapest world wide roaming dataconnection pauldelanotte VOIP 0 01-22-2007 06:51 PM
DatagramSocketChannel returning same data over and over Michael Ansel Java 5 11-04-2006 02:42 AM
Upload a file without file Upload control - ASP.Net =?Utf-8?B?U2FyYXY=?= ASP .Net 3 08-03-2005 01:09 AM
Perl crashes at 128KB? Kelvin Perl 2 09-20-2004 07:07 AM



Advertisments