Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Cisco 1721 ATM nightmare

Reply
Thread Tools

Cisco 1721 ATM nightmare

 
 
andrew@millenniumstaff.co.uk
Guest
Posts: n/a
 
      09-08-2006
Hi
I am trying to get a 1721 atm interface to work with BT and I am not
having much luck....... all I am getting is the Vi3 protocol not coming
up and a continuous debug about "PPP: Authorization NOT required"

Here's the relavant bits of config any help gratfully received:

Current configuration : 4378 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname hostname
!
logging queue-limit 100
enable secret 5 password
!
username root password 7 password
aaa new-model
!
!
aaa authentication login VTY local-case
aaa session-id common
ip subnet-zero
no ip source-route
!
!
ip domain name .com
!
no ip bootp server
ip inspect max-incomplete low 200
ip inspect max-incomplete high 400
ip inspect one-minute low 50
ip inspect one-minute high 100
ip inspect name OUTBOUNDTRAFFIC tcp
ip inspect name OUTBOUNDTRAFFIC udp
ip inspect name OUTBOUNDTRAFFIC ftp
ip inspect name OUTBOUNDTRAFFIC icmp
ip audit notify log
ip audit po max-events 100
!
!
!!
interface ATM0
ip address dhcp
ip mtu 1500
no atm ilmi-keepalive
pvc 0/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
!
interface Ethernet0
no ip address
shutdown
!
interface FastEthernet0
ip address 10.x.x.x 255.255.255.0
ip nat inside
speed auto
!
interface Dialer1
ip address 217.x.x.x 255.255.255.248
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callout
ppp chap hostname hostname
ppp chap password 7 password
!
!
ip nat inside source list NAT2 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
no ip http secure-server
!
!
!
!
dialer-list 1 protocol ip permit
!

line con 0
line aux 0
line vty 0 4
access-class TELNETSSH in
login authentication VTY
transport input telnet ssh
!
no scheduler allocate
end

Interface IP-Address OK? Method Status Protocol

Virtual-Access3 unassigned YES unset up down
ATM0 unassigned YES manual up up
ATM0.1 unassigned YES unset up up
Dialer0 217.x.x.x YES manual up up

 
Reply With Quote
 
 
 
 
Bod43@hotmail.co.uk
Guest
Posts: n/a
 
      09-08-2006

http://www.velocityreviews.com/forums/(E-Mail Removed) wrote:
> Hi
> I am trying to get a 1721 atm interface to work with BT and I am not
> having much luck....... all I am getting is the Vi3 protocol not coming
> up and a continuous debug about "PPP: Authorization NOT required"
>
> Here's the relavant bits of config any help gratfully received:
>
> Current configuration : 4378 bytes
> !
> version 12.2
> service timestamps debug datetime msec
> service timestamps log datetime msec
> service password-encryption
> !
> hostname hostname
> !
> logging queue-limit 100
> enable secret 5 password
> !
> username root password 7 password
> aaa new-model
> !
> !
> aaa authentication login VTY local-case
> aaa session-id common
> ip subnet-zero
> no ip source-route
> !
> !
> ip domain name .com
> !
> no ip bootp server
> ip inspect max-incomplete low 200
> ip inspect max-incomplete high 400
> ip inspect one-minute low 50
> ip inspect one-minute high 100
> ip inspect name OUTBOUNDTRAFFIC tcp
> ip inspect name OUTBOUNDTRAFFIC udp
> ip inspect name OUTBOUNDTRAFFIC ftp
> ip inspect name OUTBOUNDTRAFFIC icmp
> ip audit notify log
> ip audit po max-events 100
> !
> !
> !!
> interface ATM0
> ip address dhcp
> ip mtu 1500
> no atm ilmi-keepalive
> pvc 0/35
> encapsulation aal5mux ppp dialer
> dialer pool-member 1
> !
> dsl operating-mode auto
> !
> interface Ethernet0
> no ip address
> shutdown
> !
> interface FastEthernet0
> ip address 10.x.x.x 255.255.255.0
> ip nat inside
> speed auto
> !
> interface Dialer1
> ip address 217.x.x.x 255.255.255.248
> ip nat outside
> encapsulation ppp
> dialer pool 1
> dialer-group 1
> ppp authentication chap callout
> ppp chap hostname hostname
> ppp chap password 7 password
> !
> !
> ip nat inside source list NAT2 interface Dialer1 overload
> ip classless
> ip route 0.0.0.0 0.0.0.0 Dialer1
> no ip http server
> no ip http secure-server
> !
> !
> !
> !
> dialer-list 1 protocol ip permit
> !
>
> line con 0
> line aux 0
> line vty 0 4
> access-class TELNETSSH in
> login authentication VTY
> transport input telnet ssh
> !
> no scheduler allocate
> end
>
> Interface IP-Address OK? Method Status Protocol
>
> Virtual-Access3 unassigned YES unset up down
> ATM0 unassigned YES manual up up
> ATM0.1 unassigned YES unset up up
> Dialer0 217.x.x.x YES manual up up


Well for starters you seem to have the wrong VPI/VCI.


You want something like these on the
ATM/dialer

interface ATM0
no ip address
no ip mroute-cache
no atm ilmi-keepalive
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
dsl operating-mode auto
!
!

interface Dialer1
description we.keep.note.of.address.here
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname hostname
ppp chap password 7 password


Even with a static IP we let it negotiate.

Obviously you need to define the ACL for NAT
or maybe you cut it out?

 
Reply With Quote
 
 
 
 
podzol podzol is offline
Junior Member
Join Date: Sep 2006
Posts: 2
 
      09-10-2006
Quote:
Originally Posted by (E-Mail Removed)
(E-Mail Removed) wrote:
> Hi
> I am trying to get a 1721 atm interface to work with BT and I am not
> having much luck....... all I am getting is the Vi3 protocol not coming
> up and a continuous debug about "PPP: Authorization NOT required"
>
> Here's the relavant bits of config any help gratfully received:
>
> Current configuration : 4378 bytes
> !
> version 12.2
> service timestamps debug datetime msec
> service timestamps log datetime msec
> service password-encryption
> !
> hostname hostname
> !
> logging queue-limit 100
> enable secret 5 password
> !
> username root password 7 password
> aaa new-model
> !
> !
> aaa authentication login VTY local-case
> aaa session-id common
> ip subnet-zero
> no ip source-route
> !
> !
> ip domain name .com
> !
> no ip bootp server
> ip inspect max-incomplete low 200
> ip inspect max-incomplete high 400
> ip inspect one-minute low 50
> ip inspect one-minute high 100
> ip inspect name OUTBOUNDTRAFFIC tcp
> ip inspect name OUTBOUNDTRAFFIC udp
> ip inspect name OUTBOUNDTRAFFIC ftp
> ip inspect name OUTBOUNDTRAFFIC icmp
> ip audit notify log
> ip audit po max-events 100
> !
> !
> !!
> interface ATM0
> ip address dhcp
> ip mtu 1500
> no atm ilmi-keepalive
> pvc 0/35
> encapsulation aal5mux ppp dialer
> dialer pool-member 1
> !
> dsl operating-mode auto
> !
> interface Ethernet0
> no ip address
> shutdown
> !
> interface FastEthernet0
> ip address 10.x.x.x 255.255.255.0
> ip nat inside
> speed auto
> !
> interface Dialer1
> ip address 217.x.x.x 255.255.255.248
> ip nat outside
> encapsulation ppp
> dialer pool 1
> dialer-group 1
> ppp authentication chap callout
> ppp chap hostname hostname
> ppp chap password 7 password
> !
> !
> ip nat inside source list NAT2 interface Dialer1 overload
> ip classless
> ip route 0.0.0.0 0.0.0.0 Dialer1
> no ip http server
> no ip http secure-server
> !
> !
> !
> !
> dialer-list 1 protocol ip permit
> !
>
> line con 0
> line aux 0
> line vty 0 4
> access-class TELNETSSH in
> login authentication VTY
> transport input telnet ssh
> !
> no scheduler allocate
> end
>
> Interface IP-Address OK? Method Status Protocol
>
> Virtual-Access3 unassigned YES unset up down
> ATM0 unassigned YES manual up up
> ATM0.1 unassigned YES unset up up
> Dialer0 217.x.x.x YES manual up up


Well for starters you seem to have the wrong VPI/VCI.


You want something like these on the
ATM/dialer

interface ATM0
no ip address
no ip mroute-cache
no atm ilmi-keepalive
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
dsl operating-mode auto
!
!

interface Dialer1
description we.keep.note.of.address.here
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname hostname
ppp chap password 7 password


Even with a static IP we let it negotiate.

Obviously you need to define the ACL for NAT
or maybe you cut it out?
Thanks for the help, you were spot on with the VPI/VCI but I can't understand why on a 2wire router/modem it was set to 0/35?????

Thanks again
 
Reply With Quote
 
andrew@millenniumstaff.co.uk
Guest
Posts: n/a
 
      09-11-2006

(E-Mail Removed) wrote:
> (E-Mail Removed) wrote:
> > Hi
> > I am trying to get a 1721 atm interface to work with BT and I am not
> > having much luck....... all I am getting is the Vi3 protocol not coming
> > up and a continuous debug about "PPP: Authorization NOT required"
> >
> > Here's the relavant bits of config any help gratfully received:
> >
> > Current configuration : 4378 bytes
> > !
> > version 12.2
> > service timestamps debug datetime msec
> > service timestamps log datetime msec
> > service password-encryption
> > !
> > hostname hostname
> > !
> > logging queue-limit 100
> > enable secret 5 password
> > !
> > username root password 7 password
> > aaa new-model
> > !
> > !
> > aaa authentication login VTY local-case
> > aaa session-id common
> > ip subnet-zero
> > no ip source-route
> > !
> > !
> > ip domain name .com
> > !
> > no ip bootp server
> > ip inspect max-incomplete low 200
> > ip inspect max-incomplete high 400
> > ip inspect one-minute low 50
> > ip inspect one-minute high 100
> > ip inspect name OUTBOUNDTRAFFIC tcp
> > ip inspect name OUTBOUNDTRAFFIC udp
> > ip inspect name OUTBOUNDTRAFFIC ftp
> > ip inspect name OUTBOUNDTRAFFIC icmp
> > ip audit notify log
> > ip audit po max-events 100
> > !
> > !
> > !!
> > interface ATM0
> > ip address dhcp
> > ip mtu 1500
> > no atm ilmi-keepalive
> > pvc 0/35
> > encapsulation aal5mux ppp dialer
> > dialer pool-member 1
> > !
> > dsl operating-mode auto
> > !
> > interface Ethernet0
> > no ip address
> > shutdown
> > !
> > interface FastEthernet0
> > ip address 10.x.x.x 255.255.255.0
> > ip nat inside
> > speed auto
> > !
> > interface Dialer1
> > ip address 217.x.x.x 255.255.255.248
> > ip nat outside
> > encapsulation ppp
> > dialer pool 1
> > dialer-group 1
> > ppp authentication chap callout
> > ppp chap hostname hostname
> > ppp chap password 7 password
> > !
> > !
> > ip nat inside source list NAT2 interface Dialer1 overload
> > ip classless
> > ip route 0.0.0.0 0.0.0.0 Dialer1
> > no ip http server
> > no ip http secure-server
> > !
> > !
> > !
> > !
> > dialer-list 1 protocol ip permit
> > !
> >
> > line con 0
> > line aux 0
> > line vty 0 4
> > access-class TELNETSSH in
> > login authentication VTY
> > transport input telnet ssh
> > !
> > no scheduler allocate
> > end
> >
> > Interface IP-Address OK? Method Status Protocol
> >
> > Virtual-Access3 unassigned YES unset up down
> > ATM0 unassigned YES manual up up
> > ATM0.1 unassigned YES unset up up
> > Dialer0 217.x.x.x YES manual up up

>
> Well for starters you seem to have the wrong VPI/VCI.
>
>
> You want something like these on the
> ATM/dialer
>
> interface ATM0
> no ip address
> no ip mroute-cache
> no atm ilmi-keepalive
> pvc 0/38
> encapsulation aal5mux ppp dialer
> dialer pool-member 1
> dsl operating-mode auto
> !
> !
>
> interface Dialer1
> description we.keep.note.of.address.here
> ip address negotiated
> ip nat outside
> ip virtual-reassembly
> encapsulation ppp
> dialer pool 1
> dialer-group 1
> no cdp enable
> ppp authentication chap callin
> ppp chap hostname hostname
> ppp chap password 7 password
>
>
> Even with a static IP we let it negotiate.
>
> Obviously you need to define the ACL for NAT
> or maybe you cut it out?


Thanks for help it was the VPI/VCI

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cisco 1721 ATM nightmare andrew@millenniumstaff.co.uk Cisco 0 09-08-2006 10:20 AM
Cisco 1721 ATM nightmare podzol Cisco 0 09-07-2006 03:33 PM
Differences between ATM STM-1 and ATM OC-3 hlep Cisco 0 08-09-2005 06:33 AM
QoS on Cisco 1721 woth ATM-interface Iskander Cisco 13 02-23-2005 10:03 PM
Difference in setting up ATM 0 or ATM 0.1 AM Cisco 0 02-08-2005 05:32 PM



Advertisments