Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > GRE, importance of IP address for tunnel interface

Reply
Thread Tools

GRE, importance of IP address for tunnel interface

 
 
Prasanna
Guest
Posts: n/a
 
      09-01-2006
Hi All,

Setup is as follows

Net1 Router Our glob network Router Net2
40.40.40.0/24 |Router1| 10.203.118.0/24 |Router2| 40.40.41.0/24

I was trying to establish a tunnel between Net1 to Net2
In Router2(Cisco) I need to give totally 3 addresses
Tunnel src=10.203.118.181 Tunnel.dst=10.203.118.182 and
tunnel.IP=40.40.41.12/24
If I give the tunnel Ip mentioned it gives error saying it overlaps
with the interface connected to Net2 network, obviously it overlaps,
but how to get out of this error? what IP I need to configure? What
sense it makes when we have already tunnel source and destination
addresses(because GRE needs only those two addresses)?

Earlier reply would really help.

Thanks and Regards,
Prasanna.

 
Reply With Quote
 
 
 
 
Bod43@hotmail.co.uk
Guest
Posts: n/a
 
      09-01-2006

Prasanna wrote:
> Hi All,
>
> Setup is as follows
>
> Net1 Router Our glob network Router Net2
> 40.40.40.0/24 |Router1| 10.203.118.0/24 |Router2| 40.40.41.0/24
>
> I was trying to establish a tunnel between Net1 to Net2
> In Router2(Cisco) I need to give totally 3 addresses
> Tunnel src=10.203.118.181 Tunnel.dst=10.203.118.182 and
> tunnel.IP=40.40.41.12/24
> If I give the tunnel Ip mentioned it gives error saying it overlaps
> with the interface connected to Net2 network, obviously it overlaps,
> but how to get out of this error? what IP I need to configure? What
> sense it makes when we have already tunnel source and destination
> addresses(because GRE needs only those two addresses)?
>
> Earlier reply would really help.


A tunnel /creates/ a new interface and it needs an address.
You also need to specify the tunnel soure and destination
addresses so that the tunnel (GRE) traffic can flow.

You can typically use /any/ addresses for the tunnel
interfaces themselves as long as there is no conflict
with existing addresses in your net.


Router1#
interface Tunnel200
ip address 192.168.3.133 255.255.255.252
tunnel source FastEthernet0/0
tunnel destination 7.24.241.226

interface FastEthernet0/0
description Internet Facing Link
ip address 8.50.7.34 255.255.255.224


Router2#
interface Tunnel2
ip address 192.168.3.134 255.255.255.252
tunnel source BVI1
tunnel destination 8.50.7.34

interface BVI1
description Internet Facing Link
ip address 7.24.241.226 255.255.255.0


I find this quite confusing, draw pictures.

 
Reply With Quote
 
 
 
 
Prasanna
Guest
Posts: n/a
 
      09-04-2006
Thanks Bod,

I have found the answer in other way

Router1(Proprietary):
interface Tunnel1
Source:10.203.118.181 destination: 10.203.118.182
Route entry:
40.40.41.0/24 tunnel1

Interface1 ethernet
ip address 40.40.40.1 255.255.255.0

Interface2
ip address 10.203.118.181 255.255.255.0

Router2(cisco)#
interface Tunnel1
ip address 40.40.40.12 255.255.255.0
tunnel source FastEthernet0/0
tunnel destination 10.203.118.181

interface FastEthernet0/0
description Internet Facing Link
ip address 10.203.118.182 255.255.255.0

interface FastEthernet0/1
ip address 40.40.41.1 255.255.255.0



In Cisco whatever the address we configure that subnet packets are
directed to that tunnel. Eg. If we configure tunnel ip address as
40.40.40.13 255.255.255.0 then route entry 40.40.40.0 255.255.255.0
tunnel1, will be created in the routing table dynamically.
Thats why it was not allowing to assign IP address falling in any
subnet of the existing interfaces.
After configuring IP address which falls in destination network, it
started working.

Regards,
Prasanna.

 
Reply With Quote
 
slyubski slyubski is offline
Junior Member
Join Date: Jan 2009
Posts: 1
 
      01-31-2009
Quote:
Originally Posted by Prasanna
Thanks Bod,

I have found the answer in other way

Router1(Proprietary):
interface Tunnel1
Source:10.203.118.181 destination: 10.203.118.182


Interface1 ethernet
ip address 40.40.40.1 255.255.255.0

Interface2
ip address 10.203.118.181 255.255.255.0

Router2(cisco)#
interface Tunnel1
ip address 40.40.40.12 255.255.255.0
tunnel source FastEthernet0/0
tunnel destination 10.203.118.181

interface FastEthernet0/0
description Internet Facing Link
ip address 10.203.118.182 255.255.255.0

interface FastEthernet0/1
ip address 40.40.41.1 255.255.255.0



In Cisco whatever the address we configure that subnet packets are
directed to that tunnel. Eg. If we configure tunnel ip address as
40.40.40.13 255.255.255.0 then route entry 40.40.40.0 255.255.255.0
tunnel1, will be created in the routing table dynamically.
Thats why it was not allowing to assign IP address falling in any
subnet of the existing interfaces.
After configuring IP address which falls in destination network, it
started working.

Regards,
Prasanna.
Hi Prasanna.
I am trying to understand how tunnel works.
Let me ask few questions.

1. Why in your successful setup you don't
assign IP adress to tunnel interface?

2. Route entry:
40.40.41.0/24 tunnel

Where this route entry came from.?
When it showed up in the routing table for the first time?
Could you please post what isexact format of your NEW routing
tables entries on both routers.


Thanks.
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GRE Tunnel up/up Cannot ping tunnel interface tsvanduyn@yahoo.com Cisco 6 03-09-2006 01:33 AM
Split Tunnel Blocks http through tunnel but passes http around tunnel a.nonny mouse Cisco 2 09-19-2004 12:10 AM
Problem with Ip address of a Tunnel interface Davide Cisco 0 04-01-2004 08:01 AM
Problem with Ip address of a Tunnel interface Davide Cisco 0 04-01-2004 08:01 AM
Termination of an IPSec VPN tunnel and a GRE Tunnel on one physical interface. John Ireland Cisco 1 11-11-2003 04:47 PM



Advertisments